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checkSTRESS™ 
(for AutoPlant / CATIA / SmartPlant 3D / AutoCAD Plant 3D / PCF)  

Introduction 

Under the “checkSTRESS” brand name, three products are available namely checkSTRESS (which generates 

only CAEPIPE input file), checkSTRESS II (which generates input files for both CAEPIPE and CAESAR II) and 

checkSTRESS Nuke (which generates input files for both CAEPIPE and PIPESTRESS). 

The following table lists the checkSTRESS products currently available for different 3D Plant Design systems. 

Sl. No. 3D Plant Design System Product Name Status 

1 PDMS checkSTRESS Available 

2 PDMS checkSTRESS II Available 

3 PDMS checkSTRESS Nuke Available 

4 CADMATIC checkSTRESS Available 

5 CADMATIC checkSTRESS II Available 

6 CADMATIC checkSTRESS Nuke Available 

7 PDS checkSTRESS Available 

8 PDS checkSTRESS II Available 

9 PDS checkSTRESS Nuke Available 

10 PCF checkSTRESS Available 

11 PCF checkSTRESS II Available 

12 PCF checkSTRESS Nuke Available 

This document describes the common features of checkSTRESS products currently available for those 3D Plant 

Design systems (such as AutoPLANT, CATIA, SmartPlant 3D, SolidEdge, etc.) that generate .pcf files from their 

respective database. 

Details related to the generation of CAESAR II input files by checkSTRESS II and PIPESTRESS input files by 

checkSTRESS Nuke are covered in a separate document titled “CIIModel.pdf” and “PSModel.pdf” respectively.  
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Installing Program  

To install checkSTRESS on Windows OS, download the product from the website and execute the followings 

steps:  

1 Run the program "Setup.exe" and follow the instructions as they appear on the screen. 

2 Define an environmental variable with name “checkSTRESS_PCF” and the value as checkSTRESS 

Installation path.  

For example, set the value as “C:\Progra~1\checkSTRESSNukePCF (assuming checkSTRESS is installed 

in the directory “C:\Program Files\checkSTRESSNukePCF). 

Note: 

Use only short names while defining the Environmental variable and do not use ‘space’ or ‘special 

characters’ while defining the absolute path. 

How to use checkSTRESS? 

1 Select the PCF file(s). Use “shift” key for selecting multiple PCF files. checkSTRESS combines the PCF files 

in to one stress analysis model, when multiple files are selected. 

2 Specify the name of the output file. 

 

3 Select the piping code to be used for the analysis from the list box. 
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4 Enter the Starting Node number and Node increment value in the appropriate field by selecting the option 

“Rearrange Node Numbers”. By default, the Starting Node number and Node increment are set to 10 and 10 

respectively. 

5 Enter the Specific Gravity of fluid with respect to water. By default the specific gravity is set to 1.0. 

6 Select Default Hanger to be used in checkSTRESS. This selected Hanger type will be used in 

checkSTRESS, only when the hanger type in checkSTRESS corresponding to Plant Design hanger is not 

specified /available in the Mapping DB. For details on transferring support from Plant Design to 

checkSTRESS, refer Appendix D of checkSTRESS User’s manual (checkSTRESS.pdf). 

7 Specify the Starting Node number for processing network. This is set to 10 by default.  If the user is not sure 

about the node number, then this can be left as 10 or enter as 0. 

8 If the user wishes to eliminate those elements whose Nominal size (NS) is less than 50mm / 2in, then they 

can specify the value as “50/2” in the field “Process elements, if dia >”. In other words, the program will 

process only those elements whose nominal size is greater than the value specified in the field above. 

9 Specify how the Flange to be transferred to checkSTRESS.  

10 Specify how the 3 Way and 4 Way Valves are to be transferred to checkSTRESS.  

11 Choose the Global Vertical Axis for checkSTRESS from the Vertical Direction option. By default, “Z Axis” 

shall be taken as Global Vertical Axis. 

12 Press the button “Apply” to perform the Stress Check. 

   

13 Response Spectrum load data can be added through Edit Layout > Misc > Response Spectrum. Once 

added, the same can be applied in stress model through Edit Layout > Loads > Spectrum. See Appendix A 

for details on adding Spectrum. 
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14 Figure above shows the stress contour plot for the Sustained case. Expansion Stress plot and Occasional 

Stress plot can be seen by selecting the option “Expansion Stress” and “Occasional Stress” respectively as 

shown in the figure right above. 

15 Designers can also plot and view the deflected shapes of the piping system under different loading 

conditions using the options available in the heading titled “Deflected Shape” as shown in the figure on the 

right above. 

16 Designers can review the Nozzle / Anchor Qualification using the Option “Show Summary”. 

17 Hanger selected by checkSTRESS for “to be designed” hangers can be viewed by selecting the option 

“Show Hanger Report”. 

18 Designers can generate the CAEPIPE mod file using the option “Edit Layout > File > Save or Save as” for 

the Stress Department to carry out the detailed analysis including stress report preparation. 

19 Similarly, in order for the Stress Department to carry out the detailed analysis including stress report 

preparation, designers can generate CAESAR II input files in checkSTRESS II product and PIPESTRESS 

input files in checkSTRESS Nuke product respectively, by selecting the appropriate option from the dialog 

box as shown above. 

20 Using the option “Print”, designers can print the model data, code compliance for ten (10) high stress nodes, 

Nozzle / Anchor Qualification and Status of Resting Support / Limit Stops. 

Limitations 

The following are not transferred to checkSTRESS from Plant Design database at this time. However user can 

add these in checkSTRESS through Edit Layout >Misc >Section 

1 Insulation density and Insulation thickness.  

2 Corrosion allowance and Mill tolerance. 

3 Lining Density and Lining Thickness.  

Reference 

Units 

Piping system from PCF will be transferred to checkSTRESS in SI units when the attribute “UNITS-CO-ORDS” 

is defined as “MM” in PCF. Otherwise, the piping system will be transferred to checkSTRESS in ENGLISH units. 

Loads 

Temperature for the piping system is read from “PIPELINE-TEMP” attribute of Pipeline Header information 

(PIPELINE-REFERENCE attribute) in PCF and will be transferred to checkSTRESS, if available. If not available 

in PCF, then the Temperature for the piping system will be transferred as 21 deg C / 70 deg F for SI / English 

units. 

Pressure for the piping system is not available in PCF and hence the same will be transferred as 0 to 

checkSTRESS. 
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User can add / modify the Temperature and Pressure for the Piping System through Edit Layout->Misc->Loads 

Note: Program will assume that the value of the attribute “PIPELINE-TEMP” available in PCF as deg.F, if 

the “UNITS-CO-ORDS” attribute is defined as “ENGLISH” in PCF. On the other hand, the program will 

assume that the value of the attribute “PIPELINE-TEMP” available in PCF as deg.C, if the “UNITS-CO-

ORDS” attribute is defined as “MM” or “MM-HUNDREDTH” in PCF. 

Fluid Density 

Specific Gravity of the fluid (with respect to water) entered in the form as shown above will be used by 

checkSTRESS for calculating the fluid weight in the piping system. 

Weight 

The weights of Valves, Instruments, Flanges, etc. are read from “WEIGHT” attribute of component data from 

PCF and will be transferred to checkSTRESS, if available. If not available, then the weight will be transferred as 

0.0 to checkSTRESS. 

User can add / modify the weight of components through Edit Layout->Window->List. 

Wall Thickness 

Wall thicknesses of the Piping components are not available in PCF for different components. Hence, a 

Mapping DB is configured outside PCF to transfer the Wall Thickness information to checkSTRESS properly. 

Refer Appendix C of checkSTRESS User’s Manual (checkstress.pdf) for details. 

User can modify the Wall thickness of the piping components through Edit Layout->Misc->Section. 

OD and Nominal Size 

Nominal size of a component is read from END_POINT attribute of PCF. OD of the piping component is not 

available in PCF. Hence, OD corresponding to component Nominal size is extracted from the Mapping DB 

configured outside PCF to transfer the same to checkSTRESS. Refer Appendix C of checkSTRESS User’s 

Manual (checkstress.pdf) for details. 

User can modify the OD and Nominal size of the piping components through Edit Layout->Misc->Section. 

Boundary Conditions 

The present version of the checkSTRESS (for PCF) will “Anchor” all the free ends irrespective of whether they 

are connected to Equipment Nozzle or other Pipelines as the details of pipeline connections are not available in 

PCF file at this time. 

User can add / modify supports in piping system through Edit Layout->Misc->Data Types 

Supports 

Support details including their locations will be transferred to checkSTRESS as follows. 

 Checks for attribute “SUPPORT” in PCF. 

 If the attribute “SUPPORT” is defined in PCF, then reads the attribute “CO-ORDS” to locate the support 

in the specified coordinate.  
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 Reads the support type information from the attribute “SKEY” (if available) and generates the equivalent 

support type in checkSTRESS by reading the Mapping DB (SupportType.mdb available with the 

product) when the option “Transfer Support using MDB” is selected from the dialog shown above. User 

can also customize and transfer support information along with stiffnesses, gap and friction by selecting 

the option “Transfer Support without using MDB”. Refer Appendix D and Appendix E of checkSTRESS 

User’s Manual for details. 

 If the attribute “SKEY” is not defined / available, then the support type will be transferred as “Hanger” 

with Hanger Type as specified in “Default Hanger to be used” option. 

User can add / modify supports in piping system through Edit Layout->Misc->Data Types 

Material 

Material description entered at attribute “ITEM-CODE” will be read and the material property is then obtained 

from the intermediate mapping db. The material property thus obtained will be transferred to checkSTRESS. 

Refer Appendix B of checkSTRESS User’s Manual for details. 

User can add / modify the Material properties in checkSTRESS through Edit Layout->Misc->Materials. 

Thermal Anchor Movement (TAM) 

Thermal Anchor Movement (TAM) values entered at attribute “ATTRIBUTE1” under “END-CONNECTION-

EQUIPMENT” of PCF file in the format “X Y Z” in global X, Y and Z directions respectively will be transferred to 

checkSTRESS if available. These values should be defined in “mm” for SI units and in “Inch” for English units. 

If TAM is not available in PCF file, then user can also add / modify the TAM values through Edit Layout option. 

i.e., Click Edit Layout then select “Anchor” and select “Edit data” through Layout > Edit. From the dialog box 

shown, click on “Specified Displacement” and enter the TAM values. 

User defined Equipment Nozzle Allowable Loads 

Equipment Nozzle Allowable Loads (forces and moments) provided by the equipment manufacturer or 

calculated using Applicable codes / Finite Element Methods entered at attribute “ATTRIBUTE2” under “END-

CONNECTION-EQUIPMENT” of PCF file in the format FX, FY, FZ, MX, MY and MZ will be transferred to 

checkSTRESS. These values should be separated using a BLANK space. Please note, the force values should 

be entered in “lb” for English units and in “N” for SI units. Similarly, the moment values should be entered in “ft-

lb” for English units and in “Nm” for SI units. 

If the Equipment Nozzle Allowable Loads not available in the PCF then user can add these values through Edit 

Layout > Misc > User Allowables. 

The allowable thus defined/transferred are compared against calculated loads and shown / printed in Support 

Load Summary outputs (can be viewed / printed through “Show Summary” option). If the calculated loads 

exceed the allowable, they are highlighted in red.  
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PCF to checkSTRESS component Mapping 

The types of components available in PCF are simulated as tabulated below in checkSTRESS. 

Component identifier in PCF Component in checkSTRESS 

PIPE Pipe 

GASKET Pipe 

UNION Pipe 

CONNECTOR Rigid Element 

CAP Rigid Element 

FILTER Rigid Element 

INSTRUMENT Rigid Element 

INSTRUMENT with SKEY BLEW** Bellow** 

INSTRUMENT-ANGLE Rigid Element 

MISC-COMPONENT Rigid Element 

MISC-COMPONENT-ANGLE Rigid Element 

MISC-HYGENIC Rigid Element 

SAFETY-DISC Rigid Element 

TRAP Rigid Element 

TRAP-ANGLE Rigid Element 

VALVE-ANGLE Rigid Element 

REDUCER-CONCENTRIC Reducer 

COUPLING Reducer 

REDUCER-ECCENTRIC Reducer 

FILTER-OFFSET Reducer 

INSTRUMENT-OFFSET Reducer 

MISC-COMPONENT-OFFSET Reducer 

TRAP-OFFSET Reducer 
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Component identifier in PCF Component in checkSTRESS 

CROSS 
Four Rigid Elements or Four Pipes with 

Concentrated Mass 

VALVE-3WAY 
Three Rigid Elements or Three Pipes 

with Concentrated Mass 

INSTRUMENT-3WAY 
Three Rigid Elements or Three Pipes 

with Concentrated Mass  

VALVE-4WAY 
Four Rigid Elements or Four Pipes with 

Concentrated Mass 

INSTRUMENT-4WAY 
Four Rigid Elements or Four Pipes with 

Concentrated Mass 

SUPPORT HANGER (by default) 

FLANGE Flange 

LAPJOINT-RING Flange 

LAPJOINT-STUBEND Flange 

TEE 
Pipe(s) with Branch SIF (Welding TEE) 

or (Weldolet) 

ELBO-TEED 
Pipe(s) with Branch SIF (Welding TEE) 

or (Weldolet) 

INSTRUMENT-TEE 
Pipe(s) with Branch SIF (Welding TEE) 

or (Weldolet) 

REDUCER-CONCENTRIC-TEED 
Pipe(s) with Branch SIF (Welding TEE) 

or (Weldolet) 

Y-PIECE-FITTING 
Pipe(s) with Branch SIF (Welding TEE) 

or (Weldolet) 

ELBOW Bend 

FILTER-ANGLE Bend 

** Valid and available for checkSTRESS PCF, checkSTRESS II PCF & checkSTRESS Nuke PCF Version 9.40 

or later, CAEPIPE 3D+ for PCF Version 10.50 or later, AutoPlant to CAEPIPE, CATIA to CAEPIPE and PCF to 

CAEPIPE version 9.30 or later. 
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Appendix A 

Response Spectrum 
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.Spectrums. 

A (uniform response) spectrum is a table of maximum response versus natural frequency for a specific 
excitation in single degree-of-freedom systems. You can input spectrums in three ways: 

1. Input spectrums directly into the model.  

2. Create a spectrum library and load spectrums from it.  

3. Input spectrums from a text file.  

When you use the first two methods, you may use menu Options > Spectrum command to set the 
different units for the X- and the Y-axes, and also choose the interpolation method. 

 

1. Input spectrums directly into the model 

Select Spectrums from the Misc menu. You are shown the List window for spectrums. Start typing pairs of 
values into it. The frequencies or periods do not have to be in any order; checkSTRESS will sort them 
later. You can input as many pairs of values as required. 
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2. Input spectrums from a text file 

This method involves creating a separate text file (in the format shown below) for each spectrum you want 
to input. The steps are given below. 

a) For each spectrum, on the first line, type the Name of the spectrum (up to 31 chars).  On the 
second line, type units for Abscissa (X-axis) and Ordinate (Y-axis) axes, separated by a space.  

b) After these two lines, on each line, you can input a value pair. You can input as many of these 
value pair lines as required.  

c) Each spectrum should be saved to a separate text file. More than one spectrum should not be 
input in one text file as it cannot be read into checkSTRESS.  

d) Now, open the checkSTRESS model that needs these spectrums. Select Read Spectrum from 
the File menu, read all text files you created one after the other.  

 

The format of a spectrum text file is shown below. The spectrum that is read appears on the row where 
the yellow highlight is placed (under the Name column). You can use the Edit menu commands to insert 
an empty row or delete an existing spectrum. Ensure that no two spectrums share the same Name. 
checkSTRESS issues a warning should such occur. 

The spectrum text file should be in the following format: 

Name  (up to 31 characters 

Abscissa units Ordinate units 

Abscissa value1 Ordinate value1 

Abscissa value2 Ordinate value2 

. . 

. . 

. . 

Where  

Abscissa units 0 = Frequency (Hz) 

 1 = Period (Sec) 

 

Ordinate units 0 = Displacement (inch) 

 1 = Displacement (mm) 

 2 = Acceleration (in/sec2) 

 3 = Acceleration (mm/sec2) 

 4 = Acceleration (g’s) 
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Example file 

Test Spectrum 

0 2 

1 190 

2 220 

3 250 

4 1932 

5 1000 

6 1800 

. . 

. . 

Analysis note: 

While analyzing the response spectrum case, when a mode (frequency or period) falls outside the spectrum 
table, checkSTRESS issues a warning and uses the value corresponding to the closest frequency or period 
in the spectrum table (for example, checkSTRESS uses the value corresponding to the lowest frequency if 
the calculated frequency is lower than the lowest in the spectrum table or uses the value corresponding to 
the highest frequency if the calculated frequency is higher than the highest in the spectrum table). 

Once you are done inputting the different spectrums using any one of the three methods, you need to 
input the Spectrum load itself under the menu Loads > Spectrum in the Layout window.  Details on 
inputting the Spectrum Load are provided earlier under the Loads menu. 

  


