checkSTRESS™
(for AVEVA’s E3D/PDMS)

Introduction

Under the “checkSTRESS” brand name, three products are available namely checkSTRESS (which
generates only CAEPIPE input file), checkSTRESS Il (which generates input files for both CAEPIPE and
CAESAR 1) and checkSTRESS Nuke (which generates input files for both CAEPIPE and PIPESTRESS).

The following table lists the checkSTRESS products currently available for different 3D Plant Design

Systems.

Sl. No | 3D Plant Design System | Product Name Status

1 E3D/PDMS checkSTRESS Available
2 E3D/PDMS checkSTRESS Il Available
3 E3D/PDMS checkSTRESS Nuke Available
4 CADMATIC checkSTRESS Available
5 CADMATIC checkSTRESS I Available
6 CADMATIC checkSTRESS Nuke Available
7 PDS checkSTRESS Available
8 PDS checkSTRESS I Available
9 PDS checkSTRESS Nuke Available
10 PCF checkSTRESS Available
11 PCF checkSTRESS I Available
12 PCF checkSTRESS Nuke Available

This document describes the common features of checkSTRESS product(s) currently available for
E3D/PDMS. Details related to the generation of CAESAR Il input files by checkSTRESS Il and
PIPESTRESS input files by checkSTRESS Nuke are covered in a separate document titled “ClIModel.pdf”
and “PSModel.pdf’ respectively.




Installing Program
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To install checkSTRESS (for E3D/PDMS) on Windows OS, download the program from the website and
execute the followings steps:

Run the program "Setup.exe" and follow the instructions as they appear on the screen.

Add the path of the installed directory to the "pmllib" path of the E3D/PDMS.

For example SET PMLLIB=C:\Progra~1\SST_Systems\checkSTRESSPDMS %1\pmllib (assuming
checkSTRESS is installed in the directory C:\Program Files\SST_Systems\checkSTRESSPDMS).

Note: For the program to work properly, avoid using space or special characters while entering the path
or file name.

Define an environmental variable with name as “checkSTRESS PDMS” and the value as checkSTRESS
Installation path.

For example, set the value as “C:\Progra~1\SST_Systems\checkSTRESSPDMS” (assuming that the
product is installed in the directory “C:\ProgramFiles\SST_Systems\checkSTRESSPDMS).

The environment variables required by E3D/PDMS are also required for checkSTRESSPDMS. The
E3D/PDMS environment must exist as outlined in the appropriate E3D/PDMS Installation Guide.

Load E3D/PDMS and enter the Lexicon Module as a user who has Read-Write access to DICT Database and
run the datal file checkSTRESS.DAT, to create the UDA: SUPCODE for ATTA elements, UDA :NX, :NY, :NZ
and :NAL for Nozzle elements, UDA: :HNX, :HNY, :HNZ, :TNX, :TNY, :TNZ, :HNAL and :TNAL for Branch
elements.

How to use checkSTRESS?
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Add the ZONE/PIPES/BRANCHES need to be checked for stress using “Add CE” or CE Members”
button.

Branches selected for transfer need to be checked for the following.
e TEMP, PRES attributes of the BRAN element

Each branch should have avalid PH OD

e Each branch in the network should have a valid HSTU

e Each branch should have a component

e |t is recommended to perform “DATA CONSISTENCY CHECK” for all Pipes/Branches selected for
transfer.

For transferring the support details, ATTA’s have to be created at support locations and the UDA
(:SUPCODE) should be set a value as given in the field #1 (i.e., “PdSupport” ) of the access db
“SupportType.mdb”.

To use checkSTRESS (for E3D/PDMS), type “show !!checkSTRESS” on the command line of
E3D/PDMS Design Module. The following form appears,

2



checkSTRESS EEX]

File Mame Y P Db K S TempO
Input Units used in Project while entering

Pressure Bar w | Temperature Celzius w | ieight | Kilogram L
Ahalysis Code B31.1 w
Default Hanoer Desidn Grinnell w
Transfer Model in SI Units w
Specific Gravity 1
Starting Mode number 10
Mode Mumber Incremert 10
Process elements if diais = 1] T
Identify Support AT TA's with ATTYPE SUPP

Wertical Axis Transfer Jway and dway Walve as

() Direction {(¥) Rigid Elements

@ Z Direction {:} Pipes with Concentrated Mass

Tranzfer Supports Tranzfer Flange as

(¥} Using MDE (¥} Pipe with Flange

) without Using MDE ) Rigid Element

Boundary Condition
'@' Anchor Ends if connected o Mozzle

O Anchor all Free ends

My
SITE STABILIZER
ZOME  PIPES
PIPE  100-B-1
ERAN > 100-5.1-61
GASK 1

Specify/Change the Name of the file if you wish. Do not leave a blank space while giving the file

name / path. Program checks and generates error, if finds a space in the file name / path.

Select the Input units used in Project while entering “Pressure”, “Temperatures” and “Weight”
using the options as shown in the figure above. Please note, selecting wrong input units used in

project will results in incorrect output.




Select the piping code to be used for the analysis of the model from the list box.
Enter/modify the Static Seismic g’s. Available only for checkSTRESS Nuke.

Enter the Starting Node number and Node increment value in the appropriate field. By default,

the Starting Node number and Node increment are set to 10 and 10 respectively.

Enter the Specific Gravity of operating fluid with respect to water. By default the specific gravity

is set to 1.0.

Select Default Hanger to be used in checkSTRESS model. This Hanger type will be used only
when the hanger type in checkSTRESS corresponding to Plant Design hanger is not specified
/available in the Mapping DB. For details on transferring support from Plant Design to
checkSTRESS, refer Appendix D of checkSTRESS User’s manual (checkSTRESS. pdf).

When the “Identify Support ATTA’s with ATTYPE attribute set as” is entered with a Keyword,

then it will transfer support locations and its information from E3D/PDMS, only when the attribute
“‘“ATTYPE” is filled with the string that matches the Keyword entered in the form. On the other
hand, leaving this text box empty (unfilled) will transfer all the ATTA from the E3D/PDMS for the
selected Pipes/Branches without checking its “ATTYPE” attribute. For example, if the Keyword is
specified as “SUPP” then the program will include ATTA’s for transfer, only when the ATTYPE

attribute is filled with the same Keyword “SUPP”, otherwise, it excludes them from transfer.
Select the units to be used for the checkSTRESS model.

Selecting the option “SI Units” transfers the Pipes/Branches details in Sl units i.e. Length related
dimensions such as OD, Nominal Size etc in mm, Temperature in Deg C, Pressure in bar,
Weight in Kg, Density in Kg/m3, Translational Stiffness in N/mm, Rotational stiffness in N-m/deg

to the neutral file.

Similarly Selecting the option “ENGLISH Units” transfers Pipes/Branches details in ENGLISH
units i.e. Length related dimensions such as OD, Nominal Size etc in Inch, Temperature in Deg
F, Pressure in psi, Weight in Ib, Density in Ib/in3, Translational Stiffness in Ib/in, Rotational

Stiffness in Ib-in/deg to the neutral file.

Select the Boundary Conditions to be used from the form shown above. Refer the section titled

“Reference” for details.

If the user wishes to eliminate those elements whose Nominal size (NS) is less than 50mm / 2in,
then they can specify the value as “50” for SI Units and “2” for English Units in the field “Process
elements, if dia >”. In other words, the program will process only those elements whose nominal

size is greater than the value specified in the field above.

Specify how the 3 Way and 4 Way Valves to be transferred to checkSTRESS. Refer the section
titled “Reference” for details.




Navigate to the required ZONE/PIPE/BRANCH through the member list as shown in the figure
above.

Press the button “Add CE” to include and to perform the Stress Check for the selected
ZONE/PIPE/BRANCH.

User can also use the button “CE Members” to include all the members of SITE/ZONE/PIPE and
then exclude a few members using the “Remove” button if required. For example, if you wish to
add 8 PIPES out of 10 PIPES under a particular ZONE, navigate to the ZONE and press the
button “CE Members”. Highlight the PIPE (one at a time) in the included list and press the button

“Remove” to exclude them.

Choose the Global Vertical Axis for checkSTRESS model from the vertical Axis option. By
default, “Z Axis” shall be taken as Global Vertical Axis if not specified.

Note: Since E3D/PDMS always uses vertical global axis as “Z” and Stress Engineers from
different parts of the world use different coordinate systems, it is recommended that the
designers should consult with the stress department and choose the “Vertical Global
Axis” before saving the stress model in CAEPIPE/CAESAR Il format (for Stress
department to carry out the detailed analysis). On the other hand, for performing the first
level stress check using checkSTRESS, designers shall continue to use “Z” as Global

Vertical AXxis.

Press the button “Apply” to perform the Stress Check.

FH checkSTRESS Nuke : SL/ SH - Code: B31.1(2014) - [C:\Temp\Model-01.res (] - [m] X

First-Level Checks
File View Options Window Help

S R ati
Q@\Q ) tress Ratios

Code: B31.9(2020)

(+ Sustained Stress [Weight + Max. Pressure}

" Ewxpansion Stress (Max. Thermal Range)

Show

" Sustained Deflected Shape [Weight + Max. Pressure)
™ Expansion Deflected Shape [Thermal T1 - Tref]

" Operating Deflected Shape (W + P1 + T1)

Nazzle / Anchor Qualification| — Hanger Report

" Show Summary " Show Hanger Report

Status of Resting Supports / Limit Stops

Modal Analysis
o~ Export Model to PIPESTRESS ‘

Edit Layout ‘ ‘ E it |




5 Response Spectrum load data can be added through Edit Layout > Misc > Response Spectrum. Once
added, the same can be applied in stress model through Edit Layout > Loads > Spectrum. Refer to
Appendix B for details on adding Spectrum.

6 Figure above shows the stress contour plot for the Expansion case. Sustained Stress plot can be seen
by selecting the option “Sustained Stress (Weight + Pressure)” as shown in the figure right above.

7 Designers can also plot and view the deflected shapes of the piping system under different loading
conditions using the options available in the heading titled “Deflected Shape” as shown in the figure on
the right above.

8 Designers can review the Nozzle / Anchor Qualification using the Option “Show Summary”.

9 Hanger selected by checkSTRESS for “to be designed” hangers can be viewed by selecting the option
“Show Hanger Report”.

10 Designers can generate the CAEPIPE mod file using the option “Edit Layout > File > Save or Save as”
for the Stress Department to carry out the detailed analysis including stress report preparation.

11 Similarly, in order for the Stress Department to carry out the detailed analysis including stress report
preparation, designers can generate CAESAR Il input files in checkSTRESS Il product and
PIPESTRESS input files in checkSTRESS Nuke product respectively, by selecting the appropriate option

from the dialog box as shown above.

12 Using the option “Print”, designers can print the model data, code compliance for ten (10) high stress

nodes, Nozzle / Anchor Qualification and Status of Resting Support / Limit Stops.

Limitations

The following are not transferred to checkSTRESS from E3D/PDMS at this time. However user can add
these in checkSTRESS through Edit Layout->Misc->Section

1 Corrosion allowance and Mill tolerance.

2 Lining Density and Lining Thickness.

Reference

Loads

Temperature and Pressure values entered at Pipe/Branch level via TEMP and PRES attribute shall be
transferred to checkSTRESS. Hence, user should fill these attributes with appropriate values depending
upon the Units of transfer. l.e., If you wish to transfer the model in Sl units, then the value entered for
Temperature and Pressure should be in Deg C and kg/cm2 respectively. On the other hand, if you wish to
transfer the model in English Units, then the Temperature and Pressure values shall be entered in Deg F and
psi respectively.

User can also add / modify the Temperature and Pressure values in checkSTRESS through Edit Layout-

>Misc->Loads.




Fluid Density
Even though the provision is available in E3D/PDMS Propcon Database to enter the Fluid density, most of
the users do not use such facility. Hence, provision is given to specify the Specific Gravity of the fluid (with

respect to water) during the transfer of the model.

Weight

The weights of Valves, Instruments, Flanges, etc. are extracted from the Propcon Database through the
“Cweight” attribute. If defined/available in the Propcon Database, the program extracts the information and
transfer to checkSTRESS. Care should be taken while filling the “Cweight” attribute in Propcon. i.e., the

values should be specified in Kg / Ib, to transfer the same in Sl / English units respectively.

User can add / modify the weight of components by selecting the component type such as Valve, Rigid,
Flange, etc. through Edit Layout->Window->List.

Wall Thickness

Since the Wall thickness of the Piping components is generally not available in E3D/PDMS, they are set to
0.0 by default. However, user can transfer the Wall Thickness information to checkSTRESS properly from
E3D/PDMS (if they are specified) by modifying the variables defined in the program. Refer Appendix A for
details on modifying the program to extract Wall Thickness from E3D/PDMS.

User can also specify wall thickness of piping components through Mapping DB (Code.mdb) supplied along
with the project. For details refer to Appendix C of checkSTRESS User’'s Manual (checkSTRESS. pdf).

In addition to the above options, user can also modify the Wall thickness of the piping components directly in
checkSTRESS through Edit Layout->Misc->Section.

OD and Nominal Size

OD and Nominal Size are extracted from the Paragon Database of E3D/PDMS. For reducers, the arrive OD
and Thickness shall be transferred to OD1 and Thk1 of the element in checkSTRESS and the leave OD and
Thickness shall be transferred as OD2 and Thk2 of the element in checkSTRESS.

User can also modify the OD and Nominal size of the piping components directly in checkSTRESS through

Edit Layout->Misc->Section.

Boundary Conditions

Selecting the option “Anchor end if connected to Nozzle or Pipelines” will Anchor the Pipe Ends only when
they are connected to a Nozzle or Pipelines, otherwise it leaves them as Free. On the other hand, if one end
of the pipe is connected to a Nozzle and the other end of Pipe is connected to a Branch and if that Branch is

not included as the part of the Stress model, then the program will anchor both the end automatically.

For more clarity, consider the following examples. If one end of the pipe is connected to a Pump Nozzle and
the other end is not connected to any Nozzle or Pipeline, then the program will anchor the first end and leave

the other end as free (i.e., do not create any support). On the other hand, if one end of the pipe is connected




to a Nozzle and the other end is connected to a Branch and that Branch is not included in the Stress model,
then the program will anchor both the ends automatically.

Similarly selecting the option “Anchor all Free Ends” will “Anchor” all the ends of the Branches automatically

irrespective of whether they are connected to Nozzle or Pipelines.

In addition to the above, user can also add / modify supports in piping system in checkSTRESS directly

through Edit Layout->Misc->Data Types.

Supports

Supports locations and its information are included for transfer from E3D/PDMS when the following
conditions are met.

Step 1: Include/Exclude ATTA'’s for Transfer

Define ATTA and fill the attribute “ATTYPE” with an appropriate Keyword. Use the same Keyword in the text
box “Identify Support ATTA’s with ATTYPE attribute set as” (as shown in figure above). Mismatching of

Keywords will exclude the ATTA’s from transfer (or) fill the attribute “ATTYPE” with an appropriate Keyword
and leave the text box “Identify Support ATTA’s with ATTYPE attribute set as” empty (unfilled) to include all
ATTA’s for Transfer.

Step 2: Transfer Support Details
The program performs the following for transferring the support details to checkSTRESS.

e Checks for user defined attribute (UDA) “*SUPCODE”. If available, then reads the details of support
from this attribute and write them to the neutral file.

o If not available, then checks for user defined attribute “:KPSUPCODE”. If available, then read the
details from this attribute and transfer to checkSTRESS. Please note, this feature is included for
users who had used older versions of checkSTRESS. i.e., User who had used the older version of
checkSTRESS can continue to use the same user defined attribute “:KPSUPCODE” to transfer the

support details to checkSTRESS, without reentering the values to the new attribute.

e Lastly, if both the attributes are not available in E3D/PDMS, then the program will read the support
details from the “STEXT” attribute of ATTA and transfer the same to checkSTRESS. This can be
used in situations where, the users do not have write access to Dictionary Database of E3D/PDMS

to create the User Defined attribute.

Any of the attributes defined above should be set a value as given in the field #1 i.e., “PdSupport” of the
access db “SupportType.mdb”, when the user selects the option “Use Mapping DB” for transferring the
support details to checkSTRESS. Otherwise, the attribute should be filled with values as specified in
Appendix E of checkSTRESS User's Manual supplied along with the product. For details on transferring
supports “Without Using Mapping DB”, refer to Appendix D of checkSTRESS User's Manual
(checkSTRESS. pdf).




In addition to the above, user can also add / modify supports in piping system in checkSTRESS directly
through Edit Layout->Misc->Data Types.

Material
Material description entered at XTEXT attribute of SMTE is extracted from the Paragon Database and the
material property is then obtained from the intermediate mapping db. For more details, refer Appendix B of

checkSTRESS User’s Manual supplied along with the product.
User can add / modify the Material properties in checkSTRESS through Edit Layout->Misc->Materials.

Thermal Anchor Movement (TAM)

Thermal Anchor Movement (TAM) values entered at UDA :NX, :NY, and NZ in global X, Y and Z directions
respectively at Equipment Nozzle where the piping layout (selected for transfer) is connecting to. These
values are then transferred to checkSTRESS. TAM values should be defined in “mm” for E3D/PDMS
projects in Sl units and in “Inch” for E3D/PDMS project in English units.

If the Equipment Nozzle to which the Piping Layout is connecting to is not modeled in E3D/PDMS, then
these TAM values can be entered at UDA :HNX, :HNY and :HNX or :TNX, :TNY and :TNZ at E3D/PDMS
Branch corresponding to Head or Tail of pipe run. In other words, TAM at starting of the Pipe run should be
entered at :HNX, :HNY and :HNZ of E3D/PDMS Branch. On the other hand, TAM at the end of the Pipe run
should be entered at :TNX, TNY and TNZ of E3D/PDMS Branch.

User can also add / modify the Thermal Anchor Movement values through Edit Layout option. i.e., Click Edit
Layout then select “Anchor” and select “Edit data” through Layout > Edit. From the dialog box shown, click on

“Specified Displacement” and enter the TAM values.

User defined Equipment Nozzle Allowable Loads

Equipment Nozzle Allowable Loads (forces and moments) provided by the equipment manufacturer or
calculated using Applicable codes / Finite Element Methods can be entered at UDA :NAL in global X, Y and
Z directions at Equipment Nozzle in the format FX, FY, FZ, MX, MY and MZ. These values should be
separated using “,”. Please note, the force values should be entered in “Ib” for English units and in “N” for Sl

units. Similarly, the moment values should be entered in “ft-Ib” for English units and in “Nm” for S| units.

If the Equipment Nozzle to which the Piping Layout is “Connecting To” is not modeled in E3D/PDMS, then
these Equipment Nozzle Allowable Loads can be entered at UDA :HNAL or :TNAL at E3D/PDMS Branch
corresponding to Head or Tail of the Pipe run. In other words, Allowable Loads at starting of the Pipe run
should be entered at :HNAL of E3D/PDMS Branch. On the other hand, Allowable Loads at the end of the
Pipe run should be entered at :TNAL of E3D/PDMS Branch.

Example:
For Nozzle, enter the values of FX, FY, FZ, MX, MY and MZ as “:NAL ‘3000,3000,6000,500,500,2000

For E3D/PDMS Branch Head, enter the values of FX, FY, FZ, MX, MY and MZ as “HNAL
‘3000,3000,6000,500,500,2000” and




For E3D/PDMS Branch Tail, enter the values of FX, FY, FZ, MX, MY and MZ as “HNAL
‘3000,3000,6000,500,500,2000”

The allowables thus defined are compared against calculated loads and shown / printed in Support Load
Summary outputs (can be viewed / printed through “Show Summary” option). If the calculated loads exceed

the allowables, they are highlighted in red.
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E3D/PDMS to checkSTRESS component Mapping

The types of components available in E3D/PDMS are simulated as tabulated below in checkSTRESSPDMS.

E3D/PDMS Component Connection Points Component in Keyword used
Description checkSTRESS in Neutral File
Cap
Butt weld I Rigid Element RB
Cap compression " Rigid Element RB
Cap Screwed P Rigid Element RB
Cap Socket Weld " Rigid Element RB
Closure
Pipe Block "'—L: P Rigid Element RB
Pipe Block Variable Length - Rigid Element RB
Coupling
Nipple — Screwed, Coupling
Compression, Coupling RD
Screwed, Coupling Socket -— Reducer Concentric
weld, Butt weld Elbolet, Socket
Weld Elbolet, Screwed Elbolet
Cross
Butt Weld, Socket Weld, L ) )
] i3 Four Pipes with Branch
Compression, Flanged, _—— = ) CR
4 SIF (Welding TEE)
Screwed Ir
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E3D/PDMS Component
Description

Connection Points

Component in
checkSTRESS

Keyword used
in Neutral File

t,

2

Four Pipes with Branch

Set on, Set on Reinforced -l _ CR
r SIF (Welding TEE)
Blind Flange
Rigid Element or Pipe
Flange — Blind Loz J ) P FL
with Flange
i i o Rigid Element or Pipe
Flange - Reducing Concentric -, _ FL
with Flange
10
—
2
Flange Reducing Eccentric 31 NA NA
Fixed Length Tube
Fixed length Pipe with Flanged ! )
) - —"'2 Pipe Pl
ends and without Flanged ends.
Lap Joint and Stub End
. . Rigid Element or Pipe
Lap Joint Ring Loose "oz g ] P FL
with Flange
i o Rigid Element or Pipe
Lap Joint Stub End Loose -, _ FL
with Flange
PCOMponent
-I—: 1]
Block — Angle l 1 Pipe Pl
Expansion Bellows, Flame
Trap, Flexible Hose, Hose "'_L,' P Pipe Pl

Coupling, Non — Category item,
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E3D/PDMS Component
Description

Connection Points

Component in
checkSTRESS

Keyword used
in Neutral File

Restrictor Plate, Tundish

Plug

Pipe

Pl

Sight Glass

Pipe

Pl

Slip Plate, Slip Ring, Spectacle
Blind

Pipe

Pl

Reducer Conc

entric

Reducer Concentric Butt Weld,
Fabricated from Plate, Swaged
from Pipe, Compression,
Flanged, Fabricated from Plate
Flanged, Swaged from Pipe
Flanged, Nipple, Screwed,
Socket Weld Bush, Socket
Weld & Special Reducing

Flange

Reducer Concentric

RD

Reducer Concentric with a Butt
Weld Connection, Fabricated
Plate Connection, Connection
Swaged from Pipe, Connection
Flanged, Connection Fabricated
from Plate Flanged, Connection
Swaged from Pipe Flanged,
Screwed Connection and

Connection Socket Weld

Reducer Concentric

RD

Reducer Eccentric

Reducer eccentric Buttweld,
Fabricated from Plate and

Swaged from Pipe.

o
—
1 2

Reducer Eccentric

ER
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E3D/PDMS Component Connection Points Componentin Keyword used
Description checkSTRESS in Neutral File
Reducer Eccentric with a
Connection Butt Weld,
Connection Fabricated from
Plate, Connection Swaged from

) ) NA NA NA
Pipe, Connection Flanged,
Connection fabricated from
Plate Flanged and Connection
Swaged from Pipe Flanged
Eccentric Screwed, Flanged, .

g -— P Reducer Eccentric
Fabricated from Plate Flanged " Ili* ER
and Swaged from Pipe Flanged
TRAP
Pipe Pl
Trap —In Line N
e —
1 2
-I—: 1]
Trap — Angle l 1 Pipe Pl
Trap — Offset, Trap — Return NA NA NA
UNION
Union — Screwed, Socket Weld "'—L,' P Rigid Element RB
TEE or OLET
Olet - Half Coupling, Nipolet
(Screwed, Plain Ended), 1 Pipe(s) with Branch SIF
Sockolet, Thredolet, Weldolet, ! (Welding TEE) or TUTWITF/TO
. Slp——

Tee- Set-on, Set-on Reinforced 102 (Weldolet)
and Tee Pulled
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E3D/PDMS Component Connection Points Componentin Keyword used
Description checkSTRESS in Neutral File
Pipe(s) with Branch SIF
Olet — Latrolet (Butt Weld, \ 3 )
(Welding TEE) or TU/TW/TE/TO
Screwed & Socket Weld) -—
to (Weldolet)
Olet — Instrument Flanged, Tee
— Butt Weld, Compression,
Flanged, Screwed, Socket Pipe(s) with Branch SIF
Weld, Swept Branch Butt Weld, I . (Welding TEE) or TU/TW/TF/TO
Swept Branch Flanged, Swept - s 3" (Weldolet)
Branch Compression and
Swept Branch Socket Weld
Valve
Valve — Angle (Pressure -— I-:u
i i ! Valve VA
Reducing, Relief/Vent, lz
Valve — Ball, Basic, Butterfly,
Cock, Diaphragm, Gate, Globe, '
— — Valve VA
Needle, Plug, Pressure 1 o3 2
Reducing, Relief/Vent and Slide
Valve — Check -t P Valve VA
VENT
Rupture Disk -t P Rigid Element RB
Four Way Valve
L Four Rigid Elements or
Valve — 4 Way -— s Four Pipes with 4w
Concentrated Mass
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E3D/PDMS Component

Connection Points

Component in

Keyword used

Description checkSTRESS in Neutral File
Three Way Valve
I Three Rigid Elements or
Valve — 3 Way -, ”: T Three Pipes with 3w
l Concentrated Mass
INSTRUMENT
Instrument, Orifice Plate,
Restrictor Plate and Rupture -t P Rigid Element RB
Disk
-I—‘: a
Instrument Angle I' Rigid Element RB
Instrument Dial and Dial s o
b Rigid Element RB
Flanged 1
Valve — Angle Relief/Vent,
Angle Pressure Reducing,
Angle Control, Angle Control -— Ig, o
] 1 Rigid Element RB
Square Indicator, Angle Control lz
Motorised Indicator, Angle
Control Hand Indicator
Control, Control Square
Indicator, Control Motorised
Indicator, Hand Indicator, — ' — Rigid Element RB
1 a3 2
Pressure Reducing and
Relief/Vent
3 Way Control, 3 Way Control o
Three Rigid Elements or
Square, 3 Way Control _— Iu,1 — ) ]
1 2 Three Pipes with 3w

Motorised Indicator and 3 Way
Control Hand Indicator

Concentrated Mass
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E3D/PDMS Component
Description

Connection Points

Component in
checkSTRESS

Keyword used
in Neutral File

4 Way Control Square Indicator,
4 Way Control, 4 Way Control
Motorised Indicator, 4 Way

Control Hand Indicator

Four Rigid Elements or
Four Pipes with

Concentrated Mass

4w

ELBOWor B

END

Elbow — Butt Weld(90 and 45
Deg), Screwed with Female
Ends, Elbow Compression,
Screwed with Male Ends, Elbow
Socket Weld, Elbow Reducing,
Bend — Mitre, Lobster Back Butt
weld and Lobster Back Bend
and Pulled

I». -
(=

Bend

EL

Butt Weld with a Connection,
Compression with a
Connection, Screwed Female
with a Connection, Socket Weld
with a Connection, Bend
Flanged with a Connection,
Bend — Mitre with a Connection
Flanged, Butt Weld Bend —
Mitre with a Connection,
Lobster Back with a Connection

and Pulled with a Connection

Pipes with Branch SIF
(Welding TEE)

TW

Butt Weld 180 Deg Return,
Flanged 180 Deg Return and
Pulled 180 Deg Return

Bend

EL

Filter/Strainer- Straight Through

Rigid Element

RB
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E3D/PDMS Component

Connection Points

Component in

Keyword used

Description checkSTRESS in Neutral File
-I—: 1]
Filter / Strainer Angle l 1 Rigid Element RB
Flange
Flange Blind, Flared/Loose -_— —_—
. . 1 2
Backing, Flange Backing, Rigid Element or Pipe
Flange Reducing Concentric, or with Flange FL
Screwed, Slip On, Slip On with
‘J” Type Weld, Socket Weld and —
Weld Neck e
Orifice Slip On Flange and _J Rigid Element with OF

Orifice Weld Neck

Tapping
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Appendix A
Specifying Wall Thickness

This section explains how to extract the wall thickness for E3D/PDMS piping components. To specify the wall
thickness for piping components like Pipe, Olet, Tee, Elbow, Reducer and Cross, navigate to
“checkSTRESS” installed path and locate the folder “Setup”. Navigate to the folder “Objects” and then open

the corresponding .pml object files in which the thickness needs to be specified.

Locate the variables “IThis.WallThickness[1] and “IThis.WallThickness[2]” in the file and modify the values to
suit the project requirement. By default these variables are assigned to ‘0.00’.

Catalogue Parameter

If wall thickness is defined using Catalogue Parameter of SCOM in E3D/PDMS, then the variable can be
modified to read the value from Catalogue Parameter. For example, if the Wall Thickness is specified in
Catalogue Parameter 3, modify the lines as follows.

IThis.WallThickness[1] = IDbRef.catref.Param[3].String()
IThis.WallThickness[2] = IDbRef.catref.Param[3].String()
Design Parameter

If Design Parameter (DESPARAM) is used to specify the Wall Thickness, then the variable can be modified
to read the value from Design Parameter. For example, if the Wall Thickness is specified in Design

Parameter 3, modify the lines as follows.
IThis.WallThickness[1] = !DbRef.spref.Desparam[3].String()
IThis.WallThickness[2] = |DbRef.spref.Desparam|[3].String()
User Defined Attributes (UDA) at Specification component

If User Defined Attribute is used to specify the Wall thickness of the piping component at SPCO level, modify
the variable listed below to read the value from UDA. For example, if the Wall Thickness is specified in the
variable “WallThickness” of SPCO element, modify the lines as follows.

IThis.WallThickness[1] = !DbRef.Spref.:WallThickness.string()
IThis.WallThickness[2] = !DbRef.Spref.:.WallThickness.string()
User Defined Attributes (UDA) at Piping Component

If User Defined Attribute is used to specify the Wall thickness at piping component, modify the variable listed
below to read the value from UDA. For example, if the Wall Thickness is specified in the variable

“WallThickness” of piping element, modify the lines as follows.
IThis.WallThickness[1] = IDbRef.:WallThickness.string()
IThis.WallThickness[2] = IDbRef.:WallThickness.string()
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Appendix B

Response Spectrum
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A (uniform response) spectrum is a table of maximum response versus natural frequency for a specific
excitation in single degree-of-freedom systems. You can input spectrums in three ways:

1. Input spectrums directly into the model.
2. Create a spectrum library and load spectrums from it.
3. Input spectrums from a text file.

When you use the first two methods, you may use menu Options > Spectrum command to set the
different units for the X- and the Y-axes, and also choose the interpolation method.

Spectrurn Options X
Ahbszcizza Ordinate
© FEasE | Diaoonen C ich
" Period [Sec)  mm
Acceleration % jntzec?

&
O mmdsec?
~

g's
Interpolatior ¢ Linear | Interpolatior @ Linear
" Lag " Laog

ak. | Cancel

1. Input spectrums directly into the model

Select Spectrums from the Misc menu. You are shown the List window for spectrums. Start typing
pairs of values into it. The frequencies or periods do not have to be in any order; checkSTRESS will
sort them later. You can input as many pairs of values as required.

HH checkSTRESS Muke: ... - O >
File Edit View Options Misc Window
Help
IID.QM@

M ame # |Frequency | Acceleration

[Hz] [inzecd]
1 | spectrum 1 (1 0.0025
2 | spectum 2 |50 0.0025
3 | £ spectum 3 |E2 0.0025
4 4 |75 0.0025
. 5_1EIEI 0.0025
E
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2. Input spectrums from a text file

This method involves creating a separate text file (in the format shown below) for each spectrum you
want to input. The steps are given below.

a) For each spectrum, on the first line, type the Name of the spectrum (up to 31 chars). On
the second line, type units for Abscissa (X-axis) and Ordinate (Y-axis) axes, separated by a
space.

b) After these two lines, on each line, you can input a value pair. You can input as many of
these value pair lines as required.

c) Each spectrum should be saved to a separate text file. More than one spectrum should not
be input in one text file as it cannot be read into checkSTRESS.

d) Now, open the checkSTRESS model that needs these spectrums. Select Read Spectrum
from the File menu, read all text files you created one after the other.

HH checkSTRESS Nuke: ... —

File Edit View Options Misc W
Library...
Read Spectrum...
Export...

Print... Ctrl+P

The format of a spectrum text file is shown below. The spectrum that is read appears on the row where
the yellow highlight is placed (under the Name column). You can use the Edit menu commands to
insert an empty row or delete an existing spectrum. Ensure that no two spectrums share the same
Name. checkSTRESS issues a warning should such occur.

The spectrum text file should be in the following format:

Name (up to 31 characters

Abscissa units Ordinate units

Abscissa valuel Ordinate valuel

Abscissa value?2 Ordinate value2

Where

Abscissa units 0 = Frequency (Hz)
1 = Period (Sec)

Ordinate units 0 = Displacement (inch)
1 = Displacement (mm)
2 = Acceleration (in/sec?2)
3 = Acceleration (mm/sec2)
4 = Acceleration (g’s)
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Example file

Test Spectrum
0 2

190

220

250

1932

1000

1800

o U W DN

Analysis note:

While analyzing the response spectrum case, when a mode (frequency or period) falls outside the
spectrum table, checkSTRESS issues a warning and uses the value corresponding to the closest
frequency or period in the spectrum table (for example, checkSTRESS uses the value corresponding to
the lowest frequency if the calculated frequency is lower than the lowest in the spectrum table or uses
the value corresponding to the highest frequency if the calculated frequency is higher than the highest
in the spectrum table).

Once you are done inputting the different spectrums using any one of the three methods, you need to
input the Spectrum load itself under the menu Loads > Spectrum in the Layout window. Details on
inputting the Spectrum Load are provided eatlier under the Loads menu.

Spectrum Load *

¥ zspectum |>< spechum j Factor |1.000
Y spectiunm |Y spectum ﬂ Factor (1.000
£ spectum |2 spectium j Factor |1.000

tade Sum Direction Sum
¢ g ¢ 5o

" Clozely spaced " Abzolute
" Absolute

ak. | Cancel Bezet
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