Buried Piping

Tutorial for Buried Piping Modeling and Analysis using CAEPIPE
The following are the Steps to perform Buried Piping Modeling and Analysis using CAEPIPE.

General

In CAEPIPE, Soil in Buried piping analysis is modeled using bilinear restraints with an initial stiffness and an
ultimate load. After the ultimate load is reached, the displacement continues without any further increase in load,
i.e., the yield stiffness is zero. The initial stiffness is calculated by dividing the ultimate load by the yield
displacement which is initially assumed to be D/25 where D is outside diameter of the pipe.

Soil modeling is based on Winkler's model wherein the soil resistance is represented by an infinite number of
closely spaced elastic springs. Soil stiffness is calculated for all three directions at each node. Pressure value in
the load is suitably modified to consider the effect of static overburden soil pressure. Model is analyzed for
operating (W+P1+T1) condition and the displacements in the three global directions are noted. A check is made
for whether skin friction is mobilized and the soil has attained the yield state. If true, then the spring is released in
that direction indicating that soil no longer offers resistance in that direction. This modified model is again
analyzed and checked for yield stage. The iterative process is continued till the percentage difference between
displacements at each node for two successive iterations is less than 1%. The final stiffness in each direction is
the true resistance offered by the soil to the pipe in that direction.

From the above, you may note that elastic springs representing the soil stiffnesses in the Global X, Y and Z
directions are to be added at as many nodes in the buried portion of the Stress model as required to simulate
Winkler’'s soil model. So, it is important that even long buried straight pipes are discretized so that such elastic
springs are added at all intermediate nodes generated along those long buried straight pipes. In addition, it is at
the bends, elbows, and branch connections that the highest stresses are found in buried piping subjected to
thermal expansion of the pipe. These stresses are due to the soil forces that bear against the transverse run. The
stresses are proportional to the amount of soil deformation at the elbow or branch connection. Hence, before
performing the analysis, discretize the stress layout as given below.

Piping elements at the junction of bends, elbows, and branch connections as well as long straight buried pipes
can be refined through Layout window > Edit > Refine Nodal Mesh > Buried Piping. Refinement length for adding
intermediate nodes is based on the influence length computed as below.

Modulus of Subgrade Reaction (k)

This factor k defines the resistance of the soil or backfill to pipe movement due to the bearing pressure at the
pipe/soil interface. Several methods for calculating modulus of subgrade reaction (k) have been developed in
recent years. As per Trautmann, C.H., and O’'Rourke, T.D., “Lateral Force-Displacement Response of Buried
Pipes,” Journal of Geotechnical Engineering, ASCE, Vol. 111, No. 9 Sep 1985, pp. 1077-1092, the modulus of
subgrade reaction, k, can be calculated as per Eqg. (2) in Appendix VII of ASME B31.1-2014 code.

k =C,N,wD
where,

Ck = a dimensionless factor for estimating horizontal stiffness of compacted backfill. Ck may be estimated at 20 for
loose soil, 30 for medium soil, and 80 for dense or compacted soil. In the current version of CAEPIPE, the value
of Ck is internally set as 80 for both cohesive and cohesionless soil.

D = pipe outside diameter, in
w = soil density, Ib/in3

Nn = a dimensionless horizontal force factor from Fig. 8 of above stated technical paper. For a typical value where
the soil internal friction angle is 30 deg. the curve from Fig. 8 may be approximated by a straight line defined by

Nh = (0.285H)/D) + 4.3

H = the depth of pipe below grade at the pipe centerline, in
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Influence Length (Lk)

The influence length is defined as the portion of a buried transverse pipe run which is deflected or “influenced” by
pipe thermal expansion along the axis of the buried longitudinal run.

From Hetenyi’s theory, (Beams on Elastic Foundation, The University of Michigan Press, Ann Arbor, Michigan
1967) (also, see Section VII-3.3.2 of Appendix VIl of ASME B31.1-2014 code)

L =%
45

where,
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Pipe / Soil System Characteristics =
E = modulus of elasticity of pipe at reference temperature
| = moment of inertia of pipe cross section

k = modulus of subgrade reaction of soil as detailed above.

Tutorial

Snap shot shown below is a sample model for Buried Piping Modeling and Analysis.

=i* Caepipe: Layout (969) - [buriedpiping.mod (c\tutorials\buriedpiping)] — O x =i= Caepipe : Graphics - [buriedpiping.mod (chtutorials\buriedpiping)]
File Edit View Options Loads Misc Window Help File View Options Window Help
IsEse BEO @R & AE@ARAQOD DS
# |MNode | Type O (ft'in") | D (ft'in") | DZ (ft'in") | Matl | Sect | Load | Data :
4 |30 Bend -19.2813 |-7.1622  |-182913 |Ck 30U |R | ;
5 |0 -14.4819 [CE (30U R
Pl -1.3944  |CB (30U R Weldolet
7 =0 Location Rest. Supp
5 [0 -l.88EE  |CE 30U |R
5 |70 Walve -b4593  [CB (30U R
10 a0 -1.68865  |CE 30U |R Weldolet
BHE! Location Rest. Supp

12 [Bo -13944  [CE (30U R

13 |100 -38.1398 [CE (30U R Guide
14 |10 -6.2336  |CB 30U |R
15 |120 -40483  [CE (30U R
16 | 130 -48409  [CB (30U R Rest Supp
17 |10 -21325  |CB 30U |R
18 [150 Walhse -5'5" Ce |30U | R Rest. Supp
19 | 160 -21325  |CE (30U R Guide
20 |170 -29.7720 |CE (30U R
BERLE! -35p458 |CB 30U |R Welding tee
22 [1a0 Location Rest Supp
23 |10 -96.4252 [CB (30U R Welding tee
24 [130 Location Rest Supp
ERED Bend -41'g" CE (30U |R
26 |2004 |Location Rest Supp
27 |z10 Bend 3.2808 -3.2808  |CB 30U R
EREE -47.3097 |Ce |30U |R
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Step 1:

First define soils using the command Layout window > Misc > Soils.

Soil #1 x Soil # 2
. ’7 (¢ Cohesive _ ’7 " Cohesive
Soi name |54 (" Cohesionless Soil name |53 (+ Cohesiorless
Density 150 (Ib/1t3) Density |150 (Ib/1t3)
Strength 100 [psi)
Delta |30 [dea)
Ks |0.80
Ground level |3'3" [ft'in") Ground level |6'6" [ft'in"']
Walue entered is Depth of Soill above pipe Walue entered is Depth of Soil above pipe
centerline centerline
Include Insulation thickness for computing Include Insulation thickness for computing
mazimum sail loads ma=imum soil loads
oK I Cancel oK I Cancel

Two types of soils can be defined - Cohesive and Cohesionless.

Cohesive soil is hard to break up when dry, and exhibits significant cohesion when submerged. Cohesive soils
include clayey silt, sandy clay, silty clay, clay and organic clay.

Cohesionless soil is any free-running type of soil, such as sand or gravel, whose strength depends on friction
between patrticles.

Soil density and Ground level are input for both cohesive and cohesionless soils. The Ground level is used to
calculate depth of the buried section. For cohesive soil, Strength is the un-drained cohesive strength (Cs). For
cohesionless soil, Delta is angle of friction between soil and pipe, and Ks is Coefficient of horizontal soil stress.

Ground Level

Ground level for a soil is the height of the soil surface from the global origin (height could be positive or negative).
It is NOT a measure of the depth of the pipe’s centerline.

In the figure below, the height of the soil surface for Soil 1 is 3 feet from the global origin. Pipe node 10 [model
origin] is defined at (0,-5, 0). So, at Node 10, the pipe is buried 8 [= (3’ — (-5")] deep into the soil. Define similarly
for the other soil.

The pipe centerline is calculated by CAEPIPE from the given data.

4 ft. depth

Node 10
begins at begins at
(0,-50) | (0,-5,0)
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Depth of Soil above Pipe’s Centerline

When the option “Value entered is Depth of Soil above pipe centerline” is turned ON in Soil input, then CAEPIPE
will compute maximum soil loads for the sections buried using the Depth entered. This option will be helpful for
modeling pipes that are running up or down a hill with same depth of soil filled above pipe’s centerline as shown
in the figure given below.

Hillcrest .y

Warning:

Assign Soil only to those elements that are really buried in soil when the option “Value entered is Depth of Soil
above pipe centerline” is turned ON.

Step 2:

Tie the soils defined above with pipe sections through Layout window > Misc > Sections or Ctrl+Shft+S (to list
Sections). Double click on the required section property. You will see the field Soil in the bottom right corner. Pick
the soil name from the drop-down combo box.

=i* Caepipe: Pipe Sections (10) - [buriedpiping.mod (chtutenals\buriedpiping]]

File Edit WYiew Options Misc Window Help
llmﬂamn«»

Mame | Mam Thk. CorAl | MTal | Ins.Dens |Ins. Thik | Lin.Dens | Lin.Thk | Sail

Dia (mu::h]l finch) |{inch) |{%) {aFiLy) rinch) | (lb/ft3) {inch)

1 J30U | Mon Std 30 0.87402 5.0 =2
2 |hou )2 ®5 [2.375 |0.218 125 53
3 |50 2" 40 | 2376 |0.154 125
4 |20l | Maon Std 20 0.55506 R0 53
B |16 | Mon Std 15,927 | 049213 125 =3
6 |20 Mon Std 20 0.5R80R 125
7|14 14" 40 |14 0.43701 125
5 |10 10" 40 |10.75 |0.365 125
5 |FIL Maon std 44016 |11.1811 | 0.11811
101 20F | Mon Std 24262 119685 (011811
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Section name (€] ¢ ANSI O DIN Q15 €150

Marninal diameter |Mon Std - Scheduls
Outzide diameter |30 [inch) Thickness |0.87402 [inch)

Corrogion allowance [inch) kill tolerance (5.0 [%]
Inzulation : Denzity [lbAft3] Thickness [inch)
Lining : Denzity [lbAt3] Thickness [inch)

ok | Cancel | Insulatiu:un| Soail |52 -

If a part of a piping system uses a certain pipe section with some portion of it buried and the balance not buried,
then two separate sections have to be defined, with one of them without soil and the other with soil.

Step 3:
Assign the appropriate section for each buried element on the Layout window with the correct soil around it.
Step 4:

Review the stress layout by highlighting the buried sections of the model in graphics. If your model contains
sections that are above ground and buried, then you can selectively see only the buried sections of piping in
CAEPIPE graphics by highlighting the section that is tied to the soil. Use the Highlight feature under the Section
List window and place highlight on the buried piping section (see Highlight under List window>View menu, or
press Ctri+H). The Graphics window should highlight only that portion of the model that is using that specific
section/soil. See the portion shown in green in the figure below.

== Caepipe : Graphics - [buriedpiping.med (c\tutorials\buriedpiping]]

File View Options Window Help

DE@AQQRQOEHEH
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Step 5:

It is at the bends, elbows, and branch connections that the highest stresses are found in buried piping subjected
to thermal expansion of the pipe. These stresses are due to the soil forces that bear against the transverse run.
The stresses are proportional to the amount of soil deformation at the elbow or branch connection. Hence, piping
elements at the junction of bends, elbows and branch connections are to be refined in the stress layout.

This can be performed through Layout window > Edit > Refine Nodal Mesh > Buried Piping. Please see the
section titled “Buried Piping” in CAEPIPE User's Manual for details on “Nodal mesh generation”.

*i* Caepipe: Layout [969) - [bunedpiping.meod (c\tutonials\buriedpiping)]

File Edit View Options Leoads Misc Window Help
Edit type.. Ctrl+T Q
j Edit data... Ctrl+D l@l
# Copy... Ctrl+C 17 (ft'in") | Matl | Sect [Load | Data,
4 19.2913 |[C& |30U [R |
_5 Find and Replace... Ctrl+H 144619 |CE |30V |R
B 13944 |CE |30U (R |weldolet
7 Insert Ctrl+Ins Fiest Supp
8 Delete... CwleX 1 gaEs [CE |30V |R
g Split... 54583 [CE |30V |R
10 Multiple Split... |BBE5 |CE |30U (R |weldolet
11 Slope... Fest Supp
12 Rotate... 13944 |CE |30V R
13 Ehange.. 381398 |C6 (30U R | Guide Refine Nodal Mesh for
14 32336 |CE |30U |R
15 Renumber nodes... 10453 |CE |30V |R
Tl IR N R Jqg4p3 |6 [30U |R |Fest Supp {* Buried Piping
17 Refine Branches 21325 |CE 30U |R
18 Generate.. ctisG 7 Cé |30U |R  |Rest Supp (" Dynamic Analysis
14 s 21325 |ce |30u R | Guide
20 2877en |CE | 30U R Mazz Modeling Frequency [Hz) |33
21 IREISS |CE 30U [R O |wWelding tee
— 0k, Cancel
23 /4252 |CE 30U [R O |wWelding tee
I YR PR | =
Step 6:

Now, to best simulate Winkler’s soil model, discretize even the remaining long straight buried pipe elements in the
stress layout as detailed below.

Starting from CAEPIPE Version 10.30, a feature was included to discretize the long straight buried pipe elements
through Layout Window > Edit > Refine Nodal Mesh > Buried Piping. In other words, the procedure listed below in
this step is done automatically using this command.

For example, a long-buried pipe element at row no. 3 is split as given below. Since the split length is not known,
Influence Length is calculated as explained above by obtaining the properties required from the CAEPIPE model.
The resulting length is then used to split the long-buried pipe element automatically.

Density of soil S2 = 150 Ib/ft3 = 0.087 1b/in3

As explained above, dimensionless factor (Ck) is taken as 80 for cohesive and cohesionless soil.
Pipe OD (D) for element at row #3 = 30”

Pipe ID (d) for element at row #3 = 30”- (2 x 0.874) = 28.252”

Being a sloped pipe, the average height at the middle of the pipe is considered as given below

H = Depth of Pipe below grade = 3’3" + (11’ + 3')/2=10'3" = 125”
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Nh = (0.285H)/D) + 4.3 = (0.285 x 125”"/30”) + 4.3 = 5.4875

Modulus Subgrade Reaction = k = Ck.Nh.w.D = 80 x 5.4875 x 0.087 x 30 = 1145.79 psi
Moment of Inertia (I) = PI ()/64 x (D4 — D4) = (3.14/64.0) x (304 — 28.252"4) = 8487.99 in4
Modulus of elasticity of Pipe at Reference Temperature (E) = 30.8E+6 psi

k 1/4
. . p= [4EI }
Pipe / Soil System Characteristics = =[1145.79/ (4 x 30.8E+6 x 8487.99)]*1/4 = 0.0057
3
L =%
Influence Length (Lk) = ap - 3x3.14/ (4 x0.0057) =413 in

Based on the above, number of splits = (Total Length / 413) + 1 = (1758 /413)+ 1=5.25=6

So, starting from CAEPIPE Version 10.30, the long-buried pipe element at row no. 3 is automatically split in 6
equal lengths. The above procedure is followed to automatically split other long buried straight pipe elements in
the stress model.

However, in CAEPIPE Version 10.20 or earlier, long straight buried pipe element at row no. 3 in the stress layout
needs to be discretized manually using “Multiple Split...” command available through Layout Window > Edit by
highlighting the pipe element at row no. 3.

Split Row # 3

Pipe From 10 To 20
Length = 146.5040 ([ft'in"]

Intermediate Starting Node | 20000
Mode Increment |10
MNo. of Splits |6

0K | Cancel |

Step 7:

Save the refined model as “BuriedPipingRefined_StPipes.mod”. Analyze the model through File > Analyze. Upon
successful analysis, CAEPIPE displays an option “Soil Restraints” in addition to other analysis results.

Results
" Sorted stresses " Support load summarny
" Code compliance " Support loads
™ Flange repart " Element farces
™ Rat. equip report " Displacements
* Sail restraints
ak | Cancel
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=I* Caepipe : Soil Restraints - [buriedpipingrefined_stpipes.res {c\tutorials\buriedpiping})]

File Results Wiew Options Window Help
0w Ee=
Auxial Transwverse Yerical Down Yertical Lp

# Fram [To MName | Type Stiffness | Max Load | Stiness | Mex Load | Stifiess | Max Load | Stifness | Max Load |

(lbfinch) | (I} (lbfinch) | (b} (lfinch) | (lkb) (lfinch) | (lb)
1 10 20n0o | =2 Caohesive 12484 14531 7BZBE+B | 9390709 | 4.306E+6 |B16EE1Z |7 701E+B | 9240631
2 0000|200 | =2 Cahesive 12484 14831 a.072E+6 | 9686963 | 4.310E+6 | 5171866 [ 8.028E+6 | 9633850
3 20010 |20020 |2 Caohesive 12484 14981 8.319E+6 | 9983217 | 4.314E+6 (5176920 [8.356E+6 | 1.00E+7
4 20020 |20030 |52 Caohesive 12484 14531 GBEEE+B | 1.03E+7  |4318E+6 5181974 [5654E+6 | 1.04E+7
b 20030 |z0040 |52 Caohesive 12484 14531 GE13E+6 | 1.06E+7 | 4323E+6 5187025 [9.011E+6 | 1.08E+7
b 20040 (20 =2 Cahesive 12484 14831 9.060E+6 | 1.09E+7 | 4327E+6 | 5192079 [9.339E+6 | 1.12E+7
7 20 30 52 Cohesive 28564 | 30677 1.886E+6 | 2262834 | 886519 | 1063823 [1.953E+6 | 2343343
g a0 40 52 Caohesive 2BhE.4 | 30677 1.896E+6 | 2276256 | 886696 | 1064035 [1.967E+6 | 2359831
9 40 0 =52 Caohesive 2bhE.4 | 3067.7 1.906E+6 | 2287679 | 886672 | 1064247 [1.980E+6 | 2376314
10 (50 B0 =2 Cahesive Zbhb.4 | 30677 1.917E+6 | 2300101 | 887049 | 1064459 [1.954E+6 | 23492808
1 B0 70 =52 Caohesive 2BhE.4 | 30677 1.927E+6 | 2312624 | 887226 | 1064671 [ Z.008E+B | 2409236
12 (70 a0 52 Caohesive 2BhE.4 | 30677 1.937E+6 | 2324946 | 887402 | 1064883 ([Z2.0Z21E+B | 2425785
13 (80 0A =52 Caohesive 12021 | 14426 94660 | 1097592 | 417359 | 500330 955347 | 1146416
14 (308 100 =2 Cahesive 2103.4 | 2524.0 1.6E0E+E | 1992143 | 7075649 | 549059 1.694E+k | 2032874
15 (100 1110 =52 Caohesive 2BhE.4 | 30676 21Z3E+6 | 25481684 | 8B168Z | 1034018 [2.195E+B | 2633760
16 (110 120 52 Caohesive 2BhE.4 | 30676 2.240E+B | 2687480 | 863598 | 1036317 [Z2.344E+B | 2812676
17 (120 130 =2 Cahesive Zbhb4 | 30676 2.356E+B | 2826795 | 8ERET4 (1038617 [ 2.493E+6 | 2991551
18 (130 140 =2 Cahesive Zbhb4 | 30676 2472E+6 | 2966111 | 867431 [1040M7 [ 2.64ZE+6 | 3170807
13 (140 1804 |52 Caohesive 8076 8631 604957 | 985954 274429 | 329315 GehERE | 1038786
20 [150B |1&0 52 Caohesive 17288 |2071.0 1.758E+6 | 2109735 | BOB3Z23 | 728307 1.963E+6 | 2355210
21 160 170 =2 Cahesive Zbhb4 | 30676 2B04E+6 | 3126043 | 8949004 (1078805 (2.907E+6 | 3488652
22 (170 180 =2 Cahesive 22813 | 273758 2.324E+6 | 2788760 | 802263 | 962716 2h94E+B | 3113242
23 (180 180 52 Caohesive /1249 Bhb5 726244 | §71492 250708 | 300850 10745 | 972893
24 (190 200 52 Caohesive 9645 1157.4 982853 | 1179063 | 3391890 | 407028 1.097E+6 | 1316251
b 210 2el =2 Cahesive 9645 1157.4 982553 | 1179063 | 3391490 | 407028 1.097E+6 | 1316251
26 |22l 230 =2 Cahesive /124 ohbh fekadq | 87149z 2b0703 | 300350 10745 | 972893
27 |230 240 52 Caohesive 13500 23400 1.986E+7 | 2.38E+7 | B.858E+6 | 8229074 |[Z2218E+7 | ZBEE+7
28 [240 250 52 Caohesive 3871 | 38245 3.247E+B | 3896030 |11Z21E+6 | 1344959 [ 3.624E+B | 4349346
23 [2h0 260 =2 Cahesive 20682 | 24814 2107E+6 | 2828310 | 727339 | 872806 2.352E+h | 2822492




