Tutorial for Fiber/Glass Reinforced Piping (FRP/GRP) Modeling and Analysis

as per ASME NM.2 using CAEPIPE

General

FRP/GRP are being extensively used in the process, water, and chemical industries due to their high service life
(about 50 years) and high resistance to corrosion. This, in turn, reduces the total cost of GRP/FRP piping incurred
during such long service life compared to metallic pipes. GRP/FRP pipes are increasingly used to transfer water,
oil, Fuel, Glycol, wastewater, sewer, etc. Because of this, the demand for GRP/FRP piping is continuously
INncreasing.

Pipe Flexibility specifications/Stress Analysis Design Basis requirements used in engineering industries consider
FRP/GRP piping as stress critical. So, FRP/GRP systems, irrespective of their sizes and pressure, require
analysis. Hence, demand for FRP/GRP pipe stress analysis is therefore ever-increasing.

This tutorial will help to learn the steps in performing piping stress analysis of above-ground FRP/GRP piping as
per ASME NM.2 using CAEPIPE.

In case the FRP/GRP piping system for analysis includes only buried piping or both above-ground and buried
piping, we recommend that such FRP/GRP system is analyzed as per ISO 14692-3. The tutorial titled “FRP/GRP
Modeling and Analysis as per 1ISO 14692-3” provides the details of such piping analysis.

Tutorial

Snap shot shown below is a sample model for above-ground FRP Modeling and Analysis
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Step 1:

Select the piping code for analysis as “ASME NM.2" through Layout Window > Options > Analysis > Code as
shown below and press the button “OK”.



Options

Code }Temperatum] Pressure | Dynamics | Misc |

Piping code

ASME NM 2 [2020) R

-

ok | cancel |

Step 2:

Next define FRP materials required for piping system through Layout window > Misc > Materials by obtaining their
properties from the manufacturer or through the piping standard.

ASME NM.3.3 provides tables and data sheets for allowable stresses, mechanical and physical properties (e.g.,
coefficient of thermal expansion and modulus of elasticity) for Fiberglass Unsaturated Polyester Resins Type |
(SC-582), Type Il (SC-582) and Type Il (55-deg Filament Wound; ASME NM.2, Mandatory Appendix V).

In this tutorial, Material properties for Fiberglass Unsaturated Polyester Resins Type | (SC-582) are referred from
Table 1-2.1-1 of ASME NM.3.3 corresponding to the structural wall thickness of 0.2” and entered into CAEPIPE
Material properties dialog.

Table 1-2.1-1 Data Sheet for Fiberglass Unsaturated Polyester Resin Type | (SC-582)

Description and Service Limits

Reinforcement material: Fiberglass (Type E or ECR glass)
Resin material: Unsaturated polyester resin
Reinforcement pattern: Random glass

Structural wall thickness range, in: 0.1 to 0.7

Liner thickness, in.: 0.1

Modulus Data [Notes (1), (2], and (3]]

Modulus of Elasticity for Total Wall Thickness, in. (Including 0.1-in. Liner), and Temperature, °F

Up to and Including 77°F 150°F 200°F
ASTM Test 0.8 and 0.8 and 0.8 and
Property Symbaol Method 0.2 0.4 0.6 Over 0.2 0.4 0.6 Over 0.2 0.4 0.6 Over

Axial tensile, psi Eur D&38, D1599, 1.12E+06 1.13E+06 1.13E+06 L113E+06 |9.92E+05 1.00E+06 1.01E+06 1.01E+06 |8.59E+05 B.78E+05 B8.82E+05 B8.84E+05

or D2105
Axial compressive, psi Eyr D695 1.12E+06 1.13E+06 1.13E+06 L13E+06 |9.92E+05 L1L.00E+06 1.01E+06 1.01E+06 |8.69E+05 B.78E+05 B8.82E+05 8.84E+05
Asdial flexural, psi Eyz D790 or D2925  L.OBE+06 1.10E+06 1.12E+06 1.12E+06 (9.56E+05 9S.B0E+05 9.91E+05 9.97E+05 | 8.34E+05 8.58E+05 B8.69E+05 8.74E+05
Hoop tensile, psi Eyr D638, D1599, 1.12E+06 1.13E+06 1.13E+06 L13E+06 |9.92E+05 1.00E+06 1.01E+06 1.01E+06 |8.59E+05 B8.78E+05 B.B2E+05 B8.84E+05

or D2290
Hoop flexural, psi Eyr D790 or D2412  L.0BE+06 L1.10E+06 1.12E+06 1.12E+06 (9.56E+05 9.B0E+06 9.91E+05 9.97E+06 | 8.34E+0> B.58E+05 8.69E+0> 8.74E+05
In-plane shear, psi G D4255 4.1BE+05 4.21E+05 4.23E+05 4.23E+05 | 3.71E+05 3.74E+05 3.76E+05 3.77E+05 |3.25E+05 3.29E+05 3.30E+05 3.31E+05
Other Property Data [Notes (1), (2). and (3]]

Property Symbol Test Method Value for 0.2-in. Thickness
Poisson's ratio: hoop-axial tensile Vaar 034
Poisson's ratio: axial-hoop tensile Viagrr 0.34
Coefficient of thermal expansion, in./in./°F: axial Xy D696 2.11E-05
Coefficient of thermal expansion, in./in./*F: hoop [ 2.11E-05
Density, [bm/in.* P D792 0.051
Thermal conductivity, Btu-in./(hr-ft°-°F) k C1045 12654
Allowable Stress Data [Note (4]]
Property Symbol ASTM Test Method 77°F 150°F 200°F

Axial tensile, psi Safo:1) D638 or D2105 1.13E+03 1.00E+03 8.78E+02
Asxial flexural, psi Safeen) D790 or D2925 1.66E+03 1.47E+03 1.29E+03
Axial compressive, psi Sag=1) D&95 1.13E+03 1.00E+03 8.78E+02
Axial 2 = 1 biaxial tensile, psi Safz1) D1599 1.13E+03 1.00E+03 B.78E+02
Hoop 2 = 1 biaxial tensile, psi Sty D1599 1.13E+03 1.00E+03 8.78E+02
Hoop tensile, psi Swpig) D&38, D15%99, or D2290 1.13E+03 1.00E+03 8.78E+02

In-plane shear, psi T D4255 4.21E+02 3.74E+02 3.29E+02




FRP Material Moduli

CAEPIPE requires three moduli for the FRP material:

e Axial or Longitudinal (this is the most important one)
e Hoop Modulus. If this modulus is not available, use axial modulus.

e Shear or Torsional. If this modulus is not available, use engineering judgment in specifying 1/2 of axial
modulus or a similar value. Note that a high modulus will result in high stresses, and a low modulus will
result in high deflections.

In the Material List window shown on the screen, double click on an empty row to input a new material or double
click on a material description to edit the material properties.

In the Material dialog shown, enter the FRP material properties as given below.

Material # 1

Material name |PRT

Description |Polyester Resins Type | (5C-563

Type ‘FH : Fiber/Glass Reinf. Plastic [FRP) LI

Density [0.051  (Ib/4in3)
MNu |0.34
Jairt factor |1.00

I 0K I Cancel | Elopemesl Library |

The material name can be up to five alpha-numeric characters. Enter description, density and Poisson’s ratio. You
need to select “FR: Fiber Reinf. Plastic (FRP)” from the Type drop-down combo box before you click on the
Properties button.

Step 3:

Click on the Properties button, you are shown the table below where you can enter temperature-dependent
properties. Additionally, you can also define the Hoop, Torsional and Axial allowable stresses so that CAEPIPE
can use them for code compliance checks as per ASME NM.2 and display them in the FRP "Sorted Stresses”
results.

Material Properties

# | Temp |Axial Mod. | Hoop Mod. | Shear Mod. | Alpha Hoop &ll. | Torsional All. | Axial AL

(F] _|lpsi] (psi) [psi) (in/in/F) | [psi] [psi) [psi]
7 |112E+6 |1.12E+6 |0D42E+6 |21.10E-6|1130 421 1130
150 |099E+6 |0.33E+6 |0.37E+6 | 21.10E-6)1000 374 1000
200 [D.B7E+6 |0.87E+6 |0D.32E+6 |21.10E-6|878 329 are

LT T [=fef~]=

LCancel




Step 4:

After defining the FRP material properties, Section Properties and Loads required for the stress analysis,
complete the stress layout. Save the model and Analyze through Layout window > File > Analyze.

Step 5:

Upon successful analysis, CAEPIPE shows the code compliance as per ASME NM.2 under Sorted FRP stresses
as shown below.

=l Caepipe

File Results View QOptions Window Help

S BE0D & Eeér= Ele->HB

Hoop Max Long Min Long &
# |Node |Stress |Allow |Stress/|Node |Stress |Allow |Stress/ [Node |Stress |Allow | Stress/
(psi) (psi) |Allow (psi) (psi)  [Allow (psi) | (psi) |Allow
1 1200 |2336 (1100 |22 T160E [ 2191 100 [1.99 260 1142|100 |1.04
2 1210 | 2336 1100 (212 38 2188 1100 [1.59 1300 | 1141 1100 (104
3 |1210 2336 |1100 |22 20 1975 |1100 [1.80 270 1141 1100 | 1.04
4 |1220 |2336 |1100 |212 2025 (1884 1100 [1.71 260 1140|1100 [1.04
5 |1220 |2336 |1100 |22 1165 (1871 1100 [1.70 1290|1129 (1100 [1.03
6 |1230 |2336 |1100 |212 40B  [1825 |1100 |166 1410 1119 (1100 [1.02
7 1178 2334 |1100 |22 1140 (1789 |100 [1.63 1290|1110 (1100 |1.00
8 |170 2334|100 |21 35 1785 |1100 [1.62 1240|1105 (1100 [1.00
g |190 2334 |1100 |22 w0 (1773 |00 (161 10 1104 (1100 |1.00

100|190 2334|1100 |za2 1780|1767 1100 |1.61 20 1104|1100 |1.00
11 |180  [2334 |1100 212 2030|1751 |1100 | 158 1240 (1100 {1100 |1.00
12 |180  [2334 1100 |zi2 70 1721|1100 |156 230 (1074 {1100 (098
13 1175 2334|1100 212 2020|1697 1100 |15 230 (1073|1100 |088 v

FRP stresses results of CAEPIPE display the stresses computed as per ASME NM.2 on an element-by-element
basis as shown below.

=i Caepipe : FRP s
File Results View Options Window Help
p=; B
BEDGA EHeEeED Eea
# |Node [Hoop Auxial Bending | Longitudinal | Longitudinal | Torsional »
(psi) (psi) (psi) Max (psi) | Min (psi) (psi)
1 10 2333 <1122 18 1140 1104 0
20 2333 -1122 18 1140 1104 0
2 |20 2334 773 1200 1975 434 -79
30 2334 773 283 1059 496 -79
3 |32 2334 773 39 B16 738 =79
35 2334 773 1010 1785 250 -79
4 |35 2334 773 1010 1785 250 =79
38 2334 773 1413 2188 645 -79
5 |38 2334 773 1413 2188 645 =79
39 2334 773 1602 2377 833 -79
b [40A 2117 314 651 966 338 -32
40B 1818 389 352 741 38 -7
7 |40B  |2333 957 867 1825 92 -17
50 2333 957 366 1323 592 -17
g 50 2333 957 366 1323 592 -17
G0 2333 957 273 1230 B85 -17 v




CAEPIPE will show the deflections and support loads for each load case under Deflections and Support loads
results as shown below.

=l* Caepipe : Displacements: Operating (W+P1+T1) - [FRP_Piping_AS.. — m}

s on Anchors: Operating (W+P1+T1) - [FRP_Piping._...
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S BEDBGA EED Sle=s @ BEDOAEHED S s
# Displacements (global) A # |Node |Tag |FX(b) |FY(b) |FZ(k) |MX (b)) | MY () | M2 (ftib)

Node |X(inch) | (inch) [2(inch) |XX(deg) [YY (deg)|ZZ (deg) 1 |10 0 -375 44859  |-179 0 0

1 [0 |oooo  Joooo  foooo  [ooooo [ooooo  [ooooo 2 |en -3647  |-2223  |-37562 |-3805  |11169 | 783
2 |20 |oooo  |oooo  |oooo  [ooooo  [ooooo |ooooo ERE) a2 312 773 152 13 25
3 |30 |-0048 |-0018  |-0047 |-00250 |oos11 (00122 PRE: 10 118 185 91 -4 S
4 |32 |-00s2 |-0023 |-0060 |-00250 [00s28 00133 5[990 4 135 101 95 2 E
5 |35 |-0127  |-0037 |-0116 |-00110 |00147 |00281 6 |1090 2 162 42 -104 -1 2
6 |38 |-0135 |-0039 |-0139 [-00033 [-00518 |00340 7 1100 522 425 427 -180 -441 1553
7 |3 |-0133 |-0038 |-0149 |ooooo |-00910 |o038 5 |1410 8 329 -289 772 -10 -40
5 |40A |-0133 |-0038 |-0143 (00000 [-00910 (00368 5 [1510 5 860 -268 720 7 27
9 |48 |-0039 |-0018 |-0112  |00024 |-01853 (00386 10 (1710 3 827 245 535 7 22
0 |50 |-0022  |-0010 |-0085 |0.0016 |-0.2079 |0.033 11 1910 5 793 235 519 7 25
11 |e0  |-0011  |-0005  [-0032  |oooi0 [-02111 00273 12 | 2000 334 940 506 -154 782 364
12 |70 |0oo0 |00  |oooo  [ooood  [-n20s0 |o0197 B
13 |80 |-0001  [-0002  |0.041 -0.0007 |-0.1830 |0.0062 B
T an -n nnt -0 nn8 nnza -nnn1a 1-n1847 |-nonng ¥ 1

Element forces results for each load case (such as Sustained, Operating, etc.) show the Element forces and
moments in local coordinate system along with Stress Intensification Factors (SIFs) and Pressure Multiplier (m)
computed as per ASME NM.2 for each element as shown below.

(W+P1+T1) - [FRP_Piping ASME.. ~ — |
File Results View Options Window Help
V=, f=h i
DB Eed Sea= 5o
# Axial y Shear | z Shear | Torque | Inplane(ft-lb) |Outplane(f-lb) [ Torsion [ Pressure #
Node |(Ib) (Ib) (Ib) (fi-Ib) Moment | SIF |Moment | SIF | SIF Mult(m)
1 |10 -44859 |-357 0 0 -179 100]0 1.00
20 -44859 | 358 0 0 -180 1
2 20 -7297 |-1865 |-3647 [-783 -4084 11170
30 -7297 |-1319  [-3647 |-783 -420 1.00]2775 1.00
3 |32 -7297  |-729 -3647  |-783 284 1.00 | 268 1.00
35 -7297  |-66 -3647  |-783 1395 9913
4 |3 -7297  |-66 <3647 |-783 1395 -9913
38 -7297  |196 <3647 |-783 1323 1.00(-13339 |1.00
5 |38 -7297 | 250 -3647 |-783 1323 1.00(-13939 |1.00
39 -7297  |374 -3647 |-783 1161 -15839
6 |40A4 |-7297 |-3647 |-374 -783 15839 [1.00 | 1161 1.00 (1.00 1.50
408 (-3647 |7297 |-1175  |-169 8538 1.00 |-985 1.00 (1.00 1.50
7 408 |-3647 1175 7297 -169 -985 -8538
50 -3647 |1354  [7297  |-169 -1934 -3065
8 |50 <3647 |13%4  [7297  |-189 -1934 -3085
60 -3647  |1472 7297 -169 -2640 584 v

For the design of supports, Support Load Summary of CAEPIPE will show the loads on each support for all load
cases selected for analysis as given below.

=i Caepipe : Support load summary for anchor at node 10 - [FRP_Piping ASME_NMZ2.res..  — ml
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O EeE 5
Load combination FX(b) |[FY(b) |FZ(b) |MX(tb) |MY () | MZ (k)
Sustained 0 -375 0 -179 0 ]
Operating1 0 -375 44859  |-179 0 0
Sustained+Seismic1 |30 -360 30 -172 14 0
Sustained-Seismic1 |-30 -389 -30 -187 -14 0
Operatingl+Seismic 1|30 -360 44889 -172 15 1]
Operatingl-Seismic1 |-30 -389 44829 -187 -14 0
Medimum 30 -360 44889 -172 15 0
Minimum =30 -369 =30 -187 -14 1]
Allowables 0 i] 0 0 0 ]




Stiffness matrix formulated internally in CAEPIPE is given below for quick reference.

Stiffness matrix

The stiffness matrix for a pipe is calculated using the following terms:

Axial term = L/ EA

Shear term = shape factor x L / GA

Bending term =L / El

Torsion term = L / 2Gl

where L = length, A = area, | = moment of inertia, E = elastic modulus, G = shear modulus
For an isotropic material, G = E/ 2(1 + v), where v = Poisson’s ratio,

For a FRP material, E = axial modulus and G is independently specified (i.e., it is not calculated using E and v).
The hoop modulus and FRP Poisson’s ratio are only used in Bourdon effect calculation where,
Poisson’s ratio used = FRP Poisson’s ratio input x (axial modulus / hoop modulus)

Note:

Refer to Section titled “ASME NM.2” in CAEPIPE Code Compliance Manual of CAEPIPE for details on how
CAEPIPE computes the Flexibility Factors, Stress Intensification Factors and Code Stresses as per ASME NM.2.



