Tutorial on Fiber/Glass Reinforced Piping (FRP/GRP) Modeling and Analysis

as per ISO 14692-3 using CAEPIPE

General

FRP pipes, also known as GRP pipes, fiberglass reinforced plastic pipes, is a type of conveying pipes with
lightweight, high strength and corrosion resistance performance. The excellent corrosion resistance property and
outstanding mechanical, physical and chemical performance save engineering, installation and maintenance
costs, so it is regarded as the "user friendly" pipe.

FRP pipes have been proved to be superior to steel pipes in many aspects. They are widely used in industrial,
civil engineering, petroleum, power and other fields.

FRP/GRP products are proprietary and the choice of component sizes, fittings and material types can be limited
depending on the supplier. Potential vendors should be identified early in design to determine possible limitations
of component availability.

FRP piping systems can be supported using the same principles as those for metallic piping systems.

In addition to the above, Buried FRP analysis requires computation of vertical soil load on pipe sections, live load
on pipe due to the traffic and considers the effect of static overburden soil pressure.

This tutorial provides steps in performing piping stress analysis of both buried and above-ground FRP/GRP piping
as per 1SO 14692-3 using CAEPIPE.

Tutorial

Snap shot shown below is a sample model for FRP/GRP Piping Analysis as per ISO 14692-3 where a portion of
the layout is buried in soil (see the shapshot with RED highlight below) and the remaining portion of the layout is
above the ground.
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Step 1:

Select the piping code for analysis as “ISO 14692-3” through Layout Window > Options > Analysis > Code as
shown below and press the button “OK”.

Analysis Options

Code |Temperature] Pressure | Dynamics | Misc |

Piping code

ok | cance

Step 2:

Next define FRP materials required for piping system through Layout window > Misc > Materials by obtaining their
properties from the manufacturer or through the piping standard.



FRP Material Moduli
CAEPIPE requires three moduli for the FRP material:

e Axial or Longitudinal (this is the most important one)
e Hoop Modulus: If this modulus is not available, use axial modulus.

e Shear or Torsional: If this modulus is not available, use engineering judgment in specifying 1/2 of axial
modulus or a similar value. Note that a high modulus will result in high stresses, and a low modulus will
result in high deflections.

In the Material List window shown on the screen, double click on an empty row to input a new material or double
click on a material description to edit the material properties.

In the Material dialog shown, enter the FRP material properties as given below.

Material # 1

Material name |FF|

Description ‘ Fw/

Type ‘FR : Fiber/Glass Reinf. Plastic [FRP) LI

Density |0.064  [Ib/in3)
Nu (043
Joint factor {1.00

[ 0K I Cancel | Elopeﬂiesl Library |

The material name can be up to five alpha-numeric characters. Enter description, density and Poisson’s ratio. You
need to select “FR: Fiber Reinf. Plastic (FRP)” from the Type drop-down combo box before you click on the
Properties button.

Step 3:

Click on the Properties button, you are shown the table below where you can enter temperature-dependent
properties. Additionally, you can also define the Hoop, Torsional and Axial allowable stresses so that CAEPIPE
can use them for code compliance checks as per ISO 14692-3 and display them under "Sorted FRP Stresses”
results.

Material Properties

# | Temp | Axial Mod. |Hoop Mod. | Shear Mod. | Alpha Hoop &l | Torsional All. | Axial AL A

(F] | [psi) (psi) [psi) (in/in/F] | [psi) [psi) [psi)
0 |1.30E+6 |200E+6 |1.20E+6 |1B.30E-6|3191 1450 il k=)
125 |1.30E+6 |2.00E+6 [1.20E+6 |16.30E-6|3191 1450 319
592 |1.30E+6 |200E+6 |[1.20E+6 |5.74E-6 |3191 1450 g
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Step 4:

Define soils properties using the command Layout window > Misc > Soils.
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Strength [r [psi]

Dets [ [deg)
k[
Ground level [50— [ft'in")

[T Walue entered is Depth of Soil above pipe centerline

Include Insulation thickness for computing
maximum soil loads

Stiffness Category  |SC1 -

Standard Proctor Density  |SPD 95 -

wheelload [16000 ()
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0K | Cancel

Two types of soils can be defined - Cohesive and Cohesionless.

Cohesive soil is hard to break up when dry, and exhibits significant cohesion when submerged. Cohesive soils
include clayey silt, sandy clay, silty clay, clay and organic clay.

Cohesionless soil is any free-running type of soil, such as sand or gravel, whose strength depends on friction
between particles. Cohesionless soil is not applicable for ISO 14692-3. Hence, the option is grayed out in the
input screen.

Density is the density of the soil.

Strength

For cohesive soil, Strength is the same as Constrained modulus “Msn” defined in Table 5-6 of AWWA Manual
M45 (second edition).

Ground Level

Ground level for a soil is the height of the soil surface from the global origin (height could be positive or negative).
It is NOT a measure of the depth of the pipe’s centerline.

In the figure below, the height of the soil surface for Soil 1 is 3 feet from the global origin. Pipe node 10 [model
origin] is defined at (0,-5, 0). So, at Node 10, the pipe is buried 8’ [= (3’ — (-5’)] deep into the soil. Define similarly
for the other soil.

The pipe centerline is calculated by CAEPIPE from the given data.

4 ft. depth




Depth of Soil above Pipe’s Centerline

When the option “Value entered is Depth of Soil above pipe centerline” is turned ON in Soil input, then CAEPIPE
will compute maximum soil loads for the sections buried using the Depth entered. This option will be helpful for
modeling pipes that are running up or down a hill with same depth of soil filled above pipe’s centerline as shown
in the figure given below.

Hillcrest _')

Warning:

Assign Soil only to those elements that are really buried in soil when the option “Value entered is Depth of Soil
above pipe centerline” is turned ON.

Stiffness Cateqgory

Stiffness Category is required to compute the value of “Ms” the constrained soil modulus of the pipe zone
embedment listed in Table 5-4 of AWWA Manual M45 (second edition). See the snapshot shown below.

Table 5-4 Msp based on soil type and compaction condition

Inch-Pound Units

Stiffness Categories 1 and 2 (SC1, SC2)

Vertical Stress Level Depth for v, =

(see note 5), 120 pcf, SPD100, SPD95, SPDY0, SPD85,

psi ft psi psi psi pst

1 1.2 2,350 2,000 1,275 470

5 6 3,450 2,600 1,500 520

10 12 4,200 3,000 1,625 570

20 24 5,500 3,450 1,800 650

40 48 7,500 4,250 2,100 825

60 72 9,300 5,000 2,500 1,000

Stiffness Category 3 (SC3)

1.2 1,415 670 360

5 6 1,670 740 390
10 12 1,770 750 400
20 24 1,880 790 430
40 48 2,090 900 510
60 72 2,300 1,025 600

Stiffness Category 4 (SC4)

1.2 530 255 130

5 6 625 320 175
10 12 690 355 200
20 24 740 395 230
40 48 815 460 285

60 72 895 525 345




Standard Proctor Density

Standard Proctor Density is required to obtain the value of “Msb” (the constrained soil modulus of the pipe zone
embedment) listed in Table 5-4 of AWWA Manual M45 (second edition).

Wheel Load

Value entered in “Wheel Load” field will be used to compute the Live Load (WL) on pipe. Refer to Sub-section
5.7.3.6 of AWWA Manual M45 (second edition). For example, the Truck Load field can be input as 16,000 Ib for
AASHTO-20 or 20,000 Ib for AASHTO-25.

Tyre Width & Tyre Length

Tyre Width and Length input are used for computing the Live Load (WL) on pipe. By default, these values are set
as 20” and 10” respectively. Refer to Sub-section 5.7.3.6 of AWWA Manual M45 (second edition) and Section
“ISO 14692-3” in CAEPIPE Code Compliance Manual for further details.

Trench Width

Trench Width input is used to obtain the value of Sc from Table 5-5 which in turn is used for computing the
maximum allowable vertical pipe deflection of pipe. Refer to Sub-section 5.7.3 and Table 5-5 of AWWA Manual
M45 (second edition) and Section “ISO 14692-3” in CAEPIPE Code Compliance Manual for further details.

Step 5:

Tie the soils defined above with pipe sections through Layout window > Misc > Sections or Ctrl+Shft+S (to list
Sections). Double click on the required section property. You will see the field Soil in the bottom right corner. Pick
the soil name from the drop-down combo box.

=l= Caepipe : Pipe Sections (4) - [FRP_ISO_14692_3.mod (D:\KPDevelopment\Documents... — Oa
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S‘J
Name | Nom Sch Thk |CorAl|MTol [Ins.Dens [Ins.Thk |Lin.Dens | Lin.Thk | Soil
Dia [mch) {inch) | (inch) [(*%s) | (Ib/ft3) {inch) | (Ib/ft3) (inch)

1 1 Non Std b.625 | 0.322
2 |2 Naon Std 16 0.375
'3 |28 MNon Std 16 0.375 31
4_ 1B Non Std 6.625 | 0.322 S1
5

If a part of a piping system uses a certain pipe section with some portion of it buried and the balance not buried,
then two separate sections have to be defined, with one of them without soil and the other with soil as shown
above for Sections 2 and 2B.

Step 6:
Assign the appropriate section for each buried element on the Layout window with the correct soil around it.
Step 7:

Review the stress layout by highlighting the buried sections of the model in graphics. If your model contains
sections that are above-ground and buried, then you can selectively see only the buried sections of piping in
CAEPIPE graphics by highlighting the section that is tied to the soil. Use the Highlight feature under the Section
List window and place highlight on the buried piping section (see Highlight under List window>View menu, or
press Ctri+H). The Graphics window should highlight only that portion of the model that is using that specific
section/soil. See the portion shown in green in the figure below.
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Step 8:

It is at the bends, elbows, and branch connections that the highest stresses are found in buried piping subjected
to thermal expansion of the pipe. Hence, buried piping elements at the junction of bends, elbows and branch
connections are to be refined in the stress layout.

This can be performed through Layout window > Edit > Refine Nodal Mesh > Buried Piping. Please see the
section titled “Buried Piping” in CAEPIPE User’s Manual for details on “Nodal mesh generation”.
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Step 9:

After completing the stress layout, save the model and analyze through Layout window > File > Analyze. See the
file “FRP_ISO_14692_3.mod” available with this tutorials for further details.



Step 10:

Upon successful analysis, CAEPIPE shows the code compliance as per 1ISO 14692-3 under Sorted FRP stresses
as shown below.
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Hoop Max Long Min Long Cu
Node |Stress |Allow | Stress/ | Node | Stress | Allow | Stress/ Node | Stress | Allow | Stress/
(psi) | (psi) [Allow (psi)  |(psi) |Allow (psi) (psi) | Allow

3708 | 4498 2649 [1.70 B0A |7429 (2649 |2.80 804 [-9110 2649 [3.44
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FRP stresses results of CAEPIPE display the stresses computed as per 1ISO 14692-3 on an element-by-element
basis as shown below.
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= Frs
AR Ee=s S e
# [Node |[Hoop | Axial Bending | Longitudinal | Longitudinal | Torsional ~
(ps)  |(ps)  |(ps)  |Max(ps) |Minps) [(psi)
1 {10 1042 -917 708 -209 -1625 27
20 1042 -1024 1805 M| -2628 27
2 |20 1042 -1018 1805 787 -2822 27
30 1042 -1038 356 652 -1394 27
3 [404 |4498 -1104 820 -284 -1923 27
40B |2003 -811 5337 4526 -6143 52
4 |50 2003 -823 2321 1498 -3143 52
60 2003 -823 5049 4227 -5872 52
5 |60 2003 -836 5049 4213 -5386 52
70 2003 -836 3595 2759 -4432 52
B |B804 |2003 -840 8270 7428 -9110 52
80B |2003 -1443 619 -G24 -2062 4
7 |90 2003 -1510 269 -1241 -1780 4
| |100 2003 -1510 259 -1251 -1763 4
8 (100 |2003 -1620 259 -1361 -1879 4
110 |2003 -1620 102 -1518 -1722 4
9 (110 |2003 -1671 102 -1569 -1773 4
[120 |2003 -1671 169 -1502 -1840 4
10(120 |2003 -1691 35 -1656 -1726 4
130 2003 -1691 209 -1482 -1900 4
11 (130 |2003 -1752 209 -1543 -1961 4
| |140 |2003 -1752 293 -1460 -2045 4
12(140 2003 -1819 293 -1526 -2112 4
150 |2003 -1813 270 -1549 -2083 4 o




CAEPIPE will show the deflections and support loads for each load case under Deflections and Support loads
results as shown below.

erating (W+P1+T1) - [FRP_ISO_14¢
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= BE0BRR Hes Se sl BE

Displacements (global)
Mode X (inch) |%(inch) |Z(inch) |[XX({deg) |Y¥Y (deqg)|ZZ (deq)
1 |10 0.000 0.000 0.000 0.0000 (00000 {0.0000
2 |20 0.043 -0.028 -0.109 -0.0159 |-0.1886 |-0.0093
3 |30 0145 -0.034 -0.129 -0.0123 |-0.2583 |-0.0118
(4 408 |0145 -0.034 -0.129 -0.0123 |-0.2583 |-00118
5 |40 [0153 -0.024 -0.069 00160 (02116 |-0.0396
5 |50 0.153 -0.024 -0.069 00160 (02116 |-0.0396
7 |60 ni2z 0.025 -0.0Mm 00209 (00681 |-0.2585
5 |70 0107 0129 0.011 00233 (00389 |-0.4440
9 |Boa |0.107 0129 0.011 00233 |00389 |-0.4440
10808 |-0.019 0.328 0.000 00229 (-0.0009 |0.0000
11 a0 -0.019 0.328 0.000 00229 (-0.0009 |0.0000
[12]100 |-0.000 0.267 -0.001 -0.0047 |-0.0021 |0.0095
13110 |0.000 0.210 -0.001 -0.0012 |-0.0032 |-0.0015

=I* Caepipe : Loads on Anchors: Operating (W+P1+T1) - [FRP_ISO_14
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# |Node [Tag [FX(b) |FY(b) [FZib) |MX () [MY (k) |MZ (i)
1 |10 693 |47 13074 |-381 2008 |-155
2 |s70 2735 |6 -346 93 14945 |58

3 | 630 121 -0 362 302 |e60 217

4 |90 137 |59 349 206|808 |-160

5 | 750 136 47 350 163 914 127

Element forces results for each load case (such as Sustained, Operating, etc.) show the Element forces and
moments in local coordinate system along with Stress Intensification Factors (SIFs) computed as per analysis
code ISO 14692-3 for each element as given below.

== Caepipe : FRP forces in local coordinates: Operating (W+P1+T1) - [FRP

Eile Results View Options Window Help
Axial y Shear |z Shear | Torque | Inplane(ft-lb) |Outplane(ft-lb) »
Node | (Ib) (k) {Ib) (ft-1b) Moment | SIF | Moment | SIF
1 |10 -13074 |47 693 155 381 1.00 (-2009 1.00
20 -14046 |47 £33 155 -1 5214
2 |20 -13990 |47 -2102 |155 -1 5214
30 194176 |47 -2102  |155 -205 1009
3 |40A  |-14110 (11451 [-47 155 -1003 2.30 [-205 2.30
40B  |-11451 [14403 |[-47 =300 -6702 2.30 [-249 2.30
4 |50 -11555 | 5266 -1535  [-300 -249 6702
B0 -11555 | 5266 -1286  |-300 -14293 2940
5 |60 -11679 |-2960 [-1543 |-300 -14293 2340
70 -11679 |-2960 [-1419  [-300 -10346 966
6 |80A |-11716 [-17195 [-576 -300 -10346 | 2.30 | 966 2.30
B0B |-17195 (11716 |-283 26 613 2.30 [-480 230
7 |50 -17807 [136 -187 26 613 -480
100 [-17807 (136 495 26 -383 643
8 |100 |-18805 |-B8 -392 26 -383 643
110 |-18805 (-B8 290 26 17 272




For the design of supports, Support Load Summary of CAEPIPE will show the loads on each support for all load
cases selected for analysis as given below.

=I* Caepipe : Support load summary for anchor at node 10 - [FRP_ISO_14692_3.re KPDevelopm... — O

Eile Results View Options Window Help
BEO @A He 5=

Load combination [Fx (k) |FY (k) |FZ(b) |Mx(ftlb) | MY (ft-lb) | MZ (ft-Ib)

Sustained 0 -2 -1198 -8 -2 4
Operatingl -693 -47 13074 |-381 2009 -155
Maximum 0 -2 13074 |8 2009 4
Minirmum -693 -47 -1198 =381 -2 -155
Allowables 0 0 0 0 0 0

Stiffness matrix formulated internally in CAEPIPE is given below for quick reference.

Stiffness matrix

The stiffness matrix for a pipe is calculated using the following terms:

Axial term =L/ EA

Shear term = shape factor x L / GA

Bending term =L / El

Torsion term =L / 2GlI

where L = length, A = area, | = moment of inertia, E = elastic modulus, G = shear modulus
For an isotropic material, G = E/ 2(1 + v), where v = Poisson’s ratio,

For a FRP material, E = axial modulus and G is independently specified (i.e., it is not calculated using E and v).
The hoop modulus and FRP Poisson’s ratio are only used in Bourdon effect calculation where,
Poisson’s ratio used = FRP Poisson’s ratio input x (axial modulus / hoop modulus)

Note:

Refer to Section titled “ISO 14692-3” in CAEPIPE Code Compliance Manual of CAEPIPE for details on how
CAEPIPE computes the Flexibility Factors, Stress Intensification Factors and Code Stresses as per 1ISO 14692-3.



