Tutorial on Hydrogen Pipeline Analysis as per ASME B31.12 Part PL using CAEPIPE

General

In the search for a sustainable and decarbonized future, hydrogen is emerging as a key energy carrier with
tremendous potential. As the demand for hydrogen increases, the need for safe and efficient infrastructure
becomes paramount. The American Society of Mechanical Engineers (ASME) recognized this need and
developed the ASME B31.12 code to provide guidelines for the design, construction, and operation of hydrogen
piping and pipeline systems. This comprehensive code ensures the integrity and safety of hydrogen infrastructure
while promoting the growth of the hydrogen industry.

This tutorial provides steps in performing piping stress analysis of both buried and above-ground Hydrogen
Pipelines as per ASME B31.12 Part PL using CAEPIPE.

Tutorial

Snap shot shown below is a sample model for Hydrogen Pipelines as per ASME B31.12 Part PL where a portion
of the layout is buried in soil (see the snapshot with RED highlight below) and the remaining portion of the layout
is above-ground.
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Step 1:

Select the piping code for analysis as “B31.12 PL” and the “Design Factor F” through Layout Window > Options >
Analysis > Code as shown below and press the button “OK”. See para. PL-3.7.1 (b) for details on Design Factor F

in ASME B31.12 Part PL.

Analysis Options

Code |Temperature| Pressure | Dynamics | Misc |

Piping code Design Factor F

B3t1zPL2oe)  ~| [IEEAOEE -
I Use B31J for SIFs and Flexibility Factors
-

[ Combine stresses as per Max. Distortion Energy Theory

OK I Cancel




Step 2:

Next define materials required for piping system through Layout window > Misc > Materials by obtaining their
properties from the manufacturer or through the piping standard.

In the Material List window shown on the screen, double click on an empty row to input a new material. Enter the
material properties as shown below and press the button “Ok”.

Material # 1

M aterial name |A53

Description |A53 GRADE B

Type |CS : Carbon steel LI

Density |D.283 (Ib4in3)
MNu |[13
Joint factor |1-UU

0K | Cancel | Empelliesl Library I

Step 3:

Click on the Properties button and input the temperature related properties as shown below.

Material Properties

# |Temp|E Alpha  |Yield
(F) [psi] (infin/F) | [psi)

1 |20 |29.9E+6|5.77E-6 | 35000

2 |70 29.5E+6 | B.03E-6 | 35000

3 |100 |29.3E+6 [6.13E-6 | 35000

4 |125 |23.2E+6 |6.27E-6 | 35000

5 |150 |[29.1E+E|6.36E-E | 35000

E |175 |(28.9E+E|6.41E-E | 35000

7 |200 |[28.8E+6|E.45E-6 | 35000

8 |225 |[28.7E+E|6.48E-6 | 35000

8 |250 |28 6E+E|6.50E-6 | 35000

10300 |28.3E+6|6.84E-6 | 35000

171|350 |[28.0E+E | E.81E-6 | 35000

12|400 |27.7E+6 [6.79E-6 | 35000

13| 450 |27.5E+6 [6.98E-6 | 35000

14 v
Ok Cancel




Step 4:
Define soils properties using the command Layout window > Misc > Soils.

Soil # 1
N ’517 ? EZ::;:Z:E:SS
Density [624  (b/R3)
Strength W [p=1)
Deta | (deg)
ks [
Ground level F [ft'in"')

[ Walue entered is Depth of Soil above pipe centerling

Include Insulation thickness for computing
maximum soil loads

Ok I Cancel

Two types of soils can be defined - Cohesive and Cohesionless.

Cohesive soil is hard to break up when dry, and exhibits significant cohesion when submerged. Cohesive soils
include clayey silt, sandy clay, silty clay, clay and organic clay.

Cohesionless soil is any free-running type of soil, such as sand or gravel, whose strength depends on friction
between patrticles.

Density is the density of the soil.

Strength

Soil strength. This field needs to be input only for Cohesive soil. For cohesive soil, Strength is the un-drained
cohesive strength (Cs).

Ground Level

Ground level for a soil is the height of the soil surface from the global origin (height could be positive or negative).
It is NOT a measure of the depth of the pipe’s centerline.

In the figure below, the height of the soil surface for Soil 1 is 3 feet from the global origin. Pipe node 10 [model
origin] is defined at (0,-5, 0). So, at Node 10, the pipe is buried 8 [= (3’ — (-5')] deep into the soil. Define similarly
for the other soil.

The pipe centerline is calculated by CAEPIPE from the given data.

ft 4 ft. depth

Node 10
begins at
)

Depth of Soil above Pipe’s Centerline

When the option “Value entered is Depth of Soil above pipe centerline” is turned ON in Soil input, then CAEPIPE
will compute maximum soil loads for the sections buried using the Depth entered. This option will be helpful for



modeling pipes that are running up or down a hill with the same depth of soil filled above pipe’s centerline as
shown in the flgure glven below.

Hill'crest _')

Warning:

Assign Soil only to those elements that are really buried in soil when the option “Value entered is Depth of Soil
above pipe centerline” is turned ON.

Step 5:

Tie the soils defined above with pipe sections through Layout window > Misc > Sections or Ctrl+Shft+S (to list
Sections). Double click on the required section property. You will see the field Soil in the bottom right corner. Pick
the soil name from the drop-down combo box.

=l= Caepipe : Pipe Sections (4) - [Hydrogen_Pipelines ASME_B3112_PLmod (D:\KPDevelopm...
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Name | Nom Sch Thk | CorAl [M.Tol [Ins.Dens | Ins.Thk | Lin.Dens |LinThk | Soil
Dia (lnch) {inch) | (inch) | (%) | (bM3)  [(nch) |[(b/M3) | (inch)
1 |1 B" 40 |6.E25 |D.28 |
2 |2 16" 40 (16 05
J |2B 16" 40 |16 05 =1
4 |1B B" 40 (6625 |D.28 51
5

If a part of a piping system uses a certain pipe section with some portion of it buried and the balance not buried,
then two separate sections have to be defined, with one of them without soil and the other with soil as shown
above for Sections 2 and 2B.

Step 6:
Assign the appropriate section for each buried element on the Layout window with the correct soil around it.
Step 7:

Review the stress layout by highlighting the buried sections of the model in graphics. If your model contains
sections that are above-ground and buried, then you can selectively see only the buried sections of piping in
CAEPIPE graphics by highlighting the section that is tied to the soil. Use the Highlight feature under the Section
List window and place highlight on the buried piping section (see Highlight under List window>View menu, or
press Ctri+H). The Graphics window should highlight only that portion of the model that is using that specific
section/soil. See the portion shown in green in the figure below.
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Step 8:

It is at the bends, elbows, and branch connections that the highest stresses are found in buried piping subjected
to thermal expansion of the pipe. Hence, buried piping elements at the junction of bends, elbows and branch
connections are to be refined in the stress layout.

This can be performed through Layout window > Edit > Refine Nodal Mesh > Buried Piping. Please see the
section titled “Buried Piping” in CAEPIPE User’s Manual for details on “Nodal mesh generation”.
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Step 9:

After completing the stress layout, save the model and analyze through Layout window > File > Analyze. See the
file “Hydrogen_Pipeline_ ASME_B3112_PL.mod” available with this tutorial for further details.



Step 10:

Upon successful analysis, CAEPIPE shows the code compliance as per ASME B31.12 Part PL under Sorted
stresses as shown below.

Y
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Step 11:

Code Compliance results of CAEPIPE display the stresses on an element-by-element basis. For the tutorial
problem, a snapshot of Code Compliance results is shown below, in which the first element from node 320 to
node 330 is highlighted. You will observe that the 2nd Column titled “Press. Allow” output the following for each
element.

1. First row outputs the “Design Pressure” input for that element.

2. Second row outputs the “Calculated Allowable Pressure” for that element as per the equation provided in
ASME B31.12 PL. Please note, when the “Design Pressure” input for an element exceeds the “Allowable
Pressure” computed for that element, then CAEPIPE will change the display color of Design Pressure to RED.
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Press| Unrestrained (PL-26.5ab) | Unrestrained (PL-2.6.7) | Restrained (PL-263ah) *
# | Node | Allow. [ SL 0.755T |SL SE SA SE Seq 09ST |Seqg
(psi) | (psi) (psi) 0.7558T | (psi) (psi) SA (psi) (psi) 0.95T
30(320 |750 15400 |31500 [0.49
330 (1575 15928 |31500 |[0.51
31330 [750 162256 |31500 |0.48
| [340 |1575 16147 | 31500 051
32(340 |75.0 15347 |31500 |0.49
380 [157% 16120 | 31500 051
33380 [75.0 18320 | 31500 |0.49
| [360 [1575 18892 | 31500 050
34(370A | 75.0 15261 |31500 |0.48
370B |1575 18906 | 31500 |0.50
35380 |75.0 |[572 26250 0.02 2350 43649 [0.05
| |330  |1575 |538 26250 0.02 3158 43682 [0.07
36390 |75.0 [539 26250 0.02 3158 43683 [0.07
400 1575 |448 26250 0.02 2692 43774 [0.06
3714104 |75.0 [449 26250 0.02 6974 43774 (016
| |410B |1575 |532 26250 0.02 9433 43689 [0.22
38420 |75.0 |[532 26250 0.02 3625 43689 [0.08
430 1575 [1046 |26250 0.04 249 43165 [0.01
39430 [75.0 |[1044 |26250 0.04 249 43167 (0.01
| |440 |1575 [44B 26250 0.02 877 43777 (0.02
40440 | 750 |446 26250 0.02 877 43777 (002
450 1575 |577 26250 0.0z 737 43643 [0.02
41 |450 |75.0 |[577 26250 0.02 737 43643 [0.02
460 1575 |546 26250 0.02 737 43676 [0.02
42 (460 | 750 |546 26250 0.02 737 43676 [0.02
470 |1575 [553 26250 0.02 B61 43868 [0.02 v




CAEPIPE will show the deflections and support loads for each load case under Deflections and Support loads
results as shown below.

=l Caepipe : Displacements: Operatin +P1+T1) - [Hydrogen_Pip
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Displacements (global)

Node [X(inch) |Y(inch) |Z(inch) [XX(deg) |YY (deg)|ZZ (deg)
1 |10 0.000 0.000 0.000 00000 |0.0000 |0.0000
2 |20 0.059 -0.038  |-0.061 -0.0275 |[-0.0403 |-0.0513
3 |30 0.077 -00s0 |-0.073 |-0.0283 |[-0.0365 |-0.0611
(4 |04 |0077 -0.0s0  |-0.073 |-0.0283 |[-0.0365 |[-0.0611
5 |408 |0.059 -0019 |-0.062 00046 |0.0762 |-0.1264
6 |50 0.059 -0.019  |-0.082 00048  |00762 |-D.1264
7 |60 0.043 0.055 -0.021 00071 |0.0679 |-0.1455
G |
g |
[10]
1]
1
1
1
15

70 0.035 0.099 -0.003 00083 |0.0624 |-0.1541
80A |0.035 0.099 -0.003 00083 |0.0624 |-0.1541
80B |-0.012 0.143 0.007 00111 o03zr  |-0.0102
90 -0.012 0143 0.007 0.0111 00321 |-0.0102
100 |-0.003 0.101 -0.001 00020 |0.0245 |D.0078
110 |0.000 0.059 -0.002 0000z |0.0168 |-0.0004
120 |-0.000 0.051 -0.002 00003 |0.0154 [-0.0003
130 |-0.000 0.044 -0.002 0000z |0.0147 |-0.0001
16140 |0.000 -0.015 -0.001 -0.0005 [000%4 |0.0000
17150 |0.000 -0.073 -0.00m 0.0001 0.0041 0.0000
18160 [0.000 0131 -0.001 00000 |-0.0012 | 0.0000
(19(170 |0.000 -0.189 -0.001 -0.0002 |-0.0085 |0.0000
20180 [0.000 -0.248 -0.001 000tz |-0.011& |0.0002
21190 |0.000 -0.306 -0.003 -0.0023  |-0.0171  |-0.0002
22 |200 |0.000 -0.314 -0.002 -0.0037 |-0.0178 |-0.0004
23210 |0.000 -0.322 -0.001 -0.0024 |-0.0197 |-0.0004
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# |Node [Tag |[FX(b) |FY(b) |FZ(b) |MX(ftb) |MY (f-lb) | MZ (ftlb)
1 [10 1821 |-954  [15364 [-11876 [-19611 [-9903
2 |570 9630  |-94 798 406 |-54692 [170

3 630 410 1178|2145 |-3206  |6391  |3580
4 | 690 514 [-1067 (2075  |-2624  |-60S6  |-3240
(5 |750 478|173 2052|422 5036|525




Element forces results for each load case (such as Sustained, Operating, etc.) show the Element forces and
moments in local coordinate system along with Stress Intensification Factors (SIFs) computed as per analysis
code ASME B31.12 Part PL for each element as given below.

=l Caepipe : Pipe forces in local coordinates: Operating (W+P1+T1) - [Hydrogen Pipelines ASME B3112 PLre.. — O
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# | MNode | Axial y Shear [z Shear |  Torsion(ft-lb) Inplane(ft-lb) Outplane(ft-llb) Flex. Factors | Sopr

()} [(ls)] {Ib) Moment | SIF Moment | SIF Moment | SIF FFi |FFo |FFt | (psi)

1 |10 -16364 | 954 -1821 3903 11876 1.00 19611 1.00 3045
20 -17023 | 954 -1821 9903 1933 628 1027

2 |en -16992 | 954 -5655 3903 1933 628 1028
30 -17310 | 954 -BBRS 9903 25 -10681 1599

3 |40A  [-17273 |-10609 |-954 3903 10681 2.60 25 217 B19(819 3564
40B |-10609 |17773 |-954 -1883 -3284 2,60 -11810 217 B19(8.19 3817

4 |50 -10649 | 5178 3441 -1883 -11810 3284 1589
B0 -10649 | 5178 3865 -1883 -26B19 13025 3740

5 |60 -10693 |-13100 |[-3338 |-1883 -26619 13025 3738
70 -10693 |-13100 |[-3125 |-1883 -8152 8716 1545

6 |80A |[-10705 |-24017 |-3488 |-1883 -8152 2.60 8716 217 B19(819 3698
BOB |-24017 | 10705 |-2988 2104 18471 2.60 -4456 217 B.19(8.19 5856

7 |90 -24284 | 3292 -B5 2104 18471 -4456 1910
100 |-24284 |3292 1100 2104 -5606 -672 193

8 |100 (-24662 |-726 -379 2104 -5606 -672 1772

< >

For the design of supports, Support Load Summary of CAEPIPE will show the loads on each support for all load
cases selected for analysis as given below.

=i* Caepipe : Support load summary for anchor at node 10 - [Hydrogen_Pipelines_ASME_B3112_PL.res (
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Load combination |FX(lb)  |FY (b) |FZ(b) |M<(ft-b) | MY (f-lb) | M2 (ft-lb)
Sustained -25 -2 -2451 -49 39 57
Operating1 1821 -954 15364 -11876  |-19611  |-9903
Design 2527 -1228 22074  [-15140 |-2B577 |-125E9
Maximum 2b27 2 22074 -49 93 -57
Minirmurm -25 -1228 -2451 -15140 [-26577 |-125B69
Allowahbles 0 0 0 0 0 0

CAEPIPE displays an option “Soil Restraints” in addition to other analysis results as shown below.

=" Caepipe : Soil Restraints - [Hydrogen_Pipelines_ASME_B3112_PL.res (D:\KPDevelopment\Documents\Tuto 31_Hydroge...

File Results View Options Window Help

D& EeE=

Axial Transverse Yerical Down Verical Up =~
# |From [To  |Name | Type Stiffness | Max Load | Stiffness | Max Load | Stiffness | Max Load | Stiffness | Max Load
(Ibfinch) | (lb) (Ibfinch) | (lb) (Ibfinch) | (Ib) (Ibfinch) | (lb)
20 30 (st Cohesive (10225 |654.4 128999 | 82559 0.0 0.0 0.0 0.0

50 B0 = Cohesive |1363.4 |8726 443038 | 283544 458773 | 293615 296791 189946
6O 70 S1 Caohesive | BB81.7 4363 221513 (141772 229387 | 146807 148396 | 94973
90 100 |s1 Cohesive | 3739.7 |23934 1.215E+6 | 777737 1.258E+6 | BO5360 814072 [521006
100 |10 st Cohesive | 3739.7 |23934 1.215E+6 | 777737 1.258E+6 | 805360 814072 |521006
110|120 |51 Cohesive | 681.7 436.3 221519 (141772 229387 | 146807 148396 94973
120 130 |S1 Caohesive | B81.7 4363 221519 (141772 229387 | 146807 148396 | 94973
130|140 |51 Cohesive |5169.6 |3308.5 16B0E+E (1075105 |1.740E+6 |1113283 |1.125E+6 | 720212
140|150 |51 Cohesive | 5169.6 |33085 16B0E+G (1075105 | 1.740E+6 | 1113283 | 1.125E+6 | 720212

|u:)|m|--.||m|u1|.u|m|m|—l




