Tutorial on Analysis with Multiple Thermal Loads using CAEPIPE

General

The Reference Temperature (can be defined through Layout window > Options > Analysis” is “the
ambient temperature at which the pipe is to be/was initially installed”. In other words, when the whole
piping system is at Reference Temperature, the piping system is “stress free” and the involved pipe
supports are “loads free”, as long as there are NO cold springs introduced during the installation of the
system. There is no need to input Reference Pressure, as at installation the pressure is zero.

T1, T2 etc. (tuned ON through the “Layout window > Loads > Load cases”) refer to the temperatures
prevailing during different operational states of the piping system. Please note that the value of T1 for
the first operational state could be different for different portions of the piping system. In other words,
you could input multiple values for T1 (by having at least that many “Loads”) corresponding to different
portions of the piping. In addition, the same element in the piping system can experience different
temperatures T1, T2, T3 etc. during different operational states.

Hence, the Expansion (T1) case in the Results lists the “Range Solution” obtained for the temperature
range from Reference Temperature to T1 [i.e., (T1 — Tref)], similarly for Expansion (T2), and so on. The
Expansion (T1-T2) case in the Results lists the “Range Solution” obtained for the temperature range
from T1 to T2, which is internally computed as [(T1 - Tref) — (T2 — Tref)], similarly for Expansion (T1-T3)
and so on.

For the operating (W+P1+T1) case, CAEPIPE considers the weight, the pressure P1 corresponding to T1
and the expansion from Tref to T1.

The following are the Steps for performing Analysis with Multiple Thermal loads in CAEPIPE.

The attached stress system shows the layout of four (4) pipelines. These pipelines are connected to five
(5) centrifugal pumps at one end (with one of them being the Spare) and four (4) tanks at the other end.
Out of those 5 centrifugal pumps, Pump 2 is the Spare and will turn into operation when one of the
other 4 pumps fails. In other words, at any point in time, 4 pumps are operating with 1 pump either on
standby or not operational. To represent these, the following thermal load cases are required (see the
attached model).

Cases Description

Case 1 Pump 2 (the Spare) is “OFF” and the remaining Pumps are “ON”
Case 2 Pump 1 is “OFF” and the remaining Pumps (including Spare) are “ON”
Case 3 Pump 3 is “OFF” and the remaining Pumps (including Spare) are “ON”
Case 4 Pump 4 is “OFF” and the remaining Pumps (including Spare) are “ON”
Case 5 Pump 5 is “OFF” and the remaining Pumps (including Spare) are “ON”
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11 |25 041420 |A778 |12 |C2
(12 |30 Reducer R A778 (16 |C2
[13 |38 04160 |A778 |16 |C2
(14 |36 Location Flange

15 | Dual Disc Wafer Style Check Valve
16 |'weight = 242 b, Valve Length = 7.5"
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1 [is 16" |105 |16 | 0.188(0.04 |125

2|12 12" 1105 (1275|018 [0.04 |125
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Step 1:

The above cases can be defined in CAEPIPE by defining the “Number of Thermal loads” as 10 through
Layout window > Options > Analysis > Temperature.

Options

Code Temperature iF‘ressurel D:mamics! Misc !

Fieference temperature i@ (F]
Murnber of thermal cycles i?EIEIEI

Mumber of thermal loads © 1 ¢ 2 & 3 & 10

{* Themnal = Dperating - Sustained
™ Solve thermal case

Elastic Modulus
™ Use temperature dependent modulus

' Use modulus at reference temperature

QK ! Cancel




Step 2:

Define the Pressures and Temperatures for different operating cases described above through CAEPIPE
Layout window > Misc > Loads. Description corresponding to Loads C1 through CHL is given in the table
below for clarity.

Cases Description Pressures and Temperatures

Case 1 | Spare Pump at Node 1010 is “OFF” and | For C1, T1 = 70 degF; P1 = O psi. For others
the remaining Pumps are “ON” (C2 through C5), T1 = 250 degF and P1 = 10.1

psi

Case 2 | Pump 1 at Node 10 is “OFF” and the | For C2, T2 = 70 degF; P2 = 0 psi. For others, T2
remaining Pumps are “ON” = 250 degF and P2 = 10.1 psi

Case 3 | Pump 2 at Node 2010 is “OFF” and the | For C3, T3 = 70 degF; P3 = 0 psi. For others, T3
remaining Pumps are “ON” =250 degF and P3 = 10.1 psi

Case 4 | Pump 3 at Node 3010 is “OFF” and the | For C4, T4 = 70 degF; P4 = 0 psi. For others, T4
remaining Pumps are “ON” = 250 degF and P4 = 10.1 psi

Case 5 | Pump 4 at Node 4010 is “OFF” and the | For C5, T5 = 70 degF; P5 = 0 psi. For others, T5
remaining Pumps are “ON” = 250 degF and P5 = 10.1 psi

Load with name “CHL” is defined to represent the portion of the piping that are always HOT irrespective
of which pump is OFF. Hence, the T1 through T5 is 250 deg F and P1 through P5 is 10.1 psi.

The Load cases and Load combinations defined in the model can be seen using Layout window > Misc
> Loads and Layout Window > Loads > Load cases respectively.

Define the loads C1 through CHL as shown in the snap shot below.
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# |MName|T1 |F1 T2 |P2 |T3 [P3 |T4 |P4 |T5 |P5 |T6 |PE |T7 (F?7 |T8 |PB |T9 |P3 |T10 |PI0 |DesgT |Desg.Pr. | Specific |Addygt |Wind  |Wind  [Wind  [Wind
B |lps |7 | (psi) |7 | (psid |(F) | (el |(F) [(psh [(F) [Gpsh [(F) |(psi) |(F) | tpsi) |(F) | (psi) | (F) | (psi) | (F) (psi) grawity | (/) Load1|load?|Load 3 | Load 4
1k 0|0 250 |10 | 250 (100|250 | 101 [250 |10 (70 |0 7m0 m (o m (o m (o 250 10.1 0.01
2 |c2 250 |10 (700 |0 250 (101|250 101|250 |10 (70 |0 70 (0 70 (0 70 (0 70 (0 250 101 o0m
3 [c3 250 (101 {250 (100 (70 (O 280 (101|250 (101 |70 |0 mo|0 mo(o mo(o mo(o 250 10.1 0.01
4 |C4q 250 | 101|250 (1007 (260 (101 |70 |0 250 (107 (70 |0 70 (0 70 (0 70 (0 70 (0 250 101 o0m
5 [C5 250 (10.1 |250 |10 (280 (101|250 (1001 |70 |0 (0 mo|0 mo(o mo(o mo(o 250 10.1 0.01
B |CHL |20 |10 250 [10.1 |250 |10.1 | 250 |10 (250 (101 |?0 |0 70 (0 70 (0 70 (0 70 (0 250 101 o0m
7
Step 3:

Assign the Loads C1 through CHL to different portions of stress system as required while creating the
stress layout. After modeling the stress system, one can review the loads assigned to different portions
using the Highlight feature through “Loads List window”.

From the attached model, to review the loads assigned, place the highlight on each load (C1
through CHL) and press “Ctrl+H” or select option “Highlight” under List window >View to highlight
only that portion of the model that is using that specific load. The snap shot below highlight only
that portion of the model that is using the Load C1.
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Step 4:

Select the load cases and load combinations required for analysis through Layout window > Loads >
Load cases.

Load cases (29)

Expanzion [TZ - T3]
Expanzion [T2 - T10]
Expanzion [T3- T4]
Expanzion [T3- TH]
Expanzion [T3 - TE]
Expanzion [T3-T7]
Expanzion [T3 - TA]

0 Eanu:el| Al | Mone |

E wpanzion [T4]
E spanzion [TH]
E wpanzion [TE]
E wpanzion [T7]
E spanzion [TH]
Ewpansion [TH]
E wpanzion [T10]

Expanzion [TE- T3] [ Modal analysis
Expanzion [TE - T10]

Expanzion [T7 - TE]

Expanzion [T7 - T9]

Expanzion [T7F - T10]

Espanszion [TE- T3]

Expanzion [TE - T10]

[ Empty Weight [\ I Expansion [T1 -T2 [~ Expansion [T3-T9)] [~ Expansion [T3-T10]
v Sustained [w+F) v Expanzion [T1- T3] [ Expanzion [T3-T10] Iv Operating [w+P1+T1]
[v Sustained fw+P1) [v Ewxpanzion [T1-T4] ¥ Ewpansion [T4-T5] v Operating fw+P2+T 2]
W Sustained [w+F2) v Expanzion [T1-T5) [ E=pansion [T4- TE) W COperating [w+P3+T3]
[v Sustained fw+F3) [ Expanzion [T1 - TH] [ Expanzion [T4-T7] Iv Operating [w+Pd+T4]
v Sustained [W/+P4) [ Expansion (T1-T7) [~ Expansion (T4 - T8] ¥ Operating [w+P5+T5)
WV Sustained [w+F5) | Expanszion [T1-T8) [ Expansion (T4-T9) [ Operating [w-+PE+TE]
[ Sustained [w+PE] | Ewpangion [T1-T3) [ Ewpansion (T4 - T10] [ Operating [wW+P7+T7)
[ Sustained [wW+F7) [ Expanzion [T1-T10] [ Expansion [T5- TE) [ Operating [w+PE+T8]
[ Sustained [w/+F8) v Expanzion [TZ2- T3] [ Expansion [T5-T7) [ Operating [w+P3+T79)
[ Sustained [w+P3) v Expansion [T2 - T4) [ Expansion (TG - T8) [ Operating [w+P10+T10)
[ Sustained (w/+P10) v Expanzion [T2- T5) [ Expanzion [T5-T9] [ Design M+PD+TD]
[v E=pansion [T1] [ Expansion [TZ - TH] [ Expanzion [T5-T10] v Static zeizmic [g's)

v Expansion [T2] [ Expansion (T2- T7) [~ Expansion (TE - T7) ¥ wiind

W Expansion (T3] [ Ewpansion (T2 T8) [ Expansion [T6 - T8) W find 2
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Step 5:

Save the model and perform analysis through Layout window > File > Analyze.

In order to understand the loads and load combinations used for analysis, review the CAEPIPE results file
for Support Loads (loads acting on the supports by the piping for each load case), Element Forces &
Moments (local/global forces and moments on each element for each load case) and Support Load
Summary (listing support loads at particular support for all relevant load cases and load combinations).
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BEO .@l El = E«-» IREY=y

Node | Tag [ Fx (k) FZ(lb) | M ftHb) | MY i) Load cases

10 18 A 52 886 27 5 _

130 77 645 |70 |3pa0 |-636s " Sustaned [+P) Operaling P/+F2+T2)
1010 11 0 154 39 p Sustained [w/+F1] Operating [w+P3+T3]
2010 a 164 734 o3 - Sustained [w+F2) Operating [W+P4+T 4]
2130 80 703 |-800 4828 |-4928 LI A Operating [w/+F5+T5)
3010 75 177 754 28 27 Sustained [w+Pd) Seismic 1 (g]

3130 72 771 744 4477 452 Sustained ['w/+P5) iind

4010 33 227 836 -5 -12 Expansion [T1] i 2

4130 152 582 1259|5063 8085 Expansion [T2)

Expanzion [T 3]

E xpansion [T4]

E xpanzion [TH]
Expansion [T1-T2)
Expansion [T1-T3)
Expanszion [T1-T4)
Expansion [T1-T5)
Expansion [T2-T3)
Expansion [T2-T4)
Expansion [T2-TH)
Expansion [T3-T4)
Expansion [T3-T5)
Expansion [T4-TH)
Operating [ +F1+T1]

ok | Cancel
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A | E e ECE

Load combination O« o |« T O | < |« O O % Wl o T s P )
Sustained+Wind -180 15 3 44 B3 -B632
Dperating1 +vind -18 -162 il -2¢ 5 278
Operating +\Wind -246 44 /hE R 87 -5730
Dperating3+Wind -238 2 84z 39 84 5718
Dperatingd+vind -238 £ L 39 84 -5714
Operating5h+Wind -238 2 842 39 84 57149
Sustained+wind 2 -180 15 3 44 B3 -B632
Operating] +ind 2 -18 -162 il -2 5 278
Operating2 +Wind 2 -246 44 752 L 87 -5730
Dperating3+Wind 2 -238 2 84z 39 84 5718
Operatingd+ind & -238 g 54z 39 84 -5714
Operating5+Wind 2 -238 2 84z 39 84 57119
Sustained+Seismic1 |-174 15 1) 47 BR -5E49
sustained-Zeismic 1 |-186 14 -50 1 B0 -5734
Operatingl +3eismic1 |-12 -161 934 -14 8 34
Operatingl-Seismic1 |-24 -162 833 -2h g 23k
CperatingZ+=eismic 1 |-240 45 sk kB 40 -BEEY
Operating2-Seismic1 | -252 44 694 52 84 B2
Dperating3+=eismic 1 |-232 3 g5 42 g7 -BE7E
Cperating3-Seismic1 |-244 2 784 36 a1 -5760
Operatingd+>eismic1 | -232 3 845 42 g7 -5EYR
Operatingd-Seismic1 |-244 g 744 36 81 -5761
Cperatingb+Seismic 1 | -232 3 845 4z a7 -BE7E
Operatingb-Seismic1 |-244 p 784 36 81 -5761
hdaEximurm -1 45 934 i 30 3E1
binirmum -252 -162 -50 -2h g 5772
Allowables 0 0 0 0 0 0

The Sorted Stresses in CAEPIPE lists the maximum of Expansion stresses for all thermal range cases at
each node as well as the maximum of Sustained + Occasional stresses for all Occasional cases at each
node. On the other hand, for the Sustained case, it always uses the maximum pressure among the input
pressures (P1 through P10) while computing Sustained Stress at each node.
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Sustained Expansion Occasional
# SL [sH  |SL SE [8A  |SE. S0 |1.25H |30 |
Mode ((psi) |(ps)) |SH |Mode |(ps) |(psn | SA | Mode |(psi) (ps) | 1.25H

1 77004 | 46385 | 13450 (0.34 | 1204 | 7165 | 34103 | 0.21 | 904 [ 4606 | 16740 | 0.30
2 904 (452313450 | 0.34 | 7700A | 6793 [ 33752 | 0.20 | 7700A | 4685 | 16140 |0.29
3 [120A (4234 (13450 | 032 | 41104 | 7377 (37940 | 0191204 | 4596 | 16140 |0.28
4 [120B |3710(13450 | 0.28|120B |5932 (30551 |019|120B | 3960 (16140 (0.25
5 [90B [3703 (13450 | 02821104 | 7069 (37785 (019908 | 3652 | 16140 (0.24
B [100A 3701 (13450 | 028 | 2120A | BBEE [ 37716 | 016 100A | 3549 (16140 (0.24
7105 3378 (13450 | 02531104 | 6736 [ 37812 | 016|105 3631 | 16740 | 0.22
g |25 3116 (13450 | 0.23|90A | B176 (29720 | 017|258 3141 {16740 | 0.19
9 |20 3109 (13450 | 0.23 | 31204 | 6487 [ 37984 |07 ] 20 313316740 | 0.19

1 | a0 2932 (13450 | 0.22 | 41204 | BOBO [ 37526 | 016 | G0 2975 | 16740 | 0.15
11 1106 2581 (13450 | 0191104 | 5452 (37323 | 0151108 | 2703 | 16140 (017
12 |2105 |2468 (13450 | 01840904 | 5214 [ 36692 | 014 | 2105 | 2698 | 16140 (017
13 | 3105 (2328 (13450 (017 |20 4245 [ 31164 | 0,14 | 2090A | 2607 | 16140 (016
14 (140 2298 (13450 | 017|906 | 4004 [ 30557 {013 ] 3105 | 2554 | 16140 (016

Similarly, Code Compliance report lists the Stresses element-wise following the same procedure as done
for Sorted Stresses.
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BED GAR EE

Fress. Sustained Expansion Occasional
# |MNode |Allow [SL [SH SL [SE |SA  |SE |50 |1.25H|S0
(psi) |i{psi) [(psi) |SH |({psi) [(psi) [SA | (psi]) [(psi) |1.25H
1 20 100 | 3709 | 13450 | 0.23 | 4248 | 31164 (0.4 3133 | 16740 | 0.19
25 250 | 3176 | 13450 | 0.23 | 3269 | 31157 (0.0 | 3740 | 16740 | 0.19

2 |25 100 | 3116 | 13450 | 0.23 | 3272 | 31157 (0071 | 3141 | 16740 | 0.19
3 1927 | 13450 | 0.14 11988 | 32371 | 0.06 | 1946 | 16740 |0.12

3 |30 100 | 1925 | 13450 | 014 | 1980 | 32374 (0.06 | 1944 | 16140 | 012
35 &N 1940 | 13450 | 0.14 | 1984 | 32359 | 0.06 | 1961 | 16140 |0.12

4 140 100 | 1981 | 13450 | 015 | 19971 | 32316 (0.06 | 2007 | 16140 | 0.12
&0 Zn 2119 113450 | 016 | 2007 | 32176 |0.06 | 2165 | 16740 | 0.13

5 |50 100 | 2119 | 13450 | 016 | 2007 | 32176 (0.06 | 2165 | 16140 | 0.13
&a 2N 1985 | 13450 | 015 | 2005 | 32313 | 0.06 | 2008 [ 16140 |0.12

6 |70 100 | 1970 | 13450 | 015 | 2045 | 32327 (0.06 | 1994 | 16140 | 012
140 &N 2298 | 13450 | 017 | 2297 | 31993 | 0.07 | 2325 | 16740 | 0.14

71140 100 | 2298 | 13450 | 017 | 2297 | 31993 (0.07 | 2325 | 16140 | 0.14
g0 Zn 2844 113450 | 0.21 | 2744 | 31435 | 0.09 | 2895 | 16740 | 0.18

g |a0 100 | 2363 | 13450 | 016 | 2135 | 31927 (0.07 | 2436 | 16140 | 0.15
150 2N 2137 | 13450 | 01611908 | 32157 | 0.06 ) 2213 | 16140 | 0.14




