Tutorial on Evaluation of Nozzles by computing
Local Shell Stresses as per WRC 537
and
Stress Evaluation as per ASME Section VIII Division 2
using CAEPIPE

General

Whenever Pressure Vessel or Heat exchanger (Static Equipment) nozzle loads exceed the allowable
values provided by the Vendor (Equipment manufacturer), the piping stress professional is permitted to
use WRC 107 (or WRC 537 or any other FEA) to calculate the local shell stresses at the Nozzle-Shell
junction and evaluate those stresses with allowable values provided by an appropriate ASME Code. If
the stresses are found to be within those allowable values, then the nozzle loads computed by pipe
stress analysis are considered as acceptable.

This tutorial provides stepwise procedure to
1. Model the nozzle-to-shell junction as “Nozzle” to incorporate local shell flexibility.
2. Compute Loads on Nozzle by performing piping flexibility analysis.
3. Compute Local Shell Stresses at Nozzle attached to Cylindrical Vessel as per WRC 537 and
4

Evaluate Stresses as per ASME Section VIl Division 2.
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Step 1:

Pipe stress model for the layout shown above is first developed using CAEPIPE. The model is supplied
along with this tutorial.

Step 2:

In the above snap shot, Node 340 is connecting to Nozzle M1 of a Cylindrical Vessel as shown in the
figure below.
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Vessel 0D = 63" and Vessel Thickness =0.35"
Mozzle OD =22" and Nozzle Thickness =1"

From the Equipment Datasheet, the following data were referred and listed below for quick reference.

1. Equipment Material = SA335 Grade P91

Maximum Metal Temperature (T) = 230 Deg. F

Minimum Metal Temperature (Trf) = 70 Deg. F

Operating Pressure (P) = 15 psi

Peak Pressure during Occasional event = 20 psi

Sc = Basic Allowable Stress at Minimum Metal Temperature for the Shell = 35400 psi
7. Sk =Basic Allowable Stress at Maximum Metal Temperature for the Shell = 35400 psi
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For example, as per Clause 5.2.2.4 of ASME Section VIII Division 2 (2017), the Allowable Stress (All) for
both “Sustained” and “Sustained + Occasional” load case is to be entered as “1.5S,”, where S;, is the
basic allowable stress at maximum metal temperature for Shell.

Similarly, as per Clause 5.5.6 of ASME Section VIII Division 2 (2017), the Allowable Stress (All) for
Operating load case should be entered as “3 (Sc + Sn)/2 = 1.5 (Sc + Sn)”, where Sc is the allowable stress at
minimum metal temperature for Shell and Sy is defined above.

Sustained and Sustained + Occasional Allowable = 1.55, = 1.5 x 35400 = 53100 psi
Operating Allowable (All) = 1.5 (Sc + Sh) = 1.5 (35400 + 35400) = 106200 psi



Step 3:

From the equipment drawings provided by the manufacturer as shown above, the properties are
entered into CAEPIPE Nozzle at Node 340 for performing the flexibility analysis.

Mozzle at node 340

Mozzle Tag
v Cylindrical Vessel ™ Flat bottom tank,

[~ Spherical Vessel
— Mozzle

oo [z finch)  Thk [T finch)

—Wezzel

oo [52 linch]  Thk [0.35 finch)
L1 |5'EI" [ftin"] L2 |2'EI" [ftin"]
Elastic: madulus of vessel material |2?.BE+E [pi]

Yeszel aniz direction
¥ comp Y comp £ comp

| {1.000 [

k. I Eancell Displacementsl

From the figure shown above, Lengths L1 and L2 on either side of the nozzle, which are the distances
from the nozzle center line to the nearest location on vessel where the "ovalization deformation" of the
vessel is stopped such as at a stiffener on the inner or outer surface of the vessel, or at the center of a
saddle support to the vessel or at the junction to the enclosure (also called the head) or at a tube sheet

inside the vessel etc.

Step 4:

Save the CAEPIPE model and perform the analysis through Layout window > File > Analyze. CAEPIPE will
include in the pipe stress analysis the local shell stiffnesses internally computed. These local shell
stiffnesses can be seen in CAEPIPE through Layout window > View > List > Nozzle stiffnesses.
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# [Mode |Wess. |Radial (kp] | Circumferential [kmc] | Longitudinal [kml]
Type |(Ibfinch] | [in-lb/deq) [in-lb/deq)

1 ]340 |Col  [1.437E+7 [FOE22.88 8.6ERBE+5
|2 |B20 |Cyl | 1.437E+7 | 70EZ288 8.6ERE+5




Step 5:

Upon successful analysis, from the Support Loads results for different Load Cases, note down the forces
and moments at Node 340 as shown below.

=l Caepipe : Support load summary for nozzle at node 340 - [M441_Layout.res (C\Tutorials\11_12_...

File Results View Options Window Help
BED @R Be| 5 e
Load combination | Radial (P] |y Shear VL] | z Shear [VC) | Torque (MT] | Cire.Mom [MC] | Long.Mam [ML]
(Ib) (Ib) (Ib) (ft-Ib) (ft-Ib) (ft-1b)
Sustained 90 -34 -43 673 -138 1842
Operating1 137 332 -847 A7117 828 3386
Sustained+Seismic | 485 1733 955 8058 577 5653
Sustained-Seismic | -306 -1868 -1041 -3404 -853 -1970
Dperatingl +Seismic | 532 21686 150 -8386 1543 7798
Dperatingl-Seismic [-253 1502 1845 -25847 113 175
M asirnLim 532 2166 955 8058 1543 7738
Minirmum -306 -1868 -1845 -25847 -853 -1970
Allowables 0 0 0 0 1} 0

Step 6:

As stated in the Section titled “Nozzle Evaluation” of CAEPIPE Technical Reference Manual, Pressure
Stress at Shell (Pm) and Bending Stress at Shell (Pb) need to be manually calculated or determined using
computer programs and input in the “Nozzle Evaluation” Module.

where,

Pm is the Average Primary Membrane Stress across the cross-section of the vessel away from Gross
Structural Discontinuities such as a Nozzle and

Pb is the Primary Bending Stress (axial stress across the entire cross-section proportional to the distance
from the Axis of the Vessel) due to “Primary” External Loads such as Weight, Wind, Earthquake, etc.
away from Gross Structural Discontinuities such as a Nozzle.

As per the above document, for a Cylindrical Shell such as Pressure Vessel/Pre-heater/Tank, to be
conservative, Pm due to Internal Pressure is the Circumferential Stress = PD/2T, where D is the Mean
Diameter of the Cylinder.

So, Pm (for Sustained and Operating) = 15 x (63-0.35)/(2x0.35) = 1342.5 psi.
Pm (for Sustained + Occasional) = 20 x (63-0.35)/(2x0.35) = 1790 psi.

Similarly, in order to compute the Primary Bending Stress (Pb), a sample model shown below has been
developed using CAEPIPE.
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I.l I Ih»
MName Description yw | Density | M Joint |Yield |Tensile |# |Temp |E Alpha | Allowahble

pe {Ibyin3) factor | (psi) | (psi) (F (psi) (infin/F) | (psi)
1 [pa SA4335 Grade P91 |[FS [0.263 |03 |1.00 |60000 1 100 |30.8E+6 |5.90E-6 | 35400
2 ‘2 |200 |30.3E+6 |6.00E-6 | 35400
N '3 |300 |29.7E+6 |6.20E-6 | 35400
B [4 |400 | 29.2E+6 |6.30E-6 | 35400
B |5 |s00 | 26.6E+G |6.40E- | 35400

B
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Mame F1 | Desg T |Desg.Pr. | Specific | AddM\Wat. | Wind  |Wind  [Wind | Wind
(FJ (psi) | (F) (psi) grasity | (/) Load1 (Load 2 | Load 3 |Load 4

1 |l 230 [15.0 | 230 15.0 0.003
2 L2 0|0 70 a

*i* Caepipe : Pipe Sections (2] - [Preheater.mod (CA\Tutorials\MozzleQualification\Stresses)]
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Marme | MNaom Thk | Cor&l | M Tal | Ins.Dens | Ins. Thk | Lin.Dens | Lin. Thk | Sail
Dia (mu:h]l finch) [finch) (28] | (Ib/f3) (inch) | (Ib/ft3) {inch)

1 |b3 Man Stel B3 |0.35
2 |ss |10 STD|10.75 |0.365




From the Analysis results, the Stresses obtained at Nozzle Location (Node 20) are as follows.

=i Caepipe : Pipe forces in local coordinates: Sustained (W+P) - [Preheater.res (C\Tutonals\NozzleQualification\Stresses)]
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# [MNode | Axial y Shear |z Shear |  Torsionift-lb) Inplane(ftb) Cutplane(ft-lb) Flex. Factors | SL
{Ib) {Ib) (b} koment | SIF toment | SIF kMoment | SIF FFi | FFao | FFt | (psi)

1 |10 0 0 0 0 0 0 664
20 0 476 0 0 -476 0 B9

2 |20 -21 -833 0 0 -952 0 674
30 -21 -357 0 0 238 0 BEB

3 |30 -21 -357 0 0 238 0 666
40 -21 833 0 0 -952 0 674

4 |40 0 -476 0 0 -476 0 BE9
50 0 0 0 0 0 0 664
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# [MNode | Axial v Shear |z Shear Torsion(ft-Ib) Inplane(ft-k) Dutplane(ft-lb) Flex. Factors | Sopr

{Ib) (3] {1k} Maoment | SIF MMoment | SIF Moment | SIF FFi | FFa | FFt| (psi)

1 (10 0 0 0 0 0 0 BE4
20 0 476 0 0 -478 0 GBS

2 |20 -1669933 | -833 0 0 -296993 0 26899
30 -1669933 |-357 0 0 -295603 0 2h886

3 (30 -1669933 | -357 0 0 -295803 0 2hiath
40 -1669933 | 833 0 0 -296993 0 2ha39

4 (40 0 -476 0 0 -476 0 664
50 0 0 0 0 0 0 BE4

"i* Caepipe : Pipe forces in local coordinates: Seismic 1(g) - [Preheater.res (Ch\Tutonals\NozzleQualification\Stresses)]
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# [MNode | Axial w Shear |z Shear | Torsionift-lb) Inplane(ft-k) Cutplane(ft-lk) Flex. Factors | SL+S0 | SA SL+30

{Ib) {Ib) (b} Moment | SIF Moment | SIF tMoment | SIF FFi | FFao | FFt | (psi) (psi) |34

1 (10 0 0 0 0 0 0 664 47082 | 0.01
20 143 35 143 0 35 143 673 47082 | 0.01

2 (20 250 167 250 0 194 284 B82 47082 | 0.01
30 107 72 107 0 51 72 6EY 47082 | 0.0

3 |30 107 72 107 0 21 72 669 47082 | 0.0
40 2h0 167 250 0 1494 264 632 47082 | 0.01

4 140 143 35 143 0 35 143 673 47082 | 0.01
50 0 0 0 0 0 0 BE4 47082 | 0.01

Since ASME B31.3 is selected for Analysis, the Axial Stress term (F/A) is included in the Stress
Calculations.



Step 7:

From the above steps, the data obtained are summarized below.

SI. No | Description Sustained Sustained + | Operating
Occasional *

1 Axial Load (P) (Ib) 90 485 137

2 Shear Load (V¢) (Ib) -43 -1041 -847

3 Shear Load (Vy) (Ib) -34 -1868 332

4 Torsional Moment (My) (ft-1b) -673 -9404 -17117

5 Circ. Moment (M) (ft-Ib) -138 -853 828

6 Longitudinal (M,) (ft-1b) 1842 5653 3986

7 Pressure Stress at Shell (Pr) (psi) 1342.5 1790 1342.5

8 Bending Stress at Shell (Py) (psi) 674%* 682%* 26899**

9 Allowable Stress at Shell (A)) 53100 53100 106200

* Maximum Absolute (Signed) forces and moments of “Sustained + Seismic” and “Sustained — Seismic”
are used for calculating local shell stresses for “Sustained + Occasional” load case.

** Bending Stresses at shell (Pb) are taken from the sample model as explained in step 6 and the bending
stress values in the above table are corresponding to the element from nodes 20 to 30 as shown in the
snapshots.

Using the above data as well as the Vessel and Nozzle Parameters, create three (3) Nozzle Evaluation
files corresponding to Sustained, Sustained + Occasional and Operating load cases.

Step 8:

Create “Nozzle Evaluation” File through CAEPIPE Main Frame > New > Nozzle Evaluation (.noz).

" Madel [rmod)
" Matenal Library [.mat)

" Spectm Library [.zpe]
" Yalve Libram [val)

(" Beamn Section Library [.bl)
" Flange Qualification [.flg)
{* Mozzle Evaluation [ noz)

" Lug Ewvaluation [lug)

] 4 | Cancel |




Double click on the Layout and input the values corresponding to Sustained load case in the Dialog Box
as shown below.

Mozzle Bvaluation

Tite |

Code |L|:u:al Shell Strezzes at Nozzles - WHLC Bulletin 537 j

(" Mozzle to Spherical Shell ™ Nozzle ta Cylindrical Shell

Load Caze |Sustained ﬂ
RadislLoad(F) 30 (i)
ShearLoad VC) 42 (i)
ShearLoad WL [34 i)
Circurnferential boment [MC) I'I?-E— [ft-Ib)
Longitudingl Mament (ML) 1842 [fth)
Torsional Momert (MT) 673 [flb)
Vessel Thickness (T] [0.35  jinchl
YWeszzel Mean Radiuz [Rm) W [inch)
Maozzle Outside Badius [ma) |'|'|— [irzh)
Mozzle Thickness[) [0 [inch)
Maozzle bMean Radius (im) ID— [irzh)
Filet Badius ) [T [inchl
Fressure Stressz at Shell [Pm) W [psi]
Bending Stress at Shell (P [674  [psi)
Sustaired Alowable [8] (53100 [psi
Strezs Canc. Factor - Tension [Kn) IEIEIEI—
Stregz Conc. Factor - Bending [FB) IEII:IEI—

Ok Canicel

LR A

Save the file through File > Save and analyze through File > Analyze. The evaluation results obtained are
shown below.
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File Edit Optiens Help
L
Calculation of Local Stresses in Cylindrical Shells as per WRC Bulletin 537 (psi)
Stresses Fig.Mo Au Al Bu Bl Cu Cl Du Dl
Circumferential Membrane (F) ic -29 -29 -29 -29 -29 -29 -29 -29
Circumferential Bending (P) 2C-1 0 0 0 0 0 0 0 0
Circumterential Bending (P) 1c 0 0 0 0 0 0 0 0
Circumferential Membrane (MC) 34, 0 0 0 0 49 49 -49 -49
Circumferential Bending (MC) 14, 0 0 0 0 0 0 0 0
Circumferential Membrane (ML) 3B 131 -1311 1311 1311 0 0 0 0
Circumferential Bending (ML) 1B-1 0 0 0 0 0 0 0 0
Circumferential Stresses (Sp) - =130 -1341 1282 1282 19 19 -78 -78
Longitudinal Membrane (F) 4c -88 -88 -88 -88 -88 -88 -88 -88
Longitudinal Bending (P) 1C-1 0 0 0 0 0 0 0 0
Longitudinal Bending (F) 2C 0 0 0 0 0 0 0 0
Longitudinal Membrane (MC) 44 0 0 0 0 140 140 -190 -190
Longitudinal Bending (MC) 24, 0 0 0 0 0 0 0 0
Longitudinal Membrane (ML) 48 -700 -700 700 700 0 0 0 0
Longitudinal Bending (ML) 2B-1 0 0 0 0 0 0 0 0
Longitudinal Stresses (5x) - -788 -788 612 612 102 102 -277 -277
Shear Stress (v1) - -4 -4 4 4 0 0 0 0
Shear Stress VE) - 0 0 0 0 3 3 -3 -3
Shear Stress (MT) - -30 -30 -30 -30 -30 -30 -30 -30
Shear Stresses (2) - -34 -34 =27 =27 -28 -28 -33 -33
Cornbined Stress Intensity (P1) - 1343 1343 12483 12483 110 110 283 283
Stress Compliance as per ASME Section Wl Division 2 - Sustained Load

CalculatedAllowed  Ratio Status
Stress (Pm+Ph+Pl) (psi) 3360 53100 0.063 Fass

Similarly, create two (2) other models corresponding to “Sustained + Occasional” and “Operating” load
cases as shown below.



Mozzle Evaluation

Tite |

Code |L|:u:a| Shell Strezszes at Mozzles - WRC Bulletin 537

" Mozzle to Sphernical 5hell

* Mozzle to Cylindrical Shell

-]

Load Case |Sustained + Oocasional

Radial Load [P] |4585

Shear Load [WC] |-104
Shear Load [WL) |-1968
Circumferential b oment [MC) |-853

Longitudinal Morment (ML) lﬁ
Torgional Mornent (MT) W

Veszel Thickness [T) IEIEEi

Vessel Mean Radiuz (Fim) W

Mozzle Dutside B adiug [ro) lﬂi

Mozzle Thickness [t lﬂi

Mozzle Mean Radius (rm) lﬂi

Fillet B adiuz [r]

Prezzure Strezs at Shell [Pm] IV
Bending Stress at Shell (Pb] (6822
Sustained + Occasional Allowable (4] W
Strezs Conc. Factor - Tension [Kn) IEIEIDi
Stresz Conc. Factor - Bending [Kb) IEIEIDi

T

|
i1b)
i1b)
(1b)
[Ft-Ib)
[ft-lb]
[ft-lb]
finch)
[inch)
finch)
finch)
finch)
[inch)
[psi)
[psi)

[psi]

Caricel
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Calculation of Local Stresses in Cylindrical Shells as per WRC Bulletin 537 (psi)

Stresses Fig.Mo
Circumferential Membrane (F) ic
Circumferential Bending (P) 2C-1
Circumterential Bending (P) 1c
Circumferential Membrane (MC) 34,
Circumferential Bending (MC) 14,
Circumferential Membrane (ML) 3B
Circumferential Bending (ML) 1B-1

Circumferential Stresses (Sp) -

Longitudinal Membrane (F) 4c
Longitudinal Bending (P) 1C-1
Longitudinal Bending (F) 2C
Longitudinal Membrane (MC) 44
Longitudinal Bending (MC) 24,
Longitudinal Membrane (ML) 48
Longitudinal Bending (ML) 2B-1

Longitudinal Stresses (Sx) -
Shear Stress (v1) -
Shear Stress VE) -
Shear Stress (MT) -

Shear Stresses (2) -

Cormbined Stress Intensity (P1) -

Au
-168
i

0

0

0
-4025

-4183

-473

-424

-510

4335

Bl
-158

4025

1867

-473

i3
0
-424

-338

3918

Stress Compliance as per ASME Section Wl Division 2 - Sustained + Occasional Load

Calculated Allowed
53100

Stress (Pm+Ph+Pl) (psi) 6307

Al Bu
-168 -168
0 0

0 0

0 0

0 0
-4025 4025
0 0
-4183 3867
-473 -473
0 0

0 0

0 0

0 0
-2148 2148
0 0
-2621 1675
86 86

0 0
-424 -424
-510 -338
4335 3918
Ratio Status
IR Pass

699

154

-424

=270

IS

Cl
-158

699

154

-424

-270

IS

-1645

-154

-424

-579

1881

-1645

-154

-424

-579

1881




Mozzle Evaluation

Tite |

Code |L|:u:a| Shell Strezszes at Mozzles - WRC Bulletin 537

" Mozzle to Sphernical 5hell

-]

* Mozzle to Cylindrical Shell

Load Case |Dperating

RadialLoad (] [137

Shear Load [VC) |-847
Shearload (VL) [332
Circurnferemtial Moment (MC) lﬁzﬂi
Longitudinal Morment (ML) IW
Torgional Mornent (MT) W
Veszel Thickness [T) IEIEEi
Vessel Mean Radiuz (Fim) W
Mozzle Dutside B adiug [ro) lﬂi
Mozzle Thickness [t lﬂi
Mozzle Mean R adiuz [rm) lﬂi
Fillet B adiuz [r]
Prezzure Strezs at Shell [Pm] W
Bending Stress at Shell [Pb] (26899
Operating Allowsble [&1] [108200
Strezs Conc. Factor - Tension [Kn) IEIEIDi
Stresz Conc. Factor - Bending [Kb) IEIEIDi

T

|

i1b)
i1b)
(1b)
[Ft-Ib)
[ft-lb]
[ft-lb]
finch)
[inch)
finch)
finch)
finch)
[inch)
[psi)
[psi)

[psi]

Caricel

A
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Calculation of Local Stresses in Cylindrical Shells as per WRC Bulletin 537 (psi)
Stresses Fig.Mo Au Al Bu Bl Cu Cl Du Dl
Circumferential Membrane (F) ic -45 -45 -45 -45 -45 -45 -45 -45
Circumferential Bending (P) 2C-1 52 52 52 RZ 0 0 0 0
Circumterential Bending (P) 1c 0 0 0 0 -229 229 -229 229
Circumferential Membrane (MC) 34, 0 0 0 0 -292 -292 29z 29z
Circumferential Bending (MC) 1A 0 0 0 0 -3 11 11 -3
Circumferential Membrane (ML) 3B -2838 -2838 2838 2838 0 0 0 0
Circurnferential Bending (ML) 1B-1 -2051 2051 2051 -2051 0 0 0 0
Circumferential Stresses (Sp) - -4985 -780 4792 795 -3677 3003 3130 -2635
Longitudinal Membrane (F) ic -134 -134 -134 -134 -134 -134 -134 -134
Longitudinal Bending (F) 1C-1 -151 151 -151 151 0 0 0 0
Longitudinal Bending (F) 2C 0 0 0 0 L1 -h8 L1 -h8
Longitudinal Membrane (WMC) 4 0 0 0 0 -1138 -1138 1138 1138
Longitudinal Bending (MC) 25 0 0 0 0 -1184 1184 1184 -1184
Longitudinal Membrane (ML) 4B -1515 -1515 1515 1515 0 0 0 0
Longitudinal Bending (ML) b1 -3e12 |1z |1z -3612 0 0 0 0
Longitudinal Stresses (5x) - B2 2115 4843 -2080 -2398 -145 2247 -238
Shear Stress (1) - -0 -0 70 70 0 0 0 0
Shear Stress (WE) - 0 0 0 0 -2? -2? 27 27
Shear Stress (MT) - -772 -7i2 -772 -7 -7 772 -2 772
Shear Stresses (£) - 842 -g42 -702 -702 -743 -799 =744 -4
Cornbined Stress Intensity (PL+Q) - G067 3344 5520 3199 4061 3531 3554 2847
Stress Compliance as per ASME Section Wl Division 2 - Operating Loacd
CalculatedAllowed  Ratio Status

Strass (Pm+Ph+Fl+ Q) (psi) 34309 106200 0.323 Fass

Step 9:

From the Evaluation Results, it is observed that as per Clauses 5.2.2.4 and 5.5.6 of ASME Section VIII
Division 2 (2017), the Local Shell Stresses Computed at Nozzle meets the requirements.

1. Sustained Stress (Pm+Pb+Pl) = 3360 psi < 53100 psi.
2. Sustained + Occasional Stress (Pm+Pb+PI) = 6807 psi < 53100 psi and
3. Operating Stress (Pm+Pb+PI+Q) = 34309 psi < 106200 psi

Note:

CAEPIPE Models, Material Properties Referred and Nozzle Evaluation Files created are supplied along
with the tutorial package for reference.



