Tutorial on Refrigeration Piping using CAEPIPE
Steps to perform Analysis of Refrigeration Piping with ASME B31.5 Code using CAEPIPE:

The snap shot below shows the sample layout of a refrigeration piping system. The system experiences
two (2) different temperatures during its operation (from -50 deg. F to 200 deg. F) with installation
temperature as 70 deg. F. Being refrigeration piping, the analysis code is selected as ASME B31.5 for this

system.
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Step 1:
Select the Analysis code as ASME B31.5 through Layout Window > Options > Analysis as shown below.

Analysis Options

Code ITernperaturel F‘ressurel Dynarnicsl Misc |

Piping code

[~ Use B31J for 5IFs and Flesibility Fackors
W Include axial force in stress calculations

¥ Use liberal allowable stresses

0K I Cancel




Step 2:

As the piping layout involves two (2) operating temperatures, “Number of Thermal Loads” needs to be
set as “2”. This can be done through Layout Window > Analysis > Temperature as shown below. In
addition, the installation temperature (same as “Reference temperature”) can be input as shown below.

Analysis Options

Code  Temperature 3Pressurel D:mamics} Misc 1

Reference temperature iﬁ [F]
Humber of thermal cycles ;?'EIEIEI

Mumber of thermal loads & 1 & 2 ¢ 3 10

% Thermal = Operating - Sustained
7 Solve themal case

r Elastic b odulus

Note:

As per para. 519.4.5(a) of ASME B31.5 (2022), bending and torsional stresses shall be computed using
the as-installed modulus of elasticity, i.e.,, E. at installation temperature (same as “Reference
temperature”). Hence, "Use modulus at reference temperature" is set as "default" and is disabled for
user to modify.

Step 3:

Enter the Operating temperatures of the piping layout through “Layout Window > Misc > Loads” as
shown below.

iI* Caepipe : Loads (1) - [refrigerationpiping.mod (ch\tutorials\refrigerationpiping]]
File Edit Wiew Options Misc Window Help

IID @\ 0 OeE=

Mame Desg.T | Desg.Pr. | Specific | Add\Wat. ['Wind  |Wind  [%Wind  |Wind
(FJ (p9|) (FJ (p5|] (F (psi) grasity | (k) Load 1 [Load 2 |Load 3 [Load 4
L1 -50 | 100 (200 100 | 240 125 0.0m
2
Note:

Design Temperature entered will be used to determine the allowable stress for material, which is in turn
used to compute the Allowable Pressure as per the piping code selected (B31.5 in this case).

The Allowable Pressure so computed as per the piping code selected is then compared against the
Design Pressure entered above and reported in the Code Compliance results.

In addition, starting CAEPIPE Version 10.20, a new load case called “Design (W+PD+TD)” is added. When
this load case is selected for Analysis, CAEPIPE will compute and show results for Displacements,



Element Forces & Moments, Support Loads and Support Load Summary. This load cases is NOT included
in Stress Calculations, Rotating Equipment Qualifications and Flange Equivalent Pressure Calculations.

Step 4:

Select the material properties corresponding to “A53 Grade A (SEAMLESS)” through “Layout Window >
Misc > Materials > File > Library...”.

Matenal Library - [B311-2022.mat...
Fiping code : B31.1

# | Material D escription

1 |A53 GRADE & [SEAMLESS] |
(2 | 453 GRADE B [SEAMLESS)
(3 | 453 GRADE & [ERW)
|4 | 453 GRADE B [ERw)
5 |A105 GRADE &
‘5 |&105 GRADEB
7]
8|
El
10 |
11 ]

2106 GRADE C
&108

2135 GRADE A&
4135 GRADE B
&181 CLASS B0
12 |&181 CLASS 70

(] | Cancel | Library |

From the dialog box shown, select the Material library as B315-2016 from the folder “Material_Library”
available inside the CAEPIPE installation folder. Once selected, highlight the material as shown above
and press the button “OK”.

*i* Caepipe : Matenals (1) - [refngerationpiping.mod (chtutonals\refngerationpiping]]

File Edit View Options Misc Window Help
IID@@I l«»
Marme Description Ty | Density | M Joint | # |[Temp |E Alpha | Allowable
pe | (bfin3) factar (F (psi) (infin/F) | (psi)
1 [259 AB3 GRADE A (SEAMLESS) |CS [0283 |03 [100 [1 |20  [29.7E+6 |6.32E-6 | 13700
2 (2 |70 |29.4E+5 |6.40E-6 | 13700
B (3 |100 | 29.3E+6 |6.47E-5 | 13700
B (4 |200 | 28.8E+6 |6.70E-5 | 13700
B 5 |300 |28.3E+ |6.90E-5 | 13700
B (6 |400 |27.4E+6 |7.10E-6 | 13700
B 7 |s00 | 2738+ | 7.30E-6 | 13700
N '8 |00 | 265E+6 | 7.40E6 | 13700
N (9 |650 | 26.0E+6 | 7.50E6 | 13700
N (10 |700 | 255E+6 | 7.60E6 | 12500
N (11 |750 | 249E+6 | 7.70E6 | 10700
B (12800 |242E+5 | 7.80E-6 |9000
Step 5:

Define the section properties through “Layout Window > Misc > Sections”.
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# |MName [Nom | Sch Thk [CorAl [M.Tol|Ins.Dens | Ins.Thk | LinDens | Lin Thk | Soil
Dia (lnc:h) {inchy | (inch) [(32) [ (lb/f3) {inchy | {Ib/ft3) {inch)

1 |B B" 105 [B.E25 |D.134

2 |4 4" 105 (45 niz

Step 6:

Generate the piping layout as shown below.

I* Caepipe : Layout (14) - [refngerationpiping.mod (chtutonals\r...

File Edit View Options Loads Misc Window Help
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# |Node [Type  |DXtin") |DY tin") | DZ ftin") | Matl | Sect | Load | Data

1 | Title = Tutorial on Refrigeration Fiping

2 |10 From Anchor
3 |20 Reducer |-0"11" A3 | B L1

4 (30 Bend -01ot ABRT | B L1

5 (40 Bz AB3 | B L1

B |50 -1'6" AB3 | B L1

7 |60 Bend -2z ABRT | B L1

8 (70 Bend -1'g" A3 | B L1

9 (80 2" AB3 | B L1

10 (30 1'6" AB3 | B L1

11 (100 0g" A3 | B L1

12 (110 |Reducer 0" A3 |4 L1

13 (120 4" AB3 |4 L1

14(130  |Reducer 0'g" AB3 | B L1 Anchor
15

Step 7:

After creating the stress model, turn ON load cases through “Layout Window > Loads > Load cases as
follows: Expansion (T1) {which is the same as the range (T1 — Tref)}, Expansion (T2) {which is the same as
the range (T2 — Tref)}, and Expansion (T1 —T2) [= (T1 — Tref) - (T2 — Tref)].

Load cases [6)

[v Sustained [ +P] [v Expansion [T1-T2)
[ Empty *eight [ [v Operating [ +P1+T1]
[ Sustained [w/+F1] [v Operating [ +P2+T2)
[v Expansion [T1] [ Design [w+PD+TD]
[v Expansion (T2 [ Modal analpsiz
ITI Cancel | Al | Mone |




After analysis, Expansion Stress (SE) value given at any node in Results Window > Sorted stresses and
Results Window > Code compliance is the highest thermal stress range at that node among the three
thermal ranges (T1 —Tref), (T2 — Tref) and (T1 - T2).

Step 8:
Save the model and perform analysis through Layout window > File > Analyze.

In order to understand the loads and load combinations used for analysis, review the CAEPIPE results file
for Sorted Stress, Code Compliance, Displacements, Support Loads (loads acting on the supports by the
piping for each load case), Element Forces & Moments (local/global forces and moments on each
element for each load case) and Support Load Summary (listing support loads at a particular support for
all relevant load cases and load combinations).

As stated above, Sorted Stresses in CAEPIPE lists the maximum of Expansion stresses for all thermal
range cases at each node. On the other hand, for Sustained case, it always uses the maximum pressure
among the input pressures (P1 and P2 in this case) while computing Sustained Stress at each node.

=i~ Caepipe : B31.5 (2022) Code compliance (Sorted stress

File Results View Options Window Help
= HHA
Sustained Expansion
# SL[SH  [sSL. SE |84 [SE
Mode | (psi) |(psi) | SH | Mode |(psi) | (psi] |34
1 |10 1647 | 13700 (032304 | 1183 | 32775 (0.04
2 |30A 1475 (13700 (0171|710 1086 | 32603 | 0.03
J |30B (1419 (13700 (070 F0E |82V | 32456 |0.03
4 |70B (1292 (13700 (009|30B |803 32831 (002
5|20 1268 |13700 (0.08] 704 | 622 | 33080 (0.02
B |bOA (1245 (13700 (0.09|B0OE |557 (33074 |00
7|40 1212 (13700 (0.09] 20 342 | 32982 (0.
8 130 1209 (13700 (009|110 218 | 33322 (007
5 |80 1201 |13700 (008120 | 200 |33306 (0.01
10|90 1198 (13700 (0.09 )80 189 | 33049 (0.07
11 |50 1193 | 13700 (0.08 | 60A | 176 | 33002 (0.01
121100 1197 (13700 (0.09 |50 135 | 33082 (0.00
13 |B0OBE (1176 (13700 (009|700 (111 |[33063 (000
14| 70A (1170 (13700 (009|130 (104 (33047 (000
15120 |944 (13700 (0.07 |40 /b 33038 (0.00
16 (110|928 (13700 (0.07 |50 20 | 33052 (0.00

Operating Stress for Impact Test can be seen by selecting the option “Show Operating Stress for Impact

Test” through Mouse Right click.




*i* Caepipe : B31.5 (2022) Code compliance (Sorted stress...
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1Q EHe=> HEA

Sustained Expansion
# SL[sH  [sL SE |SA |SE
Mode [(psi) [(ps) [SH | MNode | (psi) | (psi) | SA

1 |10 1647 (13700002 | 304 1183 | 32775 |0.04
2_3|:IA 1475 (137000171 |10 1086 | 32603 | 0.03
3_3EIEI 1419 (13700010 70B | 827 | 32958 |0.03
-4_?EIE| 1292 (13700 0.09|30B | 803 |32831 |0.02
5_ - 1266 |1 Show Stresses

E_ BOA 12481 Show Stress Ratios

?_ 40 121211 Thresholds...

B_ 130 120911 [ Show Operating Stre[\gfor Impact Test
9 80 j120n Hide Allowables

1090 1198 (1

7 5 1188 |1 Results...

? 100 1187 |1 Mext Result

F RIE 1176 |1 Previous Result

14704 |1170|13700 0091130 (104 |33041 {0.00
150120 | 944 | 13700 |0.07 |40 5 | 33038 | 0.00
16 (110|928 | 13700007 |50 20 | 33052 |0.00

=i Caepipe : B31.5 (2022} Code compliance (Sorted stresses) - [refrigerati... — O

File Results View Options Window Help

d® Ee= BB
Sustained Expansion Dper. Stress for Impact Test
# 3L [8H |SL SE | SA SE Sopr |Sall | Sopr

Node | (psi) | (psi) | SH |Node | (psi) |(psi) | SA [Node |(psi) | (psi) | Sall
1 {10 1647 | 13700 (012 | 30A  [1183 | 32775 (0.04|30B 1777 14795 (037
2 304 |1475 (1370001110 1086 | 32603 |0.03 | 70B 1674 | 4795 (035
'3 {308 [1419|13700|010]708 |s27 |32958 |0.03[70a 1457 14795 (030
(4 708 |1292|13700|0.09)308 |e03 |328%1 |0.02|608 1406|4795 (0.29
BRED 1266 | 13700 (0.09 | 70A |622 | 33080 (0.02 | 30A 1396 4795 |0.29
6 [604 |1248|13700| 009 |60B |557 |33074 |0.02 |80 1289 | 4795 (027
7 |
5 |
9 |
10|

40 121213700 |0.09 )20 342 | 32982 | 0.01 )90 1261 (4795 |0.26
130 |1209|13700|0.09)110 |218 |33322|0.01)130 1267 (4795 |0.26
il 1201 {13700 |0.09 (120 (200 |33306 (0.01 (100 1248 (4795 |0.26
100490 1198 | 13700 | 0.09 | 80 189 | 33049 |0.01 )40 1233 (4795 |0.26
11 (50 1196 | 13700 | 0.09 |60A (176 |33002 (0.01(20 1215 (4795 |0.25
(12100 |1197|13700|0.09 |30 135 | 33052 |0.00)50 1194 (4795 |0.25
[13]608 [1176|13700|0.09|100 {111 |33083 [0.00 |60a 1165 4795 |0.24
[14]704 |1170(13700 009130 [104 |33041 00010 1153 (4795 |0.24
15 (120|944 |13700|0.07 |40 7h | 33038 |0.00)120 1038 (4795 |0.22

16110 |828 (13700 (0.07 (50 20 | 33052 |0.00)110 1029 (4795 |0.21

Similarly, Code Compliance report lists the Stresses element-wise following the same procedure as done
for Sorted Stresses.



=i~ Caepipe : B31.5 (2022) Code Compliance - [refrigeratic...
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Press. Sustained Expansion

# |Mode [Allow. [SL |SH  |SL |[SE [sAa  [SE.
(psi) | (psi) |(psi) | SH | (psi) | (psi) | SA
10 125 | 1647 | 13700 (012 | 1086 | 32603 [ 0.03
20 1268 | 13700 | 0.09| 342 |32982 | 0.01

20 125 | 1268 | 13700 (0.09)342 |329582 (0.0
30A 563 | 124913700 (009333 | 330071 |0.00

30A (125 | 7475 {13700 (0171183 | 32775 | 0.04
0B [563 | 1419 (13700 (010)803 | 32831 |0.02

0B (125 | 125113700 (009234 | 32999 | 0.00
40 BE3 (1212 | 13700 (008 )75 | 33038 |0.00

1
B
ER
4|
5 |40 [125 |1212|13700 |009 |75 |33038 000
6 |
EB
5 |
ER

50 563 |1198 | 13700 (00820 | 330682 |0.00

a0 125 |1798 | 13700 (00820 | 33062 |0.00
BO0A  [5B3 | 1785 | 13700 (00960 | 33065 |0.00

BO0A (125 | 1248 | 13700 (0081768 | 33002 | 0.07
BOB [563 |1176 (13700 (0.09)557 |33074|0.02

BOE (125 |116E {13700 (0.09)158 |33084 |0.00
04[BB3 | 116413700 (008|177 | 33086 | 0.0

04 (125 |1170 13700 (0.0 ) 622 | 33080 |0.02
0B [B63 | 1292 | 13700 (0.09)827 | 32958 |0.03

10| 706|126 |1204 (13700009 |241 |33046 (0.1
il BE3 17201 11370010.090189 (33049 (0.01

From the Displacement results for Expansion (T1) and Expansion (T1-T2), it is observed that the
Displacements are +ve in Global Y direction confirming that the piping is shrinking due to temperature
decrease for both expansion cases.

=I* Caepipe : Deflect...
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Hée= Se= s HEBRRXC

# Displacements (glabal) kY
Maode | > (inch)  |Y (inchy [ Z(inch) [*<X{deg) |Y (deq) | 22 (deq) wan /T\

1|1 0.000 0.000 0.000 0.0000 | 0.0000 | 0.0000 20 7 & %

2 |20 0.008 0.000 0.000 0.0000  |0.o000 |-0.0021

ERETSIXE 0.000 0.000 0.0000  |o.ooon  |-0.0022 T3D

EREERIE 0.008 0.000 0.0000  joooon |-0.0162 (—% I

& |40 -0.002 0.04s 0.000 0.0oo0o0 |oooon |[-00182

6 |50 -0.008 0.061 0.000 0.0000  |0.0000  [-0.0184

Z 60a  |-0.013 0.074 0.000 0.0ooo |oooon |[-0.0183 10

G |BOB |-0.009 0.083 0.000 0.0000  |0.0000  [-0.0134 E on

E 704 |-0.008 0.083 0.000 0.0000  |0.0000  [-0.0134 a0

110|708 |0.000 0.078 0.000 0.0000 |0.0000  |-0.0021

ERRED 0.000 0.065 0.000 0.00o00 | 00000 |-0.0011 40

(12|90 0.0 0.05z2 0.000 0.0o00 |oo0on |-0.000% 80

13100 |0.001 0.046 0.000 0.0000 |0.0000  |-0.0001 &0

14]110 [0.001 0.04z2 0.000 0.0000 |0.0o00 | 0.0007

15 (120 |0.000 0.004 0.000 0.0000  |o.oooo | 0.000z2 *\w‘k_j

16 (130 |0.000 0.000 0.000 0.0000 | 00000 | 0.0000 gt B0




=i Caepipe : Displacements: Expansion (T1-T2) - [refrigerationpi.. — O i* Caepipe: Deflect.. — O

File Results View Options Window Help File View Options Window Help
A EeE= He= o @mE @&GRRAS
# Displacements (global) Y

Mode [¥inch) | % (inchy | Z(inch) = (deg) [YY (deq) |22 (deg) wan /T\‘

1_ 10 0.000 0.000 0.000 0.0000 0.0000 0.0000 20 7 a 5w
2 |20 n.ma 0.000 0.000 0.0000 0.0000 -0.0045
'3 304 |0.020 0.0 0.00a n.000a 0.000a -0.0047 TaD
4 |308 |0.030 0.014 0.00a n.000a 0.000a -0.0351 (—%D
5 |40 -0.005 0,104 0.00a n.000a 0.000a -0.0345
& |50 -0.017 0134 0.000 0.0000 0.0000 -0.0399
Z G0A [-0.029 0161 0.000 0.0000 0.0000 -0.0397 10

G |(B0B |-0.020 0181 0.000 0.0000 0.0000 -0.0292 £ oo
E oA (07 nas2 0.000 0.0000 0.0000 -0.0290 a0

10 (70B |0.000 01 0.000 0.0000 0.0000 -0.0045
11| a0 0.00m 0143 0.000 0.0000 0.0000 -0.0025 0
12| a0 0.00m 0114 0.000 0.0000 0.0000 -0.0009 80
13]100 {0002 0am 0.000 0.0000 0.0000 -0.0004 50
[14]110 {0002 0.091 0.000 0.0000 0.0000 0.000m i
15 ]120 {0000 0.010 0.000 0.0000 0.0000 0.0005 E.
116|130 | 0000 0.000 0.000 0.0000 0.0000 0.0000 Ta G0

Similarly, from the Displacement results for Expansion (T2), it is observed that the Displacements are -ve
in Global Y direction confirming that the piping is expanding downward due to temperature increase.

=i Caepipe : Displacements: Expansion (T2) - [refrigerationpipin... — O =i Caepipe : Deflect...
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A EHE Eean B E

# Dizplacements (global)
Mode [=({inch) |%(inch) |Z(inch) [|==(deq) |¥™ (deg)|ZZ (deq)

1 {10 [oooo  [oooo {oooo [ooooo |ooooo | ooooo
2 |20 |-omo |-ooo0 |oooo  |ooooo  [ooooo  |o.0024

'3 |04 |-0011 |-0000 0000 {00000 |00000 {00025

(4 |08 |-0016 |-0010 |0000 00000 |00000 {00189

5 |40 |0o0z  |-0057 {0000 00000 |00000 {00213

6 |50 |000s |-0073 {0000 00000 |00000 {00215

7 |e0A |06 |-00ss  [0000  |0.0000 |00000 (00213 i

8 |60B |o011  |-0098 |0o0o0  |ooooo  |ooooo  |00157 Mo

(9 |70 [0009  |-00%8  [0000  |0.0000 |0.0000 |0.0156 ai
10|70 |oooo  |-0.093 {0000 |o0oo0  |0.0000 | 00025

1|0 |-0o00  |-0078 {0000 00000 |00000 {00014 A0
1zfao |-0000 |-0062 {0000 {00000 |00000 {00005 o
113|100 |-0001  |-0085  |0000 00000 |00000 {00003 50
14|10 |-0001 |-0049 {0000 {00000 |0.0000  |-0.0000

15 |120 {0000 |-0005 {0000 {00000 |0.0000  |-0.0003 “70
6|130 |oooo |oooo |oooo  |ooooo 00000 |0.0000 T gD

Element Forces & Moments (local forces and moments on each element for Expansion (T2) load case)
are shown below.



*i* Caepipe : Pipe forces in local coordinates: Expansion (T2) - [refrigerationpiping.res (chtutorialsirefrigerationpiping)]

File Results View Options Window Help
A EHeE= Se= i
# | MNode [ Axial w Shear |z Shear | Torsion{fi-lb) Inplane(fi-lb) Outplane(ft-lb) Flex, Factors SE [SA SE
{1k (I} {1b) Moment [ SIF toment | SIF Maoment | SIF FFi  |FFo |FFt |[(psi)|(psi) |[SA
1 |10 -7 -21 0 0 -gb 1.00 1] 1.00 bEb | 32603 (0.02
20 =7 -21 0 0 -B6 1.00 ] 1.00 184 | 32982 |0.01
e |20 -7 -21 0 0 -B6 0 184 32482 |0.01
A |7 -21 0 0 -64 I 179 33001 (0.01
3 (30A |7 21 0 0 64 359 i 299 137411374 637 32775 (002
B |21 7 0 0 43 359 i 2.9 13.74(13.74 432 32831 (002
4 (308 (21 -7 0 0 -43 i 126 32999 (0.00
40 21 -7 0 0 -12 i 40 33038 (0.00
5|40 21 -7 0 0 -12 I 40 33038 (0.00
50 21 -7 0 0 -1 I 11 |33082 (0.00
& |50 il -7 0 0 -1 0 11 |33082 (0.00
BO0A |21 -7 0 0 3 0 32 | 33085 (0.00
7 |60A (21 -7 0 0 9 359 i 299 137411374 94 33002 (0.00
B0B |7 -21 0 0 30 359 i 299 137411374 299 (33074 | 0.01
8 |e0B |[-7 -21 0 0 30 i 85 33084 (0.00
04 -7 -21 0 0 33 i 95 33086 (0.00
9 (704 |7 -21 0 0 33 359 I 2.99 13.74 (1374 334 33080 (0.01
0B |-21 7 0 0 44 359 I 2.99 13.74 (1374 445 | 32958 0.02
10 |70B [-21 -7 0 0 -44 0 130 33046 (0.00
&0 -21 -7 0 0 -34 0 102 | 33049 (0.00

Element Forces & Moments (global forces and moments on each element for Expansion (T2) load case)
are shown below.

=l Caepipe : Pipe forces in global coordinates: Expans [refrigerationpiping.res (cMutorials\r...

File Results View Options Window Help
QEE=> Ees
# [Mode [FX [FY |FZ M (WY | WE
by [fb) [k | il | (b)) | )
1 (10 -7 21 0 0 0 -85
2l 7 -1 |0 a ] BE
2 (20 -7 21 0 0 0 -Bk
A |7 -21 |0 a 0 B4
3 [304 |7 21 0 0 0 -B4
nE |7 -21 |0 a 0 43
4 [30B |7 21 a I 0 -43
40 7 -21 |0 a 0 12
5 (40 -7 21 a I 0 -12
50 7 -21 |0 0 0 1
& (50 -7 21 a I 0 -1
B0A |7 -21 |0 0 0 -9
7 |B0A |7 21 a a 0 ]
E0E |7 -21 |0 0 0 -30
§ |B0B |-7 21 a a 0 k1]
04 |7 -21 |0 0 0 -33
8 |70A |7 21 a a 0 33
L= -21 |0 0 0 -44
fve |7 21 o 0 0 44
80 7 -21 |0 I 0 -34




Support Loads on all supports by the piping for Operating Load case 1 are shown below.

i Caepipe : Loads on Anchors: Operating (W-P1+T1) - [refrigerationpiping.res (chtuterialsirefriger...

File  Results Wiew Options Window Help

R EE= S e

# |Node [Tag |[FX(b) |Frib) |FZ (k) |Mx by | MY (i) | M2 (i)
1 |10 -8 69 0 0 0 42
2 130 3 107 0 0 0 20

Support Load Summary (listing loads on a particular support by the piping) for all relevant load cases and
load combinations) is shown below.

== Caepipe : Support load summary for anchor at node 10 - [refrigerationpiping.res (chtutorialshrefri.. — O

File Results View Options Window Help

EREEIERET=

Load combination | FX (bl |F¥ (b)) |FZ (k) | k(- | Y (-l | B2 (f-R)
Sustained -2 -87 0 0 0 115
Operating!l -8 -69 0 0 0 42
Operating2 5 -108 0 0 0 20a
hdaxirnurm 5 -64 0 0 0 200
kdinirnurn -8 -108 0 0 0 42
Allowahles I 0 0 0 0 0




