Tutorial for Response Spectrum Analysis using CAEPIPE

General

The Response Spectrum is a plot of the maximum response (maximum displacement, velocity,
acceleration or any other quantity of interest) to a specified dynamic loading applied on all possible
single degree-of-freedom systems. The abscissa of the spectrum is the natural frequency (or period) of
the system, and the ordinate is the maximum response.

In general, response spectra for a seismic event are prepared by calculating the maximum response to a
specified ground motion excitation of single degree-of-freedom systems with various amounts of
damping. Numerical integration with short time steps is used to calculate the response of each single
degree-of-freedom system. The step-by-step process is continued until the total earthquake record is
completed, the results of which becomes the response of that system to that excitation. Change the
parameters of the system to change its natural frequency, repeat the process for the same excitation
and record the new maximum response. This process is repeated until all frequencies of interest have
been covered and the results plotted. Typically the El Centro, California earthquake of 1940 is used for
this purpose. Attached (“ElCentro.txt”) is an ASCII file that contains spectrum from El Centro, California
earthquake of 1940. [First line in this file is the name of the spectrum. Second line defines the “Units” for
Abscissa (X-axis) and Ordinate (Y-axis) axes, separated by a space. Starting from the 3 line, the first
column is Abscissa and the second column is Ordinate. For further details on this ASCII file, refer to
the “Spectrums” subsection under “Misc.” section of Menus in the CAEPIPE User’s Manual.]

Response Spectrum thus prepared as explained above is then input/imported into CAEPIPE Stress model
for analysis through CAEPIPE Layout window > Misc > Spectrums.

Once the inputting of different spectrums are done, input the Spectrum levels applicable for the current
analysis through Layout window > Spectrum. Define a single level for uniform response spectrum
analysis. For piping supported at different elevations with each elevation experiencing different seismic
loads, define multiple levels with the corresponding spectrum loads. In the latter case, the levels should
be assigned to each support.

Save the model and perform analysis using CAEPIPE.

Spectrum load specified will be applied at all supports, following which CAEPIPE will compute the modal
and directional responses, which are further combined as per the combination method selected.

Since the response spectra give only maximum response, only the maximum values for each mode are
calculated and then superimposed (modal combination) to give a total response. A conservative upper
bound for the total response may be obtained by adding the absolute values of the maximum modal
components (absolute sum). However, this is excessively conservative and a more probable value of the
maximum response is the square root of the sum of squares (SRSS) of the modal maxima.

Ensure the CAEPIPE results meet project specific analysis requirements. If not, make changes to the
piping layout and/or changes to support types and their locations and then reanalyze the model until
the analysis requirements are met.



Uniform Response Spectrum Analysis

The following are the Steps for performing the Uniform Response Spectrum Analysis using CAEPIPE.

Step 1:

Attached is a sample CAEPIPE model with Response Spectrum. The piping layout shown below (extracted from
the attached model) is for a water supply line that has the following layout and properties. The Analysis Code is
selected as ASME B31.9 for this sample model.

=i* Caepipe : Layout (85) - [08_responsespectrum.mod (c\tutorials\spectru... X =i Caepipe : Graphics - [08_responsespectrum.med (c\tutorial...
File Edit View Options Loads Misc Window Help File View Options Window Help
e« BED@EA g QE@mAAAOEA
# |Node | Type | Dxtin | D diny | DZ (i) | Matl | Sect| Load | Data

1 |Title =

2 |10 Fram Anchor
EREl Bend o APl 541 |54l
ERE! -2n'n" APl |54l |54l [Hanger
5 |40 Bend -1 APl 541 |54l
5 |50 3" APl |54 |54l [Rest Supp
7 |60 20" APl (540 540
& |65 " APl [540 | 540
EREl 12 APl (540 (B40 | Rest Supp
10|78 12'n" APl [540 | 540
11|80 12 APl (540 (B40 | Rest Supp
EAES 12'n" APl [540 | 540
13|90 12 APl (540 |B40 | Rest Supp
14100 o AFl (540 (540
15 (110 3" APl (540 (840 [Anchaor

16120 3" AFl (540 (540
17]130  |Reducer 3o APl (540 (540
18 [140 | Bend 3" APl | 361 | 36
[19]150  |Bend 2 -4'g" 4" APl 361 | 361
(20160 [ APl (36 | 361 |Rest Supp
21165 0" AP | 361 | 361
"2z | 170 a0 APl (361|361 |Rest Supp
'z3[180 | Bend 60" AP | 361 | 361

=I= Caepipe : Pipe Sections (4) - [08_responsespectrum.mod (c\Mutorials\spectrumtutori...

File Edit View Options Misc Window Help

IID @l O0hées

MName | Nam Sch Thk | CorAl [ M.Tal | Ing.Dens | Ins.Thk | Lin.Dens | Lin.Thk | Soil
Dia (|nch) {inchy [(inch) [(25) | (Ib/ft3) {inch) [ (Ib/t3) {inch)
1 |36l 3B STOD | 36 0.375 | 0.07% 13 2
2 (360 | 3B" STOD | 36 0.375 | 0.075 13 25
(3 (540 |Monstd 54 0.375 | 0.075 13 25
FRE Mo Std 54 0.375 | 0.075 13 2

=i Caepipe: Materials (2) - [08_responsespectrum.mod (chtutorials\spectrumtutorial)]

File Edit View Options Misc Window Help

IID R H e [ e

MNarne Description Ty [Density [Nu | Joint | Yield |Tensile |# |Temp|E Alpha | Allowable
pe [ lbfin3) factor |(psi) | (psi) F) (psi) (infinfF) | (psi)

!A53 AB3 Grade B C3 | 0283 03 1.00 | 35000 -326 | 31.4E+6 | 5.00E-6 [ 20000

AR APl 5L Grade B |C5 | 0.283 0.3 1.00 | 35000 -200 | 30.8E+6 |5.35E-6 [ 20000

1

2
EB -100 | 30.2E+6 | 5.65E-6 [ 20000
B 70 295E+6 | 6.07E-6 | 20000
200 28.8E+6 | B.38E-6 | 20000
300 28.3E+6 | B.EOE-G | 20000
400 27 7E+6 | B.E2E-6 | 19300
500 27.3E+6 | 7.02E-6 | 19000
600 2B.7E+6 | 7.23E-6 | 17900




=i* Caepipe:loads (32) - [08_responsespectrum.mod (chtutorials\spectrumtutorial)]

File Edit View Options Misc Window Help
l Ef oQ Ol &=
MNarme |T1 |P1 |Desg.T | Desg.Pr. | Specific | AddWat. [Wind  |MWind | Wind | Wind
(F1 |(psi)|(F) (psi) grasity | (Ib/f) Load 1 [Load 2 [Load 3 | Load 4
1 [B&Q |00 |125 |100 125 1.0 772 b
2 |36l 100 125 (100 125 1.0
'3 |300 [100 |125 {100 125 1.0 £5.9 i
ERED 100 (125 (100 125 1.0
5 {240 |100 |25 {100 125 1.0 546
5 |24 100 (125 (100 125 1.0
7 {200 |100 |25 {100 125 1.0 48.9 i
ERED 100 128 (100 125 1.0
‘9 |1a0 100 |125 |100 125 1.0 45.2 hd
10181 100 125 (100 125 1.0
Step 2:

Input Spectrums into CAEPIPE. This can be done in three ways:
1. Input spectrums directly into the model.
2. Create a spectrum library and load spectrums from it.
3. Input spectrums from a text file.

When the first two methods are used, the units for the X-axis and Y-axis as well as the interpolation method are
set through the menu Options > Spectrum.

*i* Caepipe: Spectrums (2} - [08 respo...

File Edit ¥iew Options Misc Window Help
Spectrum...
. . |: [ Font... ] *
Mame # |PFeriod Acceleration
(Sec) (9's]

1 [ Malta—Y 1 |0 0.0856
2 | Malta-Nv_b 2 |03z 0.1264
ER '3 0074 01712 e
L 4_ 0.11 0.214 Absrizza Ordinate
_— |5 |0.331 0.214 " Frequency Hz] Dizplacement © inch
] |5 |0.551 0.214 * Period [Sec) ° mm
— |7 |1.914 00671665 Acceleration O jntgec?
B EREHE 0036023 @ s

9 4638 0.025443 ,
T E6lE: 0.019867 " g
| e 0.011063 Interpolatior @ Linear | Interpolatior € Linear
H 1210 0.00708  Log  Log

13 (20 0.00177

14 |30 0.000787
I = | k. | Cancel

For the sample layout described above, spectrum was input directly into CAEPIPE model manually. If you wish to
read the spectrum file “ElCentro.txt” supplied into the CAEPIPE model, select “Read Spectrum” through
Spectrum List Window > File.



Step 3:

Once the inputting of different spectrums are done, input the Spectrum load itself for analysis through
Layout window > Spectrum.

=I* Caepipe : Layout (85) - [08_responsespectrum.mod (c\tutorials\spectru...

Eile Edit Yiew Options Loads Misc Window Help
j iq. q E'S’; Load cazes (6] ... {

Static seismic 1...
# [Mode |Type | D Static sismic 2... 1 | Sect | Load | Data
1 |NiES Static seismic 3... |
2_ 10 Fram v Wind1.. Anchar
3_ 20 Bend Wind 2... 541 |54l
4_ 30 Wind 3... 54 |54 |Hanger
5_ 40 Bend Wind 4... 54 |54l
E_ 50 [« Spectrum... ] 54 |54l Fest Supp
?_ 60 T 540 | 540
8_ B Harmonic... 540 1540
9 |70 eu Ao | 540|540 |Rest Supp
W 75 12'0" APl | 540 | 540
T a0 12'0" APL 540 (540 | Rest Supp
? 85 12'0" APl | 540 | 540
W 90 12'0" APl | 540 | 540 |Rest Supp
W 100 1o APl | 540 | 540

=I* Caepipe : Spectrum Levels (1) - [08_responsespectrum.mod (chtutonals\spectrumtutorial)]

File Edit View Options Misc Window Help

IID G &=

Lewvel Tag | X Spectrum | Spectrum |2 Spectrum | X Factor | ¥ Factor | £ Factor | Mode Sum | Direction Sum | Level Sum
1 |LvL0 Malta—Y_k | Malta—NY_b | Malta—MY_t | 1.000 0.043 1.000 SRSS SRSS

¥ spectrum |Malta--NY_I:| j Factor  |1.000
' EpeEctim |Malta--NY_I:| j Factar 0.043
£ spectium |Malta--NY_I:| j Factar 1.000

bode Sum Direction Sum Lewvel Sum
f+ SRSS v SRSS {+

" Clozely spaced " Abzolute F

" Absolute

" MRL

] | Cancel Reset




X, Y and Z spectrums

Select a spectrum from the drop-down combo box, which should have been input in the spectrum table for each
direction.

Factor

The multiplying (scale) factor for the spectrum is input here. The same spectrum may be multiplied by different
(Scale) factors to apply spectrum loads for different dynamic events. For example, vertical spectrum can be input
as the same as that of the horizontal spectrum with a factor as shown above.

Mode Sum

Pick one of three choices, “SRSS” (square root of sum of squares), “Closely spaced” or “Absolute”.
Direction Sum

Pick one of two choices, “SRSS” (square root of sum of squares) or “Absolute”.

Step 4:

Turn ON the load case “Response spectrum” through Layout window > Loads > Load cases. Save the model and
perform the analysis through Layout window > File > Analyze. CAEPIPE will apply these loads to compute the
response of the piping system by performing a Response Spectrum analysis along with other load cases defined
in the piping system.

Load cases [6)

v Sustained [w/+F) | Design [w+FP0+TD)
| Emphy ‘Weight [+ v find
v Expansion [T1] v Modal analysis

v Operating [#+F1+T1] v Responze spectum

ok, Ear‘u:el| Al | Nune|

Step 5:

Upon analysis, CAEPIPE will show a “Load case” with name “Response spectrum” under “Support Loads”,
“Displacements”, “Element forces” and “Support load summary” results.

Load Cases

{7 Sustained Mw/+P)

{ " Expansion [T1]

(" Dperating [&+P1+T1]
£ wind

{* Responze spectium

] Cancel




O

=l* Caepipe : Loads on Anchors: Besponse spectrum (Uniform) - [08_responsespectrum....

File Results View Options Window Help

=5 = - —
g_qj@‘[_q..;‘mz@
# |Mode | Tag |Fxilk) Frvalk) | FE2 (k) bl (-l | A (ft-lR) | M (DR

1 |10 10164 2696 2142 27 4kh B4R 191368

2 (110 11855 446 15966 25400 400410 | 80432

3 (510 4952 14 264916 121 74282 g0v

4 | B30 28497 5 2057 1 15207 33

5 |70 810 0 1806 I 8120 0

B 730 37ek 2014 1984 30272 hO334 24125

— O

File Results View Options Window Help
Q| EeE=) Ele=s =
# Displacements (global)

Mode = {inch)  [Y(inch) [Z(inch) [=<({deq) | ¥ (deq) | £2 (deq) |
1 |10 0.000 0.000 0.000 0.0000 0.0000 0.0o01
2 204 |0.003 0.00m 0.000 nome 0.0o020 0.0132
3 |20B |0235 0.015 0.014 0.00E26 0.1256 0.2231
4 |30 0.877 0.015 0017 0.0m? 0.1146 0.2332
h [40A |1.073 0.015 0.016 0.0020 01113 0.2324
B [40B |1.375 0.001 0.008 0.0024 0.0532 0.10$13
7 |50 1.351 0.000 0.006 0.0020 0.0558 0.0857
g |60 1.328 0.001 0.008 0.00M5 0.0553 0.0964
9 |65 1.1585 0.002 0.006 0.0001 0.07/18 0.0850
10170 0.996 0.000 0.00%5 0.0005 0.0&875 0.0712
11175 0.762 0.000 0.004 0.0000 0.05877 0.0574
12|80 0512 0.000 0.003 0.0001 0.0579 0.0437




=I* Caepipe : Pipe forces in local coordinates: Response spectrum (Uniform) - [08_responsespectrum.res (ch\tutonals\spectrumtutonal)]

File Results View

Options  Window  Help

O A BEEs Eeam it

#

Mode | Axial y shear |z Shear | Taorsion(ft-1b) Inplane(ft-lh) Outplane(ft-lb) Flex. Factars SL+50 sL+50
(]} ()] ()] boment [ SIF boment | SIF MMaoment [ SIF FFi |FFo |FFt |ipsi) (psi)
1 (10 2142 2696 10164 (191365 27465 53452 B388 [ 26B00 | 0.24
204 | 2142 2E96 10164 (191365 16155 16950 BE28 | 2BE00 | 0.21
2 |204 2138 2534 10150 (191368 (1.0 16185 |33 16950 | 2.76 21.98|21.95 G088 | 26600 |0.23
20B | 2594 2138 10150 (52845 |10 14977 |33 123743 |2.76 21.98|21.98 8165 | 2BE00 | 0.31
3 |20B |504 9400 202 52845 123743 14977 5211 26B00 | 0.23
3 504 8400 702 52845 gBe0 19836 4525 | 2BEO0 |07
4 |30 1191 7638 1220 52845 ga50 19836 b086 | 26600 (0049
404|119 7638 1220 52845 3916 15011 5184 | 26BB00 (019
5404 | 2504 2821 6146 52845 15011 |33 N6 |26 21.98|21.95 5795 | 26600 |0.22
q0B | 2821 2504 E146 J12ez 13836 |33 91806 | 276 21.98|21.98 7496 | 2BB00 | 0.28
E |40B | 3814 2B47 4372 71282 13836 31808 E012 | 2BE00|0.23
&0 3814 2647 4372 J12ez 19257 100776 E2E3 | 2BBO0|0.24
7 |50 4198 810 3813 71282 19257 100776 E2E3 | 2BEO0|0.24
&0 4195 810 3813 Jlzaz 17702 107639 G218 | 26600 |0.23
8 |B0 5395 BE1 2478 J12ez 17702 107639 E237 | 2BBO0|0.23
Bh 5345 861 2478 Jlzaz 9446 123741 £RA0 | 26600 | 0.25
5 |B& 7R80 1171 2484 J12ez 9448 123741 EE24 | 2BB00 | 0.25
70 7h40 1171 2484 Jlzaz 4642 107672 BRER | 26600 | 0.25

: Support load summary for anchor at node 10 - [08_respons..

File Results

View Options

BE D @R EeE

Window Help

Load combination Fxilb)y  |FY (k) [FZ{b) | M=) | bAY (i) | B2 (-l
Sustained 0 4872 -144 36275 0 0
Cperating 0 39149 -13404  |-301285 |2 4
Sustained+yWind 0 -9854 -160 36176 0 0
Operating1+Wind 0 39163 -13410  |-301387 |2 4
Sustained+Response [ 10164 -F177 13499 E3740 L3452 191368
Sustained-Fesponse (10164 |-12568  |-2286 8611 -h9452  [-191368
Cperatingl+Fesponse | 10164 41544 11261 |-273823 | 59454 191372
Operatingl-Fesponse [-10164 | 36453 -1654E |-328752 |-B9449  |-191363
bdaximum 10164 41844 13499 E3740 E3454 191372
bdinimurn 10164 |[-12668  |-16546  [-328752 |-59452  |-191368
Allowakles 0 0 0 0 0 0




Multi-level Response Spectrum Analysis

The model shown below is a 3 inch nominal diameter water line extending between two elevations, namely
Level L1 and Level L2, with each Level experiencing different seismic loads. The layout has two anchors with a
number of intermediate supports. The seimsic excitation consists of two separate spectra, with each spectrum
corresponding to the two different Levels. All supports connected from node 1 through mode 11 (inclusive of
the two end nodes) experience the upper level (Level L1) spectra excitation, while the remaining supports
experience the lower level (Level L2) spectra excitation.

For this Multi-Level Response Spectrum Analysis, only the first 15 modes are used to approximate the response
of the system. For each Level, the same spectrum load is applied along X, Y and Z directions with weighting
factors of 1.0, 0.667 and 0.0 in the three global directions respectively.

The following are the Steps to perform the Multi-level Response Spectrum Analysis using CAEPIPE.
Step 1:

Attached is a sample CAEPIPE model with Response Spectrum. The piping layout shown below (extracted from

IM

the attached model “08_ResponseSpectrum_MLRSA.mod"”) has the following layout and properties.

=i Caepipe : Layout (49) - [08_responsespectrum_mirsa.mod (ch\tutoria.. — O =i Caepipe : Graphics - [08_responsespectrum_mlrsa.. — O
File Edit View Options Loads Misc Window Help File View Options Window Help

I zEe BED @K & QE@GARAQAQAOE A
# |Node|Type  [Dx(inch | DY inchy | DZ inchy | Matl | Sect | Load | Data W
1 [Title - | ‘k.x
2_ 1 Fram Anchor 2
3 |2 12.0000 1T

4 |201 |Bend 48.0000 1T

5 |3 36.6370 2o |1 (10 |1

5 |4 18.3130 173800 |1 [1 |1 Skewed restr

7 |5 18,3200 173820 |1 [1 |1

'8 |01 [Bend  |35.6710 ren |1 (10 |1

ERE -43.0000 1

E 7 -12.0000 1 Skewed restr 19 T L1 Level

1|7 Location Skewed restr 1

12]a -24.0000 L 12 i, L2 Level

139 -24.0000 T 1

(14|10 -24.0000 1T

15 |11 -24.0000 11

16|12 240000 1 18

17|13 240000 1 7

E 14 -24.0000 1 1 1 Skewed restr 13

1914 Location Skewed restr

2015 -30.0000 T

2115 -30.0000 T

22|17 -24.0000 T

(23|13 -24.0000 1T

(2419 -24.0000 11

E 20 -24.0000 1 1 1 Skewed restr

E 20 Location Skewed rastr

27|21 104000 |-25.4000 1

26|22 104000 |-25.4000 1

79|23 104000 |-25.4000 1T

30| 24 104000 |-25.4000 1T

ERES 104000 |-25.4000 1T

E 26 -24.0000 1 1 1 Skewed restr

E 26 Location Skewed restr




=i= Caepipe : Matenals (2] - [08 responsespectrum_mirsa.mod (chtutorials\spectru...

File Edit View Options Misc Window Help

IID.QI l«»

Mame Description v | Density [Mu | Jaint Temp [E Alpha | Allowahble
pe (Ibfind) factar (F) (psi) (indin/FY | (psi)
1T b1 Cs (0.0 03 |1.00 (1 (&0 2hBE+E (0
i hd2 Cs (00 0.3 (100 |2

=I* Caepipe: Pipe Sections (2] - [02 responsespectrum_mlirsa.mod (chtutonals\spe...

File Edit View Options Misc Window Help

IID.QII«»

Mame | MNom | Sch Thk Coral | M Tal [Ins.Dens | Ins. Thk [ Lin.Densg | Lin. Thk | Sacil
Dia (lnn:hj (inchy [(inch) [(%2) | (lk/t3) finch) | (b/ft3) (inch)
1 11 3" STD | 3.65000 | 0.2160 125
2 |2 3" STD | 3.5000 | 0.2160 125
3

*l* Caepipe : Loads (2) - [08_responsespectrum_mirsa.med (chtutonals\spectrum...

File Edit Wiew Options Misc Window Help
I B0 o Ol e=
MName F1 |Desg.T [Desg.Pr. | Specific | Add Mgt [Wind | Wind  |Wind [ Wind
(Fj (psi) | (F) (psi) gravity | (b Load1 |Load 2 [Load 3 |Load 4
1 1 GO |0 |60 I 10,776
e |2 60 |0 B0 0
3
Step 2:

Input Spectrum load data from layout window: Misc Menu > Spectrums. This can be done in three ways:

1. Input spectrums directly into the model.
2. Create a spectrum library and load spectrums from it.
3. Input spectrums from a text file.

For further details, refer to the section titled “Spectrum Loads” in CAEPIPE User’s Manual.

When the first two methods are used, the units for the X-axis & Y-axis and the interpolation method are set
through the Options > Spectrum.



i~ Caepipe : Spectrums (2} - [08 res...

=i* Caepipe: Spectrums (2} - [08_res...

File Edit View Options Misc Window Help File Edit View Options Misc Window Help
IID@l L == IID.@l L ==
Marme Period Acceleration MName Period Acceleration
(Zec) (infsecd) (Sec) (infsecd)
1 |B1 1 |0.029 3381 1= 1 |0.029 23184
2 |s2 2 (0034 386.4 2 |sk 2 (0032 270.48
3 '3 |o043 386.4 3 3 | 0037 289.5
4 |0043 30912 4 | 0043 289.5
'5 |o.0sa 357,42 5 |0.04s 23184
5 [0074 357.42 ' |0.063 270.48
17 o081 30012 7 |0.071 270,45
'8 [0128 386.4 5 |oo0a 260,52
ERE £79.06 '3 (0143 289.8
10|04 579 05 10025 540,95
11 11 | 0.333 540,95
Step 3:

Define Spectrum Levels through Layout window > Loads > Spectrum. From the list window shown, double click
on an empty row and input Level Tag, select Spectrums; input factors and select Mode Sum, Direction Sum and
Level Sum. Levels L1 and L2 defined for this analysis are shown below.

Leve| Tag # 1
Level Tag
* spectium |S1 j Factor 1.000
" spectium |S1 j Factor 0.BE7
£ spectium | j Factor
tode Sum Direction Sum Level Sum
+ SR5S + SR5S + SR5S
" Clozely spaced " Abszolute " Abszolute
" Abzolute
" MRL
Ok | Cancel Reset

=l Caepipe : Spectrum Levels (2) - [08_responsespectrum_mlirsa.meod (chdutonals\spectrumtutonal)]

File Edit View Options Misc Window Help

IID ol A Wl &=

Lewvel Tag | Spectrum | % Spectrum | £ Spectrum | % Factar | % Factor | 2 Factor | Mode Sum | Direction Sum | Level Sur
1 0] 51 S1 1.000 0667 SRS5S SRSS SRE3
2 |L2 Se 52 1.000 0667 SRES SRSS SRES




Step 4:

Assign Spectrum Level to each support in the analysis model by selecting the appropriate Level Tag from the list.
Snapshots shown below are for a Restraint and an Anchor.

Skewed restraint at node 4

Tag |
Type
* Translational © Fotational
Stiffriess | ERNINCE, [IBinzh)
Direct Anchor at node 1
Irechion
*, comp Y comp £ comp
[1.000 | Tag | Level Tag  |L1 -
Tranzlational stiffnezs (Ibfinch] Ratational stiffness [in-lb/deq)
Connected to kx K K2 K 'y k22
2000E+7 |2000E+7 (2.000E+7 Rigid Rigid Rigid
LevelTag [T 5] |2000E+7 |2.000E+7 [2.000E+7 | |Riigi [Rigi [Figi
el ‘ Shear | Shear 2 | Fieleases for hanger zelection | X [ v [ 2 | =<1 vy | 22
[0k | cord | Cancel | Displacements | T~ Rigd T Ancher in Pipe LTS

Alternatively, one can use the command “Change” through “Layout Window > Edit” to assign Level Tag for all
supports in the Layout for a range specified as shown below.

Change Rows

Change Rows

From # |2 To & [15 From # |16 To & |47
[ Charge Material to [ Change Material to | |
[ Change Section to [ Change Section o | |
[ Charge Load to [ Change Load to | |
W Change Level Tag to - W Change Level Tagto -
[ Change Friction coefficient to [ Change Friction coefficient ba |
[ Charnge D | [ Change Di
[ Change D | [ Change DY
[ Change DZ | [ Change DZ
0k Cancel | Ok Cancel |
Note:

The Level Tag selection list will be enabled and available for selection only when two or more Spectrum Levels
are input in the analysis model. On the other hand, the Level Tag selection list will be disabled and the same
Level Tag will be assigned automatically to all supports when only one Spectrum Level is defined in the analysis
model.



Step 5:

The users can review the Levels assigned to different supports using the List command. Snapshots shown below
are from List command for Anchors and Skewed Restraints.

=i* Caepipe : Anchors (2) - [08_responsespectrum_mirsa.mod (chtutonials\spectrumtutorial)]

File Edit View Options Misc Window Help

IID R ==

Mode [ Tag | Kl vk K2 kz fa o il |KZZfkez Releases Lewel Tag
{Ibfinchy [(lbfinch) | (bfinch) | (indbfded) | (in-lbfdedg) | (in-lbfdeg) [= Y [ 2 15| 22 | Anchorin
1 |1 | 2.000E+7 (2.000E+7 | 2.000E+7 | Rigid Rigid Rigid GCS L1
(2 |36 2.000E+7 [2.000E+7 | 2.000E+7 | 1.00E+17 |1.00E+11 [1.00E+11 GCS L2

sl= Caepipe : Skewed restraints (11) - [08_responsespectrum_mirsa.mod (chtutonalsh...

File Edit View Options Misc Window Help
I il =] & ==
Mode | Tag | Type otiffness | Lnits *comp |[Y comp | £ comp | CHode | Lewvel Tag

1 (4 Translational | 2.000E+7 | {lbfinch) 1.000 L1
e |7 Translational | 2.000E+7 | (lb/finch) | 1.000 L1
3|7 Translational | 2.000E+7 | {lbfinch) 1.000 L1
4 (14 Translational | 20000 (lbfinchy [ 1.000 LZ
H (14 Translational | 20000 ilkafinch) 1.000 LE
6 |20 Translational | 20000 (lbfinchy [ 1.000 LZ
720 Translational | 20000 ilkafinch) 1.000 LE
8 |26 Translational | 2.000E+7 | {lb/finch) | 1.000 L2
9 |26 Translational | 2.000E+7 | (lkfinch) 1.000 L2
10|28 Translational | 2.000E+7 | (lb/finch) 1.000 L2
1128 Translational | 2.000E+7 | (lkfinch) 1.000 L2

Note: CAEPIPE will terminate the analysis, if a level tag is not assigned to a support. For further details, refer to
the flowchart under the section titled “Spectrum Loads” in CAEPIPE User’s Manual.

Step 6:

Turn ON the load case “Response spectrum” through Layout window > Loads > Load cases. Save the model and
perform the analysis through Layout window > File > Analyze. CAEPIPE will apply these loads to compute the
response of the piping system by performing a Response Spectrum analysis along with other load cases defined
in the piping system.



Load cases (3)

W Sustained [w+F]

I Empty Weight [w/]
W Expanzion [T1]

W Operating fw+F1+T1]

ok | Cancel | 4l

¥ Responze spectium

[T Design [w+PD+TD]
v todal analysis

| Maone

Upon analysis, CAEPIPE will show a “Load case” with name “Response spectrum” under “Support Loads”,
“Displacements”, “Element forces” and “Support load summary” results.

Load Cases

" Sustained pw+P)
™ Expanzion [T1)
{” Operating [w+P1+T1]

When selected, each results window (such as Support Loads, Displacements,
“Response Spectrum (Multi-level)” as shown in the snapshots below.

*I* Caepipe : Loads on Ancheors: Response spectrum (Multi-level) -

[08_responsespectrum_mirs...

etc.) will display the title as

File Results Wiew Options Window Help
o— J—
Sl Sea 5 co
# |Mode |Tag [Pkl |[Frib)  [FZib) | M (i) | MY (b | MZ -l
11 a7 83 82 238 110 231
2 |36 84 67 74 36 394 374

File Results View Options Window Help
QA HeE= Ees=c
# |Mode | Tag | Type Load | Units | ® comp | comp | £ comp | Chlode
1 |4 Translational | 202 [ (lk) 1.000
2 |7 Translational | 84 (o) | 1.000
3|7 Translational | 74 {]4]] 1.000
4 |14 Translational | 55 (k) | 1.000
5 |14 Translational | 34 (]} 1.000
6 |20 Translational | 57 (k) | 1.000
7|20 Translational | 26 (]} 1.000
g |26 Translational |136  [(lk) |1.000
9 |26 Translational |53 [{la]] 1.000
10|28 Translational | 152 [{lk) 1.000
11 |28 Translational | 95 {ls}] 1.000




*i* Caepipe : Displacements: Response spectrum (Multi-level) - [08_responsespectrum_milrsa.res (chtutorial... — O

File Results View Options Window Help

QI EE Ee= 5o BN

# Displacements (global)
Mode |X(inch) |Y(inch) | Z(inch) |=x{deq) |YY (deqg) | Z< (deqg)

111 0.0000 (00000 00000 (00000 00000 00000
e |2 00024 (0.0000 00025 (00215 | 0.0157 0.0205
3 |2A | 00024 (00000 00025 (00215 |0.0157 0.0205
4 |28 |00622 |0.006% (00689 [0.0843 | 0.0430 | 0.0586
5|3 00622 |0.0069 00689 (00843 |0.0430 | 0.0586
B |4 0.0738 (00000 00818 (00734 (00283 | 0.0679
7|5 00783 |0.023% |0.0867 (0.0884 00035 | 0.0830
8 |B01A |DO783  |00239 |00867 |00864 00098 | 0.0830
9 |&MEB |00125 00566 (00137 (0032|0029 | 0.0629
10 |6 00125 |0.0566 |0.0137 (00832 00296 | 0.0629
17 00000  (0.0567 | 0.0000 (00810 0029 0.0557
1218 00197  |0.0867 (00214 (00413 | 0.0287 0.0387
13149 0.0320 |0.0567 00344 |00223 |0.0272 | 0.0221
14110 0.0368 |0.0565 |0.0392 (00041 0.0264  |0.0082
15111 0.0343 |0.0568 00364 (00160 (00256 | 0.0154
1612 0.0256 |0.0565 00272 (00277 (00249 | 0.0263
17113 0.0135 |0.0568 |0.0143 (00325 (00243 | 0.0304
1814 00028 (00565 00017 (00287 (00238 |0.0272
19115 00135 |0.056% (001719 (00189 (00232 | 0.0218
2l |16 00220 (00563 |00188 (00079 (00229 | 0.0098

]
a

173 AN alatatn] nonren nondnr nonna? ANt labr) nonner

=I* Caepipe : Support load summary for anchor at node 1 - [08_responsespectrum_milrsare.. — O

File Results View Options Window Help

IR ] = | E

Load combination Fb) [Py |FZ(k) | M= if-b) | kY (b)Y | M (-l
Sustained 104 82 84 174 0 -192
Cperatingl 104 82 84 174 0 -192
Sustained+Response | 1530 175 175 412 109 |
sustained-Response |17 -1 12 -64 -110 -424
Operating1+Response | 150 175 175 12 103 a4
Operating1-Fespaonse |17 -1 12 -64 -110 -424

bl Eximum 140 175 175 417 104 349
kdinimurn 17 -1 12 -G4 -110 -424
Allowakles 0 0 0 0 0 0




= Caepipe : Pipe forces in local coordinates: Response spectrum (Multi-level) - [08_responsespectrum_mlrsa.res (chtutorials\spectr...

File Results

View Options

Window

Help

l HBED GR EE= Sea= i

MNode | Axial w Shear |z Shear | Tarsion(ft-lb) Inplane(ft-b) Cutplane(ft-lb) Flex Factors | SL+S0 SL+30
{1y (s} (ls)] Moment | SIF toment | SIF Moment | SIF FFi | FFo | FFt | (psi) (psi)
1|1 93 a7 gz 110 231 238 IM1e |1 ek
2 93 a7 g2 110 159 170 2454 |1 ek
2 |201a |53 108 45 110 111 205 1.00 2454 |1 ek
2B (108 93 45 28 97 71 1.00 1886 |1 I
3|3 9z 97 14 28 97 71 1886 |1 I
4 92 97 19 28 264 110 5300 |1 i
4 |4 88 114 5 28 264 110 5300 |1 i
g ki 114 & 2 &5 116 17z |1 ek
5 |501A |93 105 30 2 &5 116 1.00 17z |1 ek
BB [105 93 30 B Il 96 1.00 1343 |1 ek
B |6 9z 5 &3 B g4 a4 1343 |1 ek
7 9z 75 B4 B 111 m 1883 |1 ek
7|7 g7 2z 17 B 111 m 1883 |1 ek
8 a7 22 17 G 45 102 1348 |1 i
g |8 a 20 16 B a5 102 1348 |1 i
] g1 20 16 b gz 95 1222 |1 ek
9 |4 /b 15 13 b gz 95 1222 |1 ek
110 75 15 13 B g9 M 1084 |1 ek
10010 &4 12 12 B &4 M 1084 |1 ek
1 &9 12 12 B 78 76 G639 1 ek
11111 &5 18 16 B 78 76 G639 1 ek
12 65 18 16 B 43 48 513 1 i
12|12 &1 26 2z B 45 45 513 1 I
13 61 26 22 G 36 19 336 1 i




