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checkSTRESS™ 

(for CADMATIC) 

Introduction 

Under the “checkSTRESS” brand name, three products are available namely checkSTRESS (which 
generates only CAEPIPE input file), checkSTRESS II (which generates input files for both CAEPIPE 
and CAESAR II) and checkSTRESS Nuke (which generates input files for both CAEPIPE and 
PIPESTRESS). 

The following table lists the checkSTRESS products currently available for different 3D Plant Design 
Systems. 

Sl. No 3D Plant Design System Product Name Status 

1 PDMS checkSTRESS Available 

2 PDMS checkSTRESS II Available 

3 PDMS checkSTRESS Nuke Available 

4 CADMATIC checkSTRESS Available 

5 CADMATIC checkSTRESS II Available 

6 CADMATIC checkSTRESS Nuke Available 

7 PDS checkSTRESS Available 

8 PDS checkSTRESS II Available 

9 PDS checkSTRESS Nuke Available 

10 PCF checkSTRESS Available 

11 PCF checkSTRESS II Available 

12 PCF checkSTRESS Nuke Available 

This document describes the common features of checkSTRESS product(s) currently available for 
PDMS. Details related to the generation of CAESAR II input files by checkSTRESS II and 
PIPESTRESS input files by checkSTRESS Nuke are covered in a separate document titled 
“CIIModel.pdf” and “PSModel.pdf” respectively. 
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Installing Program 

To install checkSTRESS on Windows, download the product from the website and execute the 
followings steps: 

1 Run the program "SETUP.EXE" and follow the instructions as they appear on the screen. 

2 After successful installation of the program, create an environmental variable with the name 
“checkSTRESS_CADMATIC” and set the value of the variable as 
“checkSTRESS_Installed_Path”. For example, assuming the checkSTRESS is installed in 
“C:\Program Files\checkSTRESSCADMATIC”, the value would be “C:\Progra~1\ 
checkSTRESSCADMATIC”). 

3 The environmental variable can be set as given below 

 Open the Control Panel window and open the System Properties window by double 
clicking the “SYSTEM” icon from within the Control Panel window. Select the 
“Environment Variables” button from the “Advanced” tab for Windows 2000 or select 
the Environment tab and click “New” button. 

 Then enter in the Variable prompt “checkSTRESS_CADMATIC”, and 
“checkSTRESS_installed_path” (where the checkSTRESS is installed) in the Value 
prompt, for example ““C:\Progra~1\ checkSTRESSCADMATIC”. 

 Once entered, select the “Set” button to confirm 

Note: For the program to work properly, avoid using space or special characters while 
entering the path or file name. 

How to use checkSTRESS? 

1 Pipes selected for Transfer need to be checked for the following. 

a. Pressure and Temperature of the Pipeline defined using Pipeline Tags or Model 
Object Tags. 

b. Support type can be transferred to checkSTRESS by creating a user-defined tag to 
the CADMATIC project with the name “sty” (Support Type) or any other tag name and 
assigning the same tag to the component connecting the pipe and the pipe support 
such as U-clamp, O-clamp, etc., at each pipe support location. The tag created as 
stated above should be set a value as given in the field #1 of the access db 
“SupportType.mdb” available in the installed directory of checkSTRESS to transfer 
the support type. 

c. If the MMT_LEAVE_GASKET_GAPS is set to 1, then the translator treats the same 
as real gaps and might put an anchor at that location. 

2 Load the CADMATIC Plant Modeler and run the macro “Setup\checkSTRESS.mac” available 
in the installed path of checkSTRESS through “Run Script”. The following form appears. 
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a. Select the piping code to be used for the analysis of the model from the list box.  

b. Enter/modify the Static Seismic Load (g’s). Available only for checkSTRESS Nuke. 

c. Enter the Starting Node number and Node increment value in the appropriate field. 
By default, the Starting Node number and Node increment are set to 10 and 10 
respectively. 

d. Enter the Specific Gravity of operating fluid. By default the specific gravity of water 
(i.e. 1) will be used for analysis. 

e. Select Default Hanger to be used in checkSTRESS model. This Hanger type will be 
used only when the hanger type in checkSTRESS corresponding to Plant Design 
hanger is not specified /available in the Mapping DB.  

f. Select the Boundary Conditions to be used from the form shown above. Refer section 
4.0 titled “Reference” for details. 

g. Choose the Global Vertical Axis for checkSTRESS model from the vertical Axis 
option. By default, “Z Axis” shall be taken as Global Vertical Axis if not specified. 

 Note: Since CADMATIC always uses vertical global axis as “Z” and Stress 
Engineers from different parts of the world use different coordinate systems, it 
is recommended that the designers should consult with the stress department 
and choose the “Vertical Global Axis” before saving the stress model in 
CAEPIPE format (for Stress department to carry out the detailed analysis). On 
the other hand, for performing the first level stress check using checkSTRESS, 
designers shall continue to use “Z” as Global Vertical Axis. 
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h. If the user wishes to eliminate those elements whose Nominal size (NS) is less than 
50mm / 2in, then they can specify the value as “50” for SI Units and “2” for English 
Units  in the field “Process elements, if dia >”. In other words, the program will 
process only those elements whose nominal size is greater than the value specified 
in the field above. 

i. Specify how the 3 Way and 4 Way valves to be transferred to checkSTRESS. Refer 
section 4.0 for details. 

j. Specify how the Flanges are to be transferred to checkSTRESS. Refer section 3.0 for 
details. 

k. Specify whether the Mapping DB shall be used during transfer or not. Refer 
checkSTRESS.pdf for details. 

l. The Function ‘Pick Pipe Line’ lets the user to select the objects from the graphics. 
The user can select entire Pipelines or the Portion of the Pipes. Pipelines that are 
selected for transfer will be shown in “PipeLine Name Lists” box as shown in figure 
above.  

m. Press the button “Apply” to perform the Stress Check. 

   

3 Response Spectrum load data can be added through Edit Layout > Misc > Response 
Spectrum. Once added, the same can be applied in stress model through Edit Layout > 
Loads > Spectrum. See Appendix A for details on adding Spectrum.  

4 Figure above shows the stress contour plot for the Expansion case. Sustained Stress plot and 
Occasional Stress plot can be seen by selecting the option “Sustained Stress (Weight + 
Pressure)” and “Occasional Stress” respectively as shown in the figure right above.  

5 Designers can also plot and view the deflected shape of the piping system under different 
loading condition using the options available in the heading titled “Deflected Shape” as shown 
in the figure right above. 

6 Designers can review the Nozzle / Anchor Qualification using the Option “Show Summary”. 
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7 Hanger selected by checkSTRESS for “to be designed” hangers can be viewed by selecting 

the option “Show Hanger Report”. 

8 Designers can generate the CAEPIPE mod file using the option “CAEPIPE 7.2x mod” for the 
Stress Department to carry out the detailed analysis. 

9 Similarly, in order for the Stress Department to carry out the detailed analysis including stress 
report preparation, designers can generate CAESAR II input files in checkSTRESS II product 
and PIPESTRESS input files in checkSTRESS Nuke product respectively, by selecting the 
appropriate option from the dialog box as shown above. 

10 Using the option “Print”, designers can print the model data, code compliance for ten (10) high 
stress nodes, Nozzle / Anchor Qualification and Status of Resting Support / Limit Stops. 

11 Mode shapes reports using the option “Show Modes” are available only for checkSTRESS 
Nuke product. 

3.0 Limitations 

The following are not transferred to checkSTRESS from CADMATIC database at this time. However 
user can add these in checkSTRESS through Edit Layout->Misc->Section 

1 Insulation density and Insulation thickness.  

2 Corrosion allowance and Mill tolerance. 

3 Lining Density and Lining Thickness.  

4.0 Reference 

Loads 

By default, Temperature and Pressure values entered at Pipes and Standard components via OpT 
and opP shall be transferred to checkSTRESS. If the Temperature and Pressure values for Pipes and 
Standard components and entered at different tags names other than opT and opP, then designer 
has to specify the name of the Tags in the dialog box as shown in the figure above. Designer should 
make sure that these tags are filled with appropriate values depending upon the Units of transfer. I.e., 
If you wish to transfer the model in SI units, then the value enter for Temperature and Pressure 
should be in Deg C and kg/cm2 respectively. On the other hand, if you wish to transfer the model in 
English Units, then the Temperature and Pressure values shall be entered in Deg F and psi 
respectively. 

User can also add / modify the Temperature and Pressure for the piping system in checkSTRESS 
through Edit Layout->Misc->Loads 

Fluid Density 

Specify the Specific Gravity of the fluid (with respect to water) during the transfer of the model. 

Weight 

The weights of Valves, Instruments, Flanges, etc. are extracted from the Dimension Table through 
first mass quantity type attribute. If the values are defined /available in the database, then the 
program extracts the information and transfers the same to checkSTRESS. 

User can add / modify the weight of components by selecting the component type such as Valve, 
Rigid, Flange, etc. through Edit Layout->Window->List. 
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OD, Wall Thickness and Nominal Size 

Nominal Size is extracted from the first NS Quantity type of Dimension Table. Similarly, OD and Wall 
Thickness is extracted from first diameter and first wall thickness quantity type respectively from 
CADMATIC Dimension Table. For reducers and tees, the arrive OD and Thickness will be read from 
first Diameter and Wall Thickness quantity type and leave OD and Thickness will be read from second 
Diameter quantity type and Wall Thickness quantity type.  

User can also modify OD, Wall thickness and Nominal size of the piping components directly in 
checkSTRESS through Edit Layout->Misc->Section. 

Flange 

Flange from CADMATIC can be transferred as “Pipe with Flange” or “Rigid element” to 
checkSTRESS. If the user selects “Pipe with Flange” option from the form, then the program creates a 
pipe with the length of the pipe equivalent to length of flange and creates a Flange at the pipe end in 
checkSTRESS with flange type as “Weld Neck”. The OD and Thickness (in or mm) corresponding to 
Flange Nominal Size is transferred to pipe in checkSTRESS.  

If the user selects “Rigid element” option then, the program will transfer the same as “Rigid Element” 
to checkSTRESS. Dry weight of flange extracted from CADMATIC will be transferred to “Weight” field 
of the Rigid Element in checkSTRESS. 

User can also modify the property of Flange through Edit Layout->Window->List->Flanges. 

Boundary Condition 

Selecting the option “Anchor end if connected to Nozzle or Pipelines” will Anchor the Pipe Ends only 
when they are connected to a Nozzle or Pipelines, otherwise it leaves them as Free. On the other 
hand, if one end of the pipe is connected to a Nozzle and the other end of Pipe is connected to a Pipe 
and if that Pipe is not included as the part of the Stress model, then the program will anchor both the 
end automatically.  

For more clarity, consider the following examples. If one end of the pipe is connected to a Pump 
Nozzle and the other end is not connected to any Nozzle or Pipeline, then the program will anchor the 
first end and leave the other end as free (i.e., do not create any support). On the other hand, if one 
end of the pipe is connected to a Nozzle and the other end is connected to a Pipe and that Pipe is not 
included in the Stress model, then the program will anchor both the ends automatically. 

Similarly selecting the option “Anchor all Free Ends” will “Anchor” the Pipe ends automatically 
irrespective of whether they are connected to Nozzle or Pipelines. 

In addition to the above, user can also add / modify supports in piping system in checkSTRESS 
directly through Edit Layout->Misc->Data Types. 

Supports 

 Checks for user defined “sty” or the tag name specified by the user in the dialog box as 
shown above. If available, then reads the details of support from this attribute and write them 
to the neutral file.  

 Tag defined above should be set a value as given in the field  #1 i.e., “PdSupport” of the 
access db “SupportType.mdb”, when the user selects the option “Use Mapping DB” for 
transferring the support details to checkSTRESS. Otherwise, the attribute should be filled with 
values as specified in Appendix E of checkSTRESS User’s Manual supplied along with the 
product. For more details refer to Appendix D of checkSTRESS User’s Manual on transferring 
supports “Without Using Mapping DB”. 
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 User can also add / modify support through Edit Layout > Misc > Data Types or by double 
clicking the Data Type in the Layout window. 

Three Way Valve 

Three Way Valve from CADMATIC can be transferred as “Three Rigid Elements” or “Three Pipes with 
one Concentrated Mass at its Centre” to checkSTRESS by connecting the near end & center, far end 
& center and branch end & center. From the section property, weight of fluid (kg/lb) is calculated and 
is added to the dry weight (kg/lb) of Three Way valve read from CADMATIC database. The total 
weight thus obtained is transferred to each rigid element in proportion to its length.  

In the later option, the dry weight of Three Way valve is transferred as weight of the Concentrated 
Mass at the intersection of the three pipes. 

User can modify the weight of rigid element through Edit Layout->Misc->Element Types and 
Concentrated Mass through Edit Layout->Misc->Data Types. 

Four way Valve 

Four Way Valve from CADMATIC can be transferred as “Four Rigid Elements” or “Four Pipes with 
one Concentrated Mass at its Centre” to checkSTRESS by connecting the near end & center, far end 
& center and two branch end & center. From the section property, weight of fluid (kg/lb) is calculated 
and is added to the dry weight (kg/lb) of Four Way valve read from CADMATIC. The total weight thus 
obtained is transferred to each rigid element in proportion to its length.  

In the later option, the dry weight of Four Way valve is transferred as weight of the Concentrated 
Mass at the intersection of the three pipes. 

User can modify the weight of rigid element through Edit Layout->Misc->Element Types and 
Concentrated Mass through Edit Layout->Misc->Data Types. 

Material 

Material description entered at Material tag of corporate catalogue is extracted from the database and 
the material property is then obtained from the intermediate mapping db. Refer Appendix B of 
checkSTRESS User’s Manual for more details. 

User can add / modify the Material properties in checkSTRESS through Edit Layout > Misc > 
Materials. 

Thermal Anchor Movement (TAM) 

Thermal Anchor Movement (TAM) values entered at User defined attributes HNX, HNY and HNX or 
TNX, TNY and TNZ (attributes need to be added and assigned for Model Object through CADMATIC 
COS and their values to be assigned in Plant Modeller using the option “Whole Pipeobject”) 
corresponding to Start or End of pipe run is transferred to checkSTRESS. In other words, TAM at 
starting of the Pipe run should be entered at HNX, HNY and HNZ of Pipe Run. On the other hand, 
TAM at the end of the Pipe run should be entered at TNX, TNY and TNZ of Pipe run. TAM values 
should be defined in “mm” for CADMATIC projects in SI units and in “Inch” for CADMATIC project in 
English units. 

For more clarity, consider the following example shown in figure below. Point A is connecting to a 
Tank. The TAM values corresponding to this point should be defined by selecting the Pipe run 1 and 
their values should be entered to attributes “HNX”, “HNY” and “HNZ”. Similarly, TAM values for Point 
B and C should be defined at attributes “TNX”, “TNY” and “TNZ” of the Pipe runs 2 and 3 respectively. 
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User can also add / modify the Thermal Anchor Movement values through Edit Layout option. i.e., 
Click Edit Layout then select “Anchor” and select “Edit data” through Layout > Edit. From the dialog 
box shown, click on “Specified Displacement” and enter the TAM values. 

User defined Equipment Nozzle Allowable Loads 

Equipment Nozzle Allowable Loads (forces and moments) provided by the equipment manufacturer or 
calculated using Applicable codes / Finite Element Methods can also be entered at Pipe runs as using 
the User Defined attributes HAL and TAL in global X, Y and Z directions at Start or End of Pipe run 
respectively in the format FX, FY, FZ, MX, MY and MZ as explained above for entering TAM values. 
Please note, the Equipment Nozzle Allowable Loads entered at HAL / TAL should be separated using 
“,” as shown in the figure above. In addition, the force values should be entered in “lb” for English 
units and in “N” for SI units. Similarly, the moment values should be entered in “ft-lb” for English units 
and in “Nm” for SI units. 

User can add / modify the Equipment Nozzle Allowable Load values through Edit Layout > Misc > 
User Allowable. 

The allowable thus defined are compared against calculated loads and shown / printed in Support 
Load Summary outputs (can be viewed / printed through “Show Summary” option). If the calculated 
loads exceed the allowable, they are highlighted in red.  
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5.0 CADMATIC to checkSTRESS Component Mapping 

The types of components available in Cadmatic are simulated as tabulated below in checkSTRESS.  

Cadmatic 
Component 
Description 

Constraints Geometric 
Types 

checkSTRESS 
Component 

Key Word in 
Neutral File 

If modeled as Piping Components 

Straight Pipes DM_GT_PIPE = TRUE  &  

Bend Angle = 0  
Pipe PI 

Free Bends DM_GT_PIPE = TRUE  & 

Bend Angle > 0  
Bend EL 

Flexible Curves DM_GT_FLXCURVE = TRUE 

 

Bend EL 

Flanges DM_GT_2P = True  & 

Primary Connection Code = 1 
or 3 (Connection Type is 
Flange) 

 

Rigid Element 
or Pipe with 

Flange 
FL 

Conc. Reducer DM_GT_2P = True  & 

2
nd

 Nominal Size > 0 
 

Reducer 
Concentric 

RD 

Straight Pipes DM_GT_2P = True  & 
Keyword in corporate 
catalogue of CADMATIC has 
“*PIPE*” e.g. Seamless 
Straight Pipe 

 
Pipe PI 

Flow meters, 
Adaptor, Flexible 
hoses, Caps 

DM_GT_2P = True 

 

Rigid Element RB 

Eccentric Reducer DM_GT_3PDIRFIX = True 

 

Reducer 
Eccentric 

ER 

Fixed Angle Curves DM_GT_FIXCURVE = True 

 

Bend EL 
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Cadmatic 
Component 
Description 

Constraints Geometric 
Types 

checkSTRESS 
Component 

Key Word in 
Neutral File 

Asymmetric Curves DM_GT_ASYMCURVE = True 

 

Bend EL 

U-Piece DM_GT_RETURN = True 

 

Bend EL 

Sliding Sockets,  

Unions 

DM_GT_PENETR = True 

 
Rigid Element RB 

If modeled as Standard Components 

Filter / Strainer DM_GT_FLXCURVE = TRUE 

 

Rigid Element RB 

Some Flanges DM_GT_2P = True  & 

Primary Connection Code = 1 
or 3 (Connection Type is 
Flange) 

 

Rigid Element 
or Pipe with 

Flange 
FL 

Straight Pipes DM_GT_2P = True  & 

Keyword in corporate 
catalogue of CADMATIC has 
“*PIPE*” eg Seamless Straight 
Pipe 

 Pipe PI 

Valves DM_GT_2P = True  & 

Keyword in corporate 
catalogue of CADMATIC has 
“*VALVE*” eg Ball check valve 
PVC 

 Valve 
VA 

 

Conc. Reducer DM_GT_2P = True  & 

2
nd

 Nominal Size > 0 
 

Reducer 
Concentric 

RD 

Flow meters, 
Adaptor, Flexible 
hoses 

DM_GT_2P = True 

 

Rigid Element RB 
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Cadmatic 
Component 
Description 

Constraints Geometric 
Types 

checkSTRESS 
Component 

Key Word in 
Neutral File 

Eccentric Reducer DM_GT_3PDIRFIX = True 

 

Reducer 
Eccentric 

ER 

Fixed Angle Valves DM_GT_FIXCURVE = True  & 

Keyword in corporate 
catalogue of CADMATIC has 
“*VALVE*” eg Pressured rig-
valve WDP 

 

Valve VA 

Straight Pipes DM_GT_FIXCURVE = True  & 

Keyword in corporate 
catalogue of CADMATIC has 
“*PIPE*” eg Seamless Straight 
Pipe 

 

Pipe PI 

Filter / Strainer DM_GT_FIXCURVE = True 

 

Rigid Element RB 

3 Way Valves DM_GT_TEE = True  & 

Keyword in corporate 
catalogue of CADMATIC has 
“*VALVE*” eg Three-way 
valve Wafer 

  

 

Three Rigid 
Elements or 
Three Pipes 

with 
Concentrated 

Mass 

3W 

Welding TEE DM_GT_TEE = True 

 

Pipes with 
Branch SIF 

(Welding TEE)  
TW 

4 Way Valves DM_GT_CROSS = True  & 

Keyword in corporate 
catalogue of CADMATIC has 
“*VALVE*” eg Four-way valve 
Wafer 

 

Four Rigid 
Elements or 

Four Pipes with 
Concentrated 

Mass 

4W 

Crosses DM_GT_CROSS = True 

 

Four Pipes with 
Branch SIF 

(Welding TEE) 
CR 

Lateral TEE DM_GT_LATERAL = True 

 

Pipes with 
Branch SIF 

(Welding TEE) 
TW 
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Cadmatic 
Component 
Description 

Constraints Geometric 
Types 

checkSTRESS 
Component 

Key Word in 
Neutral File 

Valves DM_GT_VALVE = True & 
Keyword in corporate 
catalogue of CADMATIC has 
“*VALVE*” eg Ball Valve    

Valve VA 

Reduced Valves DM_GT_VALVE = True & 

2
nd

 Nominal Size > 0 & Key 
word in corporate catalogue 
should not have “*valve*”. 

  

Reducer 
Concentric 

RD 

 

Flow meters, 
Pressure gauges, 
Manometers, 
Strainers 

DM_GT_VALVE = True 

 

Rigid Element RB 

Asymmetric Valves DM_GT_ASYMCURVE = True 

& Keyword in corporate 
catalogue of CADMATIC has 
“*VALVE*” eg Pressured rig-
valve WDP 

 

Valve VA 

Asymmetric Curves DM_GT_ASYMCURVE = True 

 

 

Bend EL 

U-Piece DM_GT_RETURN = True 

 

Bend 

 

 

EL 

Y-piece DM_GT_YPIECE = True 

      

Pipes with 
Branch SIF 

(Welding TEE) 

 

TW 

 

Sliding Sockets, 

Unions 

DM_GT_PENETR = True 

 
Rigid Element RB 
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Appendix A 
Response Spectrum 
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.Spectrums. 

A (uniform response) spectrum is a table of maximum response versus natural frequency for a 
specific excitation in single degree-of-freedom systems. You can input spectrums in three ways: 

1. Input spectrums directly into the model.  

2. Create a spectrum library and load spectrums from it.  

3. Input spectrums from a text file.  

When you use the first two methods, you may use menu Options > Spectrum command to set 
the different units for the X- and the Y-axes, and also choose the interpolation method. 

 

1. Input spectrums directly into the model 

Select Spectrums from the Misc menu. You are shown the List window for spectrums. Start 
typing pairs of values into it. The frequencies or periods do not have to be in any order; 
checkSTRESS will sort them later. You can input as many pairs of values as required. 
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2. Input spectrums from a text file 

This method involves creating a separate text file (in the format shown below) for each spectrum 
you want to input. The steps are given below. 

a) For each spectrum, on the first line, type the Name of the spectrum (up to 31 chars).  
On the second line, type units for Abscissa (X-axis) and Ordinate (Y-axis) axes, 
separated by a space.  

b) After these two lines, on each line, you can input a value pair. You can input as many 
of these value pair lines as required.  

c) Each spectrum should be saved to a separate text file. More than one spectrum 
should not be input in one text file as it cannot be read into checkSTRESS.  

d) Now, open the checkSTRESS model that needs these spectrums. Select Read 
Spectrum from the File menu, read all text files you created one after the other.  

 

The format of a spectrum text file is shown below. The spectrum that is read appears on the row 
where the yellow highlight is placed (under the Name column). You can use the Edit menu 
commands to insert an empty row or delete an existing spectrum. Ensure that no two spectrums 
share the same Name. checkSTRESS issues a warning should such occur. 

The spectrum text file should be in the following format: 

Name  (up to 31 characters 

Abscissa units Ordinate units 

Abscissa value1 Ordinate value1 

Abscissa value2 Ordinate value2 

. . 

. . 

. . 

Where  

Abscissa units 0 = Frequency (Hz) 

 1 = Period (Sec) 

 

Ordinate units 0 = Displacement (inch) 

 1 = Displacement (mm) 

 2 = Acceleration (in/sec2) 

 3 = Acceleration (mm/sec2) 

 4 = Acceleration (g’s) 
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Example file 

Test Spectrum 

0 2 

1 190 

2 220 

3 250 

4 1932 

5 1000 

6 1800 

. . 

. . 

Analysis note: 

While analyzing the response spectrum case, when a mode (frequency or period) falls outside the 
spectrum table, checkSTRESS issues a warning and uses the value corresponding to the closest 
frequency or period in the spectrum table (for example, checkSTRESS uses the value 
corresponding to the lowest frequency if the calculated frequency is lower than the lowest in the 
spectrum table or uses the value corresponding to the highest frequency if the calculated 
frequency is higher than the highest in the spectrum table). 

Once you are done inputting the different spectrums using any one of the three methods, you 
need to input the Spectrum load itself under the menu Loads > Spectrum in the Layout window.  
Details on inputting the Spectrum Load are provided earlier under the Loads menu. 

  

 


