
checkSTRESS™  

[for Intergraph's PDS] 

Introduction 

Under the “checkSTRESS” brand name, three products are available namely checkSTRESS (which 
generates only CAEPIPE input file), checkSTRESS II (which generates input files for both CAEPIPE and 
CAESAR II) and checkSTRESS Nuke (which generates input files for both CAEPIPE and PIPESTRESS). 

The following table lists the checkSTRESS products currently available for different 3D Plant Design 
systems. 

Sl. No. 3D Plant Design System Product Name Status 

1 PDMS checkSTRESS Available 

2 PDMS checkSTRESS II Available 

3 PDMS checkSTRESS Nuke Available 

4 CADMATIC checkSTRESS Available 

5 CADMATIC checkSTRESS II Available 

6 CADMATIC checkSTRESS Nuke Available 

7 PDS checkSTRESS Available 

8 PDS checkSTRESS II Available 

9 PDS checkSTRESS Nuke Available 

10 PCF checkSTRESS Available 

11 PCF checkSTRESS II Available 

12 PCF checkSTRESS Nuke Available 



This document describes the common features of checkSTRESS products currently available for PDS.  

Details related to the generation of CAESAR II input files by checkSTRESS II and PIPESTRESS input files 
by checkSTRESS Nuke are covered in a separate document titled “CIIModel.pdf” and “PSModel.pdf” 
respectively.  

Installing Program 

To install checkSTRESS on Windows OS, download the program from the website and execute the 
followings steps:  

1. Run the program "Setup.exe" and follow the instructions as they appear on the screen. 

2. Define an environmental variable with name “checkSTRESS_PDS” and the value as checkSTRESS 
Installation path. For example, set the value as “C:\Progra~1\checkSTRESSNukePDS (assuming 
checkSTRESS is installed in the directory “C:\Program Files\checkSTRESSNukePDS). 

Note: 

Use only short names while defining the Environmental variable and do not use ‘space’ or ‘special 
characters’ while defining the absolute path. 

How to use checkSTRESS? 

1. Select the Neutral file generated out of PDS.  

2. Specify the name of the output file. 

 



3. Select the piping code to be used for the analysis from the list box. 

4. Enter the Starting Node number and Node increment value in the appropriate field by selecting the 
option “Rearrange Node Numbers”. By default, the Starting Node number and Node increment are 
set to 10 and 10 respectively. 

5. By default, specific gravity of the fluid with respect to water is set to 1.0. User can modify the same 
through Edit Layout->Misc->Loads after launching checkSTRESS. 

6. Select Default Hanger to be used in checkSTRESS. This selected Hanger type will be used in 
checkSTRESS, only when the hanger type in checkSTRESS corresponding to Plant Design hanger 
is not specified /available in the Mapping DB. For details on transferring support from Plant Design 
to checkSTRESS, refer Appendix D of checkSTRESS User’s manual (checkSTRESS.pdf). 

7. Specify the Starting Node number (equivalent to minimum anchor node specified in the defaults.dat 
while extracting neutral file from PDS) for processing network. This is set to 901 by default. User can 
change this node number to match with the minimum anchor node specified in defaults.dat file. If the 
user is not sure about the node number, this can be left as 901 or 0. 

8. If the user wishes to eliminate those elements whose Nominal size (NS) is less than 50mm / 2in, 
then they can specify the value as “50/2” in the field “Process elements, if dia >”. In other words, the 
program will process only those elements whose nominal size is greater than the value specified in 
the field above. 

9. Specify how the Flange to be transferred to checkSTRESS.  

10. Specify how the 3 Way and 4 Way Valves are to be transferred to checkSTRESS.  

11. Choose the Global Vertical Axis for checkSTRESS from the Vertical Direction option. By default, “Z 
Axis” shall be taken as Global Vertical Axis. 

12. Press the button “Apply” to perform the Stress Check. 

  



13. Response Spectrum load data can be added through Edit Layout > Misc > Response Spectrum. 
Once added, the same can be applied in stress model through Edit Layout > Loads > Spectrum. 
Refer to Appendix A for details on adding Response Spectrum. 

14. Figure above shows the stress contour plot for the Sustained case. Expansion Stress plot can be 
seen by selecting the option “Expansion Stress” as shown in the figure right above. 

15. Designers can also plot and view the deflected shapes of the piping system under different loading 
conditions using the options available in the heading titled “Show” as shown in the figure on the right 
above. 

16. Designers can review the Nozzle / Anchor Qualification using the Option “Show Summary”. 

17. Hanger selected by checkSTRESS for “to be designed” hangers can be viewed by selecting the 
option “Show Hanger Report”. 

18. Designers can generate the CAEPIPE mod file using the option “Edit Layout > File > Save or Save 
as” for the Stress Department to carry out the detailed analysis including stress report preparation. 

19. Similarly, in order for the Stress Department to carry out the detailed analysis including stress report 
preparation, designers can generate CAESAR II input files in checkSTRESS II product and 
PIPESTRESS input files in checkSTRESS Nuke product respectively, by selecting the appropriate 
option from the dialog box as shown above. 

20. Using the option “Print”, designers can print the model data, code compliance for ten (10) high 

stress nodes, Nozzle / Anchor Qualification and Status of Resting Support / Limit Stops. 

Limitations 

The following are not transferred to checkSTRESS from PDS at this time. However user can add these in 
checkSTRESS through Edit Layout->Misc->Section 

1. Insulation density and Insulation thickness.  

2. Corrosion allowance and Mill tolerance. 

3. Lining Density and Lining Thickness.  

Procedure for extracting neutral files from PDS software 

This version of checkSTRESS is compatible with PDS versions released after May 1998 and upto PDS 
Version 8.xx. 

1. The present version of the checkSTRESS is supplied with the PDSTRESS.TBL and 
DEFAULTS.DAT. 

2. Replace the files PDSTRESS.TBL and DEFAULTS.DAT currently available in the directory   
PDS_Installed_Dir\win32app\INGR\pdstress\dat\ with the files PDSTRESS.TBL and   
DEFAULTS.DAT supplied with this version. 

3. Replace the PDS to STRESS Map path available in EXTERNAL FILES block of DEFAULTS.DAT as 
shown below with your current path of PDSTRESS.TBL (path in which PDSTRESS.TBL is available) 
by opening the file DEFAULTS.DAT. 



 EXTERNAL FILES 
 !Note: maximum 5 files, 40 characters maximum for each file 
 ! 1234567890123456789012345678901234567890 
 e:\win32app\ingr\pdstress\dat\pdstress.tbl     !PDS TO STRESS MAP (path is user defined) 
 ENDOF EXTERNAL FILES 

4. Refer to PDS Stress Interface User’s Guide for more details on how to modify the option files 
PDSTRESS.TBL and DEFAULTS.DAT for adding new components. 

5. For User-defined components, the PDS Administrator has to ensure that the corresponding details 
are added in PDSTRESS.TBL and DEFAULTS.DAT. For new component categories, the PDS 
Administrator has to send the details of such component categories to SST Systems / InfoPlant, so 
that SST Systems / InfoPlant could incorporate such details in the next release of the 
checkSTRESS. 

6. If the support detail is not specified at support location then it will be transferred as “Hanger” to 
checkSTRESS. Refer to Appendix D and Appendix E of checkSTRESS User’s Manual for details on 
transferring supports to checkSTRESS. 

7. Load the PDS software and click on "Stress Interface" and type in the name of the pipeline and 
name of the Neutral File in the form and click "Apply". This will create a Neutral File at the specified 
location. 

8. Thermal Anchor Movement (TAM) values extracted and written to stress neutral file through “LNOD” 
or “MLNOD” with type value as “MV” in global X, Y and Z directions can be transferred to 
checkSTRESS. TAM values should be defined in “mm” for PDS projects in SI units and in “Inch” for 
PDS project in English units. 

User can also add / modify the Thermal Anchor Movement values through Edit Layout option. i.e., 
Click Edit Layout then select “Anchor” and select “Edit data” through Layout > Edit. From the dialog 
box shown, click on “Specified Displacement” and enter the TAM values. 

9. Equipment Nozzle Allowable Loads (forces and moments) provided by the equipment manufacturer 
or calculated using Applicable codes / Finite Element Methods should be extracted and written  
through “LNOD” and “MLNOD” with type as “AL” in global X, Y and Z directions the format FX, FY, 
FZ, MX, MY and MZ. These values should be separated using “,”. Please note, the force values 
should be entered in “lb” for English units and in “N” for SI units. Similarly, the moment values 
should be entered in “ft-lb” for English units and in “Nm” for SI units. 

User can also add / modify the Equipment Nozzle Allowable Loads through Edit Layout > Misc > 
User Allowables.  

The allowables thus defined are compared against calculated loads and shown / printed in Support 
Load Summary outputs (can be viewed / printed through “Show Summary” option). If the calculated 
loads exceed the allowables, they are highlighted in red.  



 

 

 

 

 

 

 

 

 

 

 

Appendix A 
Response Spectrum 



.Spectrums. 

A (uniform response) spectrum is a table of maximum response versus natural frequency for a specific 
excitation in single degree-of-freedom systems. You can input spectrums in three ways: 

1. Input spectrums directly into the model.  

2. Create a spectrum library and load spectrums from it.  

3. Input spectrums from a text file.  

When you use the first two methods, you may use menu Options > Spectrum command to set the 
different units for the X- and the Y-axes, and also choose the interpolation method. 

 

1. Input spectrums directly into the model 

Select Spectrums from the Misc menu. You are shown the List window for spectrums. Start typing 
pairs of values into it. The frequencies or periods do not have to be in any order; checkSTRESS will 
sort them later. You can input as many pairs of values as required. 

 



2. Input spectrums from a text file 

This method involves creating a separate text file (in the format shown below) for each spectrum you 
want to input. The steps are given below. 

a) For each spectrum, on the first line, type the Name of the spectrum (up to 31 chars).  On 
the second line, type units for Abscissa (X-axis) and Ordinate (Y-axis) axes, separated by a 
space.  

b) After these two lines, on each line, you can input a value pair. You can input as many of 
these value pair lines as required.  

c) Each spectrum should be saved to a separate text file. More than one spectrum should not 
be input in one text file as it cannot be read into checkSTRESS.  

d) Now, open the checkSTRESS model that needs these spectrums. Select Read Spectrum 
from the File menu, read all text files you created one after the other.  

 

The format of a spectrum text file is shown below. The spectrum that is read appears on the row 
where the yellow highlight is placed (under the Name column). You can use the Edit menu commands 
to insert an empty row or delete an existing spectrum. Ensure that no two spectrums share the same 
Name. checkSTRESS issues a warning should such occur. 

The spectrum text file should be in the following format: 

Name  (up to 31 characters 

Abscissa units Ordinate units 

Abscissa value1 Ordinate value1 

Abscissa value2 Ordinate value2 

. . 

. . 

. . 

Where  

Abscissa units 0 = Frequency (Hz) 

 1 = Period (Sec) 

 

Ordinate units 0 = Displacement (inch) 

 1 = Displacement (mm) 

 2 = Acceleration (in/sec2) 

 3 = Acceleration (mm/sec2) 

 4 = Acceleration (g’s) 

 



Example file 

Test Spectrum 

0 2 

1 190 

2 220 

3 250 

4 1932 

5 1000 

6 1800 

. . 

. . 

Analysis note: 

While analyzing the response spectrum case, when a mode (frequency or period) falls outside the 
spectrum table, checkSTRESS issues a warning and uses the value corresponding to the closest 
frequency or period in the spectrum table (for example, checkSTRESS uses the value corresponding to 
the lowest frequency if the calculated frequency is lower than the lowest in the spectrum table or uses 
the value corresponding to the highest frequency if the calculated frequency is higher than the highest 
in the spectrum table). 

Once you are done inputting the different spectrums using any one of the three methods, you need to 
input the Spectrum load itself under the menu Loads > Spectrum in the Layout window.  Details on 
inputting the Spectrum Load are provided earlier under the Loads menu. 

  

 


